This question is not answered. Helpful answers available: 0. Correct answers available: 1.


Permlink Replies: 5 - Pages: 1 - Last Post: 25 May 24, 23:11 Last Post By: JeffTucker Threads: [ Previous | Next ]
PhilippeCharles

Posts: 116
Registered: 8-Dec-2012
Possible major regression in v34.3 - Photo legend are gone!
Posted: 25 May 24, 15:26
 
  Click to reply to this thread Reply
It looks like the legend of a photo is now gone when generating an existing album with v34.3. I am using jAlbum on Windows 10, with the "Projector" skin v4.3.

Steps:
  • I have created and build an album this morning with version v34.1, everything was fine.
  • I noticed the release of the new version v34.3 and download it.
  • Uninstalled (properlly) the v34.1 and install v34.3.
  • Build the same album : the legend on all photos were gone!
  • Uninstall v34.3 and install again v34.1.
  • Build the same album : everything is fine again.

http://www.philippecharles.jalbum.net/2024 Beauval

What puzzles me is that the version v34.3 was released already 5 weeks ago; so this must not be a general issue, otherwise people would have been reporting this? Could this be related to the skin instead (although no newer version of Projector)?

Edit: replaced wording "title" by "legend".

Edited by: PhilippeCharles on 25 May 2024, 15:27

Edited by: PhilippeCharles on 25 May 2024, 18:55
JeffTucker

Posts: 8,117
Registered: 31-Jan-2006
Re: Possible major regression in v34.3 - Photo title are gone!
Posted: 25 May 24, 16:06   in response to: PhilippeCharles in response to: PhilippeCharles
Helpful
  Click to reply to this thread Reply
I've made a test album with your project settings, and the titles and comments all appear on the lightbox images, as expected.

It appears that you're not entering jAlbum titles for the images, but are using the IPTC information. As an additional test, I used some images that have an IPTC Object Name, but no manually-entered jAlbum title, and those work properly, as well.

I downloaded one of the slide images from your album, which still has all of its metadata, used it in a project, and found that it has no title, either entered in jAlbum or contained in other metadata fields. It does have a comment, however, and that is being displayed, as expected.

In short, I can't replicate this problem, using jAlbum 34.3.2 and Projector 4.3.
PhilippeCharles

Posts: 116
Registered: 8-Dec-2012
Re: Possible major regression in v34.3 - Photo legend are gone!
Posted: 25 May 24, 18:54   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Hello Jeff,
Thank you for your quick feedback; I need to be a bit more explicit to describe the issue:
  • It's a question of using the right wording: you are right, the problem is not about the image "title" but about the image "legend" => I corrected it above.
  • In the skin parameter settings "Lightbox" > "Main Image" > "Legend", I am indeed using the comment data from the IPTC data of the image as a legend being displayed under the image.

Nevertheless, the problem is that a project being made with v34.1 with legend under all images, result in images being displayed without legend when the same project is build with v34.3.
JeffTucker

Posts: 8,117
Registered: 31-Jan-2006
Re: Possible major regression in v34.3 - Photo legend are gone!
Posted: 25 May 24, 21:13   in response to: PhilippeCharles in response to: PhilippeCharles
Helpful
  Click to reply to this thread Reply
I think I know what's happening, because of a change in the metadata handling in jAlbum 34.2.

First, open the image directory - Tools > Open directories > Image directory, or just CTRL-SHIFT-I - and attach just one of the images from the first folder. If it's too large, please upload it separately and give us a link to it.

Next, as a quick test of my theory, open the image directory, then delete Les Maitres des Airs\.jalbum\comments.properties. Close the project and open it again. Now make the album again. Do the lightbox captions now appear correctly?

(ETA: David and RobM, here's what I'm thinking: he's got a comments.properties file in each folder, with an entry for each image, but they're all empty. So, when priority is given to the jAlbum comment, it's grabbing that empty string, and ignoring the IPTC Caption/Abstract. If I'm right, this is something the core could perhaps handle better.

ETA: And with a little further testing, I've confirmed this theory. In short, once an empty jAlbum comment exists, you're stuck with the empty value unless you delete the entry in the file. Only then can the metadata value "bubble up.")
RobM

Posts: 3,743
Registered: 4-Aug-2006
Re: Possible major regression in v34.3 - Photo legend are gone!
Posted: 25 May 24, 22:26   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
ETA: And with a little further testing, I've confirmed this theory. In short, once an empty jAlbum comment exists, you're stuck with the empty value unless you delete the entry in the file. Only then can the metadata value "bubble up.")
Just repeated your test and get the same result. Now what was that quote, ah yes 'The UI checkboxes now corresponds to how things work in reality' ;)
JeffTucker

Posts: 8,117
Registered: 31-Jan-2006
Re: Possible major regression in v34.3 - Photo legend are gone!
Posted: 25 May 24, 23:11   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
RobM wrote:
Now what was that quote, ah yes 'The UI checkboxes now corresponds to how things work in reality' ;)

Well, yes, but a jAlbum comment that's void, null, or empty should be regarded as "no jAlbum comment," and it should start looking to the second, third, etc., choices.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums