This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 11 - Pages: 1 - Last Post: 16 May 24, 15:50 Last Post By: JeffTucker Threads: [ Previous | Next ]
hanso

Posts: 97
Registered: 16-Apr-2008
Update Jalbum Bridge Wordpress plugin please
Posted: 9 May 24, 15:44
 
  Click to reply to this thread Reply
From the Wordpress site:

This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress

Last update September 29, 2022

It needs an update! A valuable asset for my jalbums!
Laza

Posts: 1,793
Registered: 6-Sep-2005
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 13 May 24, 18:35   in response to: hanso in response to: hanso
 
  Click to reply to this thread Reply
It's tested up to 6.0.8 - what 3 major versions do they mean? The only thing I need to update is the tested version number, otherwise, it's fully compatible with the latest version. What a janitor-mentality...
JeffTucker

Posts: 8,196
Registered: 31-Jan-2006
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 13 May 24, 18:56   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
It's tested up to 6.0.8 - what 3 major versions do they mean?

Offhand, I'd say they mean WP 3, WP 4, and WP 5. So, the "official" version is actually four major versions behind.
JeffTucker

Posts: 8,196
Registered: 31-Jan-2006
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 13 May 24, 19:21   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
What a janitor-mentality...

No different from what jAlbum does in the skin repository when a skin hasn't been touched in over two years. "This may not work."
Laza

Posts: 1,793
Registered: 6-Sep-2005
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 14 May 24, 10:02   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
So, the "official" version is actually four major versions behind.
??? The plugin is stated to be compatible with WP 6.0.8, and the latest WP is 6.5.3. How can this be 3 major versions?

No different from what jAlbum does in the skin repository when a skin hasn't been touched in over two years.
Yes, point taken. But we all know the skins we retire do not meet today's standards. A WP plugin can be as simple as counting the visitors or placing a link - nothing related to security or growing outdated. WP threatens users for no reason.
JeffTucker

Posts: 8,196
Registered: 31-Jan-2006
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 14 May 24, 11:56   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
??? The plugin is stated to be compatible with WP 6.0.8, and the latest WP is 6.5.3. How can this be 3 major versions?

Sorry, I was conflating the WP versions with the Bridge versions. That means that it's actually 5 major versions. In the WP numbering scheme, the first decimal numbers are "major" versions, and are even given names (like macOS). So, 6.1, 6.2, 6.3, 6.4, and 6.5 are all "major" versions.

I have no idea what the whole numbers are. Perhaps "life-altering" versions?

But we all know the skins we retire do not meet today's standards. A WP plugin can be as simple as counting the visitors or placing a link - nothing related to security or growing outdated. WP threatens users for no reason.

I'm not talking about skins that get moved to the legacy bin. jAlbum sticks a red warning on any skin, even one in the "active" category, after two years.

But ultimately, it's WP's app and plugins are being distributed on WP's website, so they can set whatever rules they like. No one is being forced to write plugins.

And frankly, when it comes to the skin repository, jAlbum allows obsolete stuff to hang around far, far too long. IMO, this damages the brand.
Laza

Posts: 1,793
Registered: 6-Sep-2005
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 14 May 24, 15:58   in response to: hanso in response to: hanso
 
  Click to reply to this thread Reply
Hanso, do you experience any problems with the plugin? I only see this warning message: "Warning: this plugin has not been tested with your current version of WordPress." - but nothing else.

At the moment the script that updated the plugin is broken. I will have to relearn the GIT update process. The only change is "Tested up to: 6.5.3" - a very unnecessary update in my opinion.
RobM

Posts: 3,870
Registered: 4-Aug-2006
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 14 May 24, 16:20   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza

Posts: 1,793
Registered: 6-Sep-2005
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 14 May 24, 17:20   in response to: hanso in response to: hanso
 
  Click to reply to this thread Reply
I could update the plugin once I realized it's not a GIT but an SVN repo. :)
JeffTucker

Posts: 8,196
Registered: 31-Jan-2006
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 14 May 24, 17:24   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
I could update the plugin once I realized it's not a GIT but an SVN repo. :)

Could have been worse. They could be using the DVCS - David Version Control System. Totally inscrutable.
hanso

Posts: 97
Registered: 16-Apr-2008
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 16 May 24, 15:48   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
I have no problems with the plugin. I use it with much pleasure!

Wordpress starts to warn about not being updated and I agree here.Not updated will scare of new users (security is a real concern for Wordpress users, as most used web CMS it is a target) as a not maintained plugin is a risk.

Wordpress will remove the plugin in the near future if it is not updated. The same happened several years ago.

I would be nice just to bump version numbers once in a while and upload a new build.
Even if no new features are added, there might be underlying library/framework/whatever updates.

And I see that just happened! Thanks!
JeffTucker

Posts: 8,196
Registered: 31-Jan-2006
Re: Update Jalbum Bridge Wordpress plugin please
Posted: 16 May 24, 15:50   in response to: hanso in response to: hanso
 
  Click to reply to this thread Reply
Updated WP version compatibility posted:

https://wordpress.org/plugins/jalbum-bridge/
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums