This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 16 - Pages: 2 [ 1 2 | Next ] - Last Post: 31 Jul 23, 19:04 Last Post By: JeffTucker Threads: [ Previous | Next ]
yoschi24

Posts: 9
Registered: 30-Jul-2019
keine Umlaute oder Sonderzeichen
Posted: 30 Jul 23, 14:49
 
  Click to reply to this thread Reply
hallo an alle,
album upload erledigt, aber fotos/ordner/unterordner mit umlaute im namen
wurden vom upload ausgeschlossen

welche einstellungen muß ich vornehmen?
anbei jetzige einstellungen 88591 ohne utf8
gruß yoschi

Edited by: $1180812 on 30 Jul 2023, 14:51
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: keine Umlaute oder Sonderzeichen
Posted: 30 Jul 23, 14:54   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
Attachment utf8.png (17.2 KB)
Use UTF-8. See screenshot - two settings.
yoschi24

Posts: 9
Registered: 30-Jul-2019
Re: keine Umlaute oder Sonderzeichen
Posted: 30 Jul 23, 15:11   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
wow! wenn das keine schnelle hilfe ist...
herzlichen dank
gruß yoschi
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: keine Umlaute oder Sonderzeichen
Posted: 30 Jul 23, 15:21   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
We like the easy ones.
yoschi24

Posts: 9
Registered: 30-Jul-2019
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 06:34   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
hallo jeff, aus gegebenem Anlaß melde ich mich noch einmal…

habe gestern die zwei mal utf-8 einstellungen vorgenommen
und leider feststellen müssen: der Fehler mit den nicht gezeigten Fotos
besteht weiterhin
deswegen meine frage: muß ich sonstwo etwas eintragen, und wenn ja,
wo und was?
habe vorübergehend in der gesamten fotogalerie alle äöü mit ae, oe und ue
ersetzt
gruß yoschi - https://erfolg-ohne-ende.de

Edited by: JeffTucker on 31 Jul 2023, 07:32, to make link clickable
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 13:27   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
Attachment working.png (360.8 KB)
Attachment nametitle.png (354.6 KB)
Your settings are correct, and the coding in the index pages is also correct. See the screenshot of my little test album, using your settings (with a few of my images) - working.png.

That leaves only two possible causes of the problem:

1. Make sure you are using the jAlbum uploader, instead of a third-party FTP program. Some FTP programs "helpfully" offer to convert things to ASCII.

2. Make sure your web host supports diacritical characters in directory and file names. Most do, but some do not.

If your web host does not support diacriticals in directory (folder) names, you will need to use simple names for the raw folders, and then use a jAlbum title the provide the readable text. See nametitle.png.
yoschi24

Posts: 9
Registered: 30-Jul-2019
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 13:32   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
oha! danke! werde bei STRATO nachschauen was dort eingestellt ist..

im übrigen, beim upload verwende ich ausschließlich jalbum
liebe grüß yoschi
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 13:35   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
yoschi24 wrote:
im übrigen, beim upload verwende ich ausschließlich jalbum

Good. That narrows it down to only one possible cause: the web host.

My little test album. Strange location for a graduation party - Death Valley!

(demo album removed)

Edited by: JeffTucker on 31 Jul 2023, 09:07 to remove demo album link
yoschi24

Posts: 9
Registered: 30-Jul-2019
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 14:49   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
nun wird das "ä" angezeigt, aber im ordner werden keine fotos angezeigt...
ich verstehe gar nicht mehr
  • siehe in meiner galerie unter "schulleben"

Edited by: yoschi24 on 31 Jul 2023, 15:06
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 14:53   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
Attachment name.png (60.3 KB)
Attachment title.png (79.7 KB)
Don't give up! Your captions are still OK. It's only the "raw" names of the folders that are creating a problem.

As I said, above, you can use simple names for the raw folder, like anschlussfeier. Then just enter a jAlbum title for that folder of Anschlußfeier. The album will work on your web host, and will look fine to your site visitors. The album will show the title instead of the raw folder name. But internally, the folder name will be anschlussfeier, which will keep your web host happy.

ETA: See screenshots!
AndreWolff

Posts: 1,292
Registered: 14-Dec-2007
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 14:59   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
I use the Strato server already 20 years without problems and I use the jAlbum uploader.
See here an album with special characters:

https://andrewolff.nl/FotoSerie/Scandinavie/Noorwegen_2005/4_Vagan/index.htm
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 15:15   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
yoschi24 wrote:
nun wird das "ä" angezeigt, aber im ordner werden keine fotos angezeigt...
ich verstehe gar nicht mehr
  • siehe in meiner galerie unter "schulleben"

This is exactly the same problem. Change the folder name to 7brust2008a. Make the folder title 7b Rust 2008 ä.

If you always use simple names for folders and files, you'll never have problems. The titles can be as fancy as you like!
davidekholm

Posts: 3,432
Registered: 18-Oct-2002
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 16:47   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Try "Album Settings - Advanced - Naming - Compatibility - Remove diacritics", this makes jAlbum replace "ä" with "a" etc in GENERATED file names. It puts the original version as title so you hardly notice any change.

If you really want diacritical marks in the characters of file- and folder names, please give me access to your server and I'll test.
yoschi24

Posts: 9
Registered: 30-Jul-2019
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 17:13   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
hallo david,
zugangsdaten sind per mail an dich unterwegs
und danke...
yoschi24

Posts: 9
Registered: 30-Jul-2019
Re: keine Umlaute oder Sonderzeichen
Posted: 31 Jul 23, 18:30   in response to: yoschi24 in response to: yoschi24
 
  Click to reply to this thread Reply
BINGOOOO

so liebe freunde! fehler gefunden und alles erledigt!
danke an alle die mir geholfen haben!
aber ganz besonders an jeff und david

es war die einstellung unter upload ERWEITERT!
dort fehlte das häckchen für UTF-8!
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums