This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 14 - Pages: 1 - Last Post: 1 Jun 23, 13:30 Last Post By: davidekholm Threads: [ Previous | Next ]
clusterwood

Posts: 3
Registered: 26-Jun-2009
No preview
Posted: 29 May 23, 18:08
 
  Click to reply to this thread Reply
Hej,

in V30.0.1 on W10 and W11 the preview button doesn't work anymore.

Thanks for reading,
Lutz
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: No preview
Posted: 29 May 23, 18:54   in response to: clusterwood in response to: clusterwood
 
  Click to reply to this thread Reply
No problem for me - external/integrated/windowed browser, with/without embedded server, makes no difference. Win11.

ETA: Are you seeing any error messages in the console? Is there a "warning" triangle at lower right?
phil44

Posts: 51
Registered: 18-Jun-2010
Re: No preview
Posted: 29 May 23, 22:56   in response to: clusterwood in response to: clusterwood
 
  Click to reply to this thread Reply
On my installation (V31.0.1 / W10), the Preview button appears only if Preferences / Preview / Type is set to "Integrated".

I usually set this setting to "External browser", and it is a little bit annoying to not have this button, so I have to dive into the menus to find again the command to open the preview in the external browser. IMHO, it would be better if the button was visible.
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: No preview
Posted: 29 May 23, 23:06   in response to: phil44 in response to: phil44
 
  Click to reply to this thread Reply
phil44 wrote:
On my installation (V31.0.1 / W10), the Preview button appears only if Preferences / Preview / Type is set to "Integrated".

I believe that's always been true. The big buttons at the top indicate what will be shown within the jAlbum window, and the preview is shown there only when using the integrated browser.

The preview button to the right of the Make album button is always present. And, of course, F12 always works.

Returning to the original post, I know this is a stupid question, but you are making the album before trying to preview it, right?
clusterwood

Posts: 3
Registered: 26-Jun-2009
Re: No preview
Posted: 30 May 23, 08:55   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Yes, that's right: F12 works and so does the preview button right of "Make Album". Only the "Preview" button in the menu bar shows no reaction. If I switch back to an older version, it works again. I have tried this on two different computers with the same result.
phil44

Posts: 51
Registered: 18-Jun-2010
Re: No preview
Posted: 30 May 23, 09:46   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
The preview button to the right of the Make album button is always present...

You're right! How can I have missed this one?
davidekholm

Posts: 3,432
Registered: 18-Oct-2002
Re: No preview
Posted: 30 May 23, 10:05   in response to: clusterwood in response to: clusterwood
 
  Click to reply to this thread Reply
clusterwood wrote:
Yes, that's right: F12 works and so does the preview button right of "Make Album". Only the "Preview" button in the menu bar shows no reaction. If I switch back to an older version, it works again. I have tried this on two different computers with the same result.

What "Preview button" in the menu bar are you referring to? Do you mean the Album->Preview menu item? That one works here.
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: No preview
Posted: 30 May 23, 12:38   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
Attachment ss010893.png (80.0 KB)
This one - see screenshot. Confirmed. Windows and macOS.

Most of us don't use the integrated browser, and most of us just habitually hit F12, so that's why no one noticed this problem.

Console dump:
Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException: Cannot invoke "java.awt.event.ActionEvent.getModifiers()" because "e" is null
	at se.datadosen.jalbum.JAlbumFrame$JAlbumFrameActions$26.actionPerformed(JAlbumFrame.java:4043)
	at se.datadosen.explorer.JAlbumExplorer$8.actionPerformed(JAlbumExplorer.java:476)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at java.desktop/javax.swing.JToggleButton$ToggleButtonModel.setPressed(Unknown Source)
	at java.desktop/javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.desktop/java.awt.Component.processMouseEvent(Unknown Source)
	at java.desktop/javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.desktop/java.awt.Component.processEvent(Unknown Source)
	at java.desktop/java.awt.Container.processEvent(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.Component.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue$5.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$5.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.run(Unknown Source)
davidekholm

Posts: 3,432
Registered: 18-Oct-2002
Re: No preview
Posted: 30 May 23, 15:06   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Thanks for reporting. I'll have this fixed in the next release
clusterwood

Posts: 3
Registered: 26-Jun-2009
Re: No preview
Posted: 30 May 23, 23:46   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
Many thanks.
davidekholm

Posts: 3,432
Registered: 18-Oct-2002
Re: No preview
Posted: 31 May 23, 12:26   in response to: clusterwood in response to: clusterwood
 
  Click to reply to this thread Reply
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: No preview
Posted: 31 May 23, 14:06   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
That fixes the bug. :)

But check your email re: the new installer.
davidekholm

Posts: 3,432
Registered: 18-Oct-2002
Re: No preview
Posted: 1 Jun 23, 13:23   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
That fixes the bug. :)

But check your email re: the new installer.


I believe the installation location changed when we changed theme for the quick fix I made available at https://jalbum.net/download/jAlbum-install.exe. Other issues arose as well due to this:
  • The option to choose installation folder went away
  • The "Start jAlbum after install" checkbox wasn't respected

For now, I'll revert to the classic theme again.
JeffTucker

Posts: 7,994
Registered: 31-Jan-2006
Re: No preview
Posted: 1 Jun 23, 13:28   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
The "new theme" looks good. It would be nice if you could persuade it to be better behaved. ;)

BTW, one other delightful little quirk of Windows if you end up with two versions of the app installed in two different places: if you use the Windows utility to remove the unwanted version, that also breaks the file association with .jap and .jaskin files, even though the newest app version is still on the PC. You have to run the installer again to get those "hooked up" properly. It's a thrill a minute.
davidekholm

Posts: 3,432
Registered: 18-Oct-2002
Re: No preview
Posted: 1 Jun 23, 13:30   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
I basically like the more modern look of the new theme, but the progress bar is REALLY hard to see and some texts have not been translated (to Swedish at least). This, together with the other theme related issues makes me shy away from it for now.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums