This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 7 - Pages: 1 - Last Post: 1 Jan 22, 21:53 Last Post By: linuxrog
linuxrog

Posts: 259
Registered: 21-Nov-2008
Upload addressing error
Posted: 30 Nov 21, 20:42
 
  Click to reply to this thread Reply
Attachment url.error.png (38.2 KB)
My hosting service changed the ip address for my site. I've adjusted that, with some difficulty, with Tools > Upload Manger. Problem: the link, appearing at the bottom of the upload window, is now incorrect. See attachment (host/url blanked). The correct path is shown at the top is of the upload dialog:
[url]/public_html/pics/ 

And, files updates are uploaded to the correct folder. However, the link at the bottom,
[url]/rockies/ 

Is incorrect. It should be
[url]/pics/rockies/ 

This causes a 404 error condition in my browser - at the completion of the upload, my browser is automagically opened and the 404 error appears. Of course the location is unreachable because the
/pics
sub-folder is missing.

How to fix? Bug? If so, move as appropriate.

Thanks for looking into this.

/Roger
RobM

Posts: 4,186
Registered: 4-Aug-2006
Re: Upload addressing error
Posted: 30 Nov 21, 21:03   in response to: linuxrog in response to: linuxrog
 
  Click to reply to this thread Reply
Is the entry under Settings>General>Address?

Edited by: RobM on 30 Nov 2021, 20:04
JeffTucker

Posts: 8,168
Registered: 31-Jan-2006
Re: Upload addressing error
Posted: 30 Nov 21, 22:06   in response to: linuxrog in response to: linuxrog
 
  Click to reply to this thread Reply
After choosing Tools > Upload Manager, and connecting to your host, navigate to public_html/pics, then click the Mark as web root icon.
linuxrog

Posts: 259
Registered: 21-Nov-2008
Re: Upload addressing error
Posted: 1 Dec 21, 20:43   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
No dice on that. Now the Address at the bottom of the Upload dialog is blank and a 404 error is still being thrown. The upload does work.

Out of curiosity I clicked the Advanced (Wrench) icon. Nothing happens.
JeffTucker

Posts: 8,168
Registered: 31-Jan-2006
Re: Upload addressing error
Posted: 1 Dec 21, 22:45   in response to: linuxrog in response to: linuxrog
 
  Click to reply to this thread Reply
linuxrog wrote:
Now the Address at the bottom of the Upload dialog is blank....

Never seen that - I didn't think it was possible.
linuxrog

Posts: 259
Registered: 21-Nov-2008
Re: Upload addressing error
Posted: 1 Dec 21, 23:08   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Bug? I looked again, including to see if there was black text there and it was therefore invisible. Not. The problem still xists.
davidekholm

Posts: 4,061
Registered: 18-Oct-2002
Re: Upload addressing error
Posted: 2 Dec 21, 17:18   in response to: linuxrog in response to: linuxrog
 
  Click to reply to this thread Reply
linuxrog wrote:
Bug? I looked again, including to see if there was black text there and it was therefore invisible. Not. The problem still xists.

An address is only printed if you've selected a folder within the folder you've marked as web root.

Any error printed to jAlbum's system console window?
If not, perhaps you can email me (david_at_jalbum_dot_net) your "accounts.xml" file for inspection (hit CTRL+SHIFT+C to locate it). It does contain your passwords so I understand if you choose not to
linuxrog

Posts: 259
Registered: 21-Nov-2008
Re: Upload addressing error
Posted: 1 Jan 22, 21:53   in response to: linuxrog in response to: linuxrog
 
  Click to reply to this thread Reply
Thanks for the help.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums