This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 2 - Pages: 1 - Last Post: 13 Aug 21, 19:23 Last Post By: JeffTucker Threads: [ Previous | Next ]
JeffTucker

Posts: 8,207
Registered: 31-Jan-2006
HiDPI under program control sometimes not honored
Posted: 13 Aug 21, 18:17
 
  Click to reply to this thread Reply
Just ran into another problem in the same vein as one that RobM encountered recently.

Working on some new skin versions. You can make an album with regular thumbnails, but the skin really wants HiDPI, so it puts up a confirm dialog, asking if you want to change the setting. If you say YES, it invokes engine.setHiDPIThumbs(true). This happens in init.bsh.

If the album has never been made before, that works. But if the album was previously made with regular thumbnails, that change doesn't register as something that needs new thumbnail images, and they don't get recreated. It takes a forced remake (which is nasty, because that also reprocesses all the videos). Not even saving, closing, and reopening will cause new thumbnails to be generated.

jAlbum 25b2
JeffTucker

Posts: 8,207
Registered: 31-Jan-2006
Re: HiDPI under program control sometimes not honored
Posted: 13 Aug 21, 19:00   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Put this on "hold" - I'm now getting inconsistent results, and need to investigate further.
JeffTucker

Posts: 8,207
Registered: 31-Jan-2006
Re: HiDPI under program control sometimes not honored
Posted: 13 Aug 21, 19:23   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Mystery solved, I think. This is working correctly. But what isn't working correctly is this:

https://jalbum.net/forum/thread.jspa?threadID=57627
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums