This question is answered. Helpful answers available: 0. Correct answers available: 1.


Permlink Replies: 9 - Pages: 1 - Last Post: 31 Jan 21, 18:19 Last Post By: JohnnyBalubas
JohnnyBalubas

Posts: 61
Registered: 3-May-2017
What am I doing wrong?
Posted: 31 Jan 21, 16:31
 
  Click to reply to this thread Reply
Attachment Clip_3.jpg (193.1 KB)
Attachment Clip_2.jpg (128.7 KB)
Attachment Clip_1.jpg (135.2 KB)
Am I doing something wrong or is there yet another bug in photoblogger?

If i change different setups within photoblogger, like changing to "dark" from "simple", it seems to mess up everything. To get it right I have the change skin completely and then back again and even then it doesn't always work. See attached pics.
Clip 3 is what it should look like, but i'm not even sure about that unless the default folder image have been changed lately. Before it was a yellow folder but that is perhaps a design change?
I have tried to clear cache and also removed the created files and rendered new ones but that dont work either.
Could it be so that some settings isn't stored with the skin since it works with a skin change sometimes?
JeffTucker

Posts: 7,635
Registered: 31-Jan-2006
Re: What am I doing wrong?
Posted: 31 Jan 21, 16:39   in response to: JohnnyBalubas in response to: JohnnyBalubas
 
  Click to reply to this thread Reply
Not sure what's going on, but if you change to another skin, then change back to Photoblogger, the skin is reloaded with its defaults. Any changes you have made from the default settings are jettisoned. You can rescue the situation if you close the project without saving, then reopen it - that will bring back the last saved settings.

This is not a Photoblogger thing - this is how the jAlbum core handles skin changes.
JohnnyBalubas

Posts: 61
Registered: 3-May-2017
Re: What am I doing wrong?
Posted: 31 Jan 21, 16:44   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
But the thing is that i get different results when i change back and forward between photoblogger and other skins.
Laza

Posts: 2,840
Registered: 6-Sep-2005
Re: What am I doing wrong?
Posted: 31 Jan 21, 16:57   in response to: JohnnyBalubas in response to: JohnnyBalubas
Helpful
  Click to reply to this thread Reply
Attachment folder.svg (1.2 KB)
Yes, I have changed the folder icon to this hollow one which fits better with most of the styles, although I admit this doesn't look good on white background. I will provide 2 or three different design for the next release. Until then you can replace the new one with the old (attached) in the skin directory's "res" subfolder.
JohnnyBalubas

Posts: 61
Registered: 3-May-2017
Re: What am I doing wrong?
Posted: 31 Jan 21, 16:59   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
I will do that. Thank you!
JohnnyBalubas

Posts: 61
Registered: 3-May-2017
Re: What am I doing wrong?
Posted: 31 Jan 21, 17:33   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
I replaced the folder image with the new and it still creates the pages with the old image. How is that possible?
Before you ask: Jalbum was closed when I replaced the file. And i have changed from photoblogger to tiger and then back again after I started Jalbum. But no effect.
I have also double checked my installation directory to see that i didn't miss the exchange of the file in photobloggers res directory.
JeffTucker

Posts: 7,635
Registered: 31-Jan-2006
Re: What am I doing wrong?
Posted: 31 Jan 21, 17:37   in response to: JohnnyBalubas in response to: JohnnyBalubas
Helpful
  Click to reply to this thread Reply
You're probably making the file change in the wrong copy of the skin. Launch jAlbum. Choose Photoblogger. Then, Tools, Open directories, Skin directory.

jAlbum plants skin updates in a different location from where the bundled skins are stored.

And, as always, CTRL-F5.
JohnnyBalubas

Posts: 61
Registered: 3-May-2017
Re: What am I doing wrong?
Posted: 31 Jan 21, 17:52   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
That was correct! I didn't know that and what's the point of have different installation directorys - a bit confucious I think.
Anyway thanks a lot.....again. Now I'm back on track again.
JeffTucker

Posts: 7,635
Registered: 31-Jan-2006
Re: What am I doing wrong?
Posted: 31 Jan 21, 18:16   in response to: JohnnyBalubas in response to: JohnnyBalubas
 
  Click to reply to this thread Reply
Bundled skins need to be with the program - in Windows, that's C:\Program Files\jAlbum. But when you install other skins, or install an update to a skin, Windows can run into permission problems when you try to alter the program files. So, those installs have to go elsewhere.
JohnnyBalubas

Posts: 61
Registered: 3-May-2017
Re: What am I doing wrong?
Posted: 31 Jan 21, 18:19   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Ok, that seems reasonable.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums