Permlink Replies: 5 - Pages: 1 - Last Post: 15-Jul-2020 19:32 Last Post By: Laza Threads: [ Previous | Next ]
Laza

Posts: 2,365
Registered: 6-Sep-2005
Version 2.0 released for Block Editor
Posted: 16-Jun-2020 14:22
  Click to reply to this thread Reply
Yesterday I've released the new Wordpress jAlbum bridge plugin, v2.0

This version is made for the new Block Editor (Gutenberg). Many parts of the plugin has been rewritten from ground. As the old (TinyMCE) version was based on "short codes", and the new on "blocks", it can't automatically convert old projectors into blocks. These old projectors will still work on the production site, but no settings dialog is available. You can use them, but have to edit the short codes - the settings - manually.

Change log:

Version 2.0.5
  • Fixing broken projector with absolute album URL's

Version 2.0.4
  • Fixing range slider numeric input field is too narrow to accommodate 5-digit numbers on WP 5.0 - 5.2
  • Fixing link to album is broken in certain cases
  • Fixing wrong transitions in "coverflow" using random order
  • Fixing wrong ordering criteria and direction with certain ordering types

Version 2.0.3
  • Fixed broken links to album
  • Short code (old plugin) projectors had no links, even though originally the links were enabled by default

Version 2.0.2
  • Range slider numeric input field too narrow to accommodate 5-digit numbers
  • Aspect ratio combo box shows 10:1 when you chose 8:1, 6:1, 16:9, 6:5, 4:3, 9:16

Version 2.0.1
  • Projector is broken when using "Title + link" as title caption. (In the post, but not in Editor)
  • Removed spinner arrows from range control inputs on FireFox
  • More than 3 keywords error on WordPress 5.0 - 5.2
  • "blockEditor" missing error on WordPress 5.0 - 5.2
  • Lighter link icon with "Title + link" captions
  • Better animation for the first frame in "Slide" transition
  • Immediate rendering of hidden faces in "Carousel" transition
  • Displaying projectors added with previous versions. Still no TinyMCE preferences dialog is provided, so you can edit the short codes manually or re-add them as Blocks.

Version 2.0.0
  • Extensive rework of the plugin for Wordpress' new Block Editor (a.k.a Gutenberg)
  • New transition type: "Zoom"
  • New ordering criteria: "File size", added new ascending/descending orders
  • Block can be "wide width" and "full width" too
  • Better - flicker-free - transitions on the 3D projectors
  • The plugin is now translatable
  • Better database compatibility with the upgraded skins

https://wordpress.org/plugins/jalbum-bridge/

Edited by: Laza on 16-Jun-2020 16:41

Edited by: Laza on 17-Jun-2020 10:43

Edited by: Laza on 17-Jun-2020 13:12
FabioM

Posts: 24
Registered: 27-Dec-2008
Re: Version 2.0 released for Block Editor
Posted: 17-Jun-2020 09:11   in response to: Laza in response to: Laza
  Click to reply to this thread Reply
I used the old jAlbum Bridge in WP for many years, now I just did the upgrade to new one but I do not see the button of the new plugin.
Laza

Posts: 2,365
Registered: 6-Sep-2005
Re: Version 2.0 released for Block Editor
Posted: 17-Jun-2020 10:14   in response to: FabioM in response to: FabioM
  Click to reply to this thread Reply
The button works the normal way in the Block Editor:


If you don't use the (default) Block Editor you either resort to short codes (I will write up a tutorial) or go back to the TinyMCE compatible plugin (1.x)
hanso

Posts: 76
Registered: 16-Apr-2008
Re: Version 2.0 released for Block Editor
Posted: 18-Jun-2020 17:22   in response to: Laza in response to: Laza
  Click to reply to this thread Reply
Great to see jalbum Bridge updated!

The Block editor is now the supported editor for the Bridge.Well done!

For those who continue to use the Classic Editor a description of the shortcode settings will be very welcome!
FabioM

Posts: 24
Registered: 27-Dec-2008
Re: Version 2.0 released for Block Editor
Posted: 15-Jul-2020 18:57   in response to: Laza in response to: Laza
  Click to reply to this thread Reply
I was a user of the previous version of jAllbum bridge and I use a WP theme and his author says the following about your new version:

Currently Kinatrix theme doesn't have Gutenberg features. We'll be getting this in as an update.

It will take some time as that's going to be a major upgrade while maintaining backwards compatibility for those who have used it without it.

Could you ask the plugin developer if they support shortcode methods. If they have a shortcode then you can use it with the pagebuilder through the shortcode block.

Edited by: FabioM on 15-Jul-2020 18:57
Laza

Posts: 2,365
Registered: 6-Sep-2005
Re: Version 2.0 released for Block Editor
Posted: 15-Jul-2020 19:32   in response to: FabioM in response to: FabioM
  Click to reply to this thread Reply
Yes, jAlbum Bridge still supports old shortcodes. Read the last section - "Note to existing users" - of this blog post:
https://jalbum.net/en/blog/entry/jalbum-bridge-reborn-for-wordpress-new-block-editor
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums