This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 5 - Pages: 1 - Last Post: 06-Apr-2020 15:31 Last Post By: jGromit Threads: [ Previous | Next ]
oehl

Posts: 96
Registered: 16-Mar-2017
Subpage not reachable.
Posted: 06-Apr-2020 08:15
 
  Click to reply to this thread Reply
Hello.
I have a strange issue:
My website http://www.jZoom.de has several tiles. Some are working like"Architecture", when clicking on it (Link: http://www.jzoom.de/Architecture/index.html) Others are not working like "People". If you click on it, you will get the error message "page not found". Strange is, that here the link is http://oehl.jalbum.net/People/ and not http://www.jzoom.de/People/index.html as expected.
On the preview in jAlbum it's perfectly working.
I cleared the browser cache, without positiv result. The I deleted everything and generated the website completely new and uploaded it: no change.
Please help.
Thx.
BR,
Johannes
Laza

Posts: 2,301
Registered: 6-Sep-2005
Re: Subpage not reachable.
Posted: 06-Apr-2020 12:59   in response to: oehl in response to: oehl
 
  Click to reply to this thread Reply
If the local preview works, and the uploaded version don't it's usually an Upload error, and a repeated "Upload" can cure it.
oehl

Posts: 96
Registered: 16-Mar-2017
Re: Subpage not reachable.
Posted: 06-Apr-2020 13:47   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
thx, Laza. I already tried it. But this didn't help.
I compared the folders again: Architecture is local and at the server starting with a capital letter. People is written on the server with a lower case caracter, while local with a capital letter. But I haven't changed the names since a very long time.
jGromit

Posts: 7,808
Registered: 31-Jan-2006
Re: Subpage not reachable.
Posted: 06-Apr-2020 15:01   in response to: oehl in response to: oehl
 
  Click to reply to this thread Reply
It's hard to imagine how the folder names were converted to lower case on the server. The jAlbum upload routine doesn't include an option to make that switch (some FTP client programs do).

But if you just want to fix everything, delete the published album and upload it again.
oehl

Posts: 96
Registered: 16-Mar-2017
Re: Subpage not reachable.
Posted: 06-Apr-2020 15:25   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
The problem is solved.
I do not know why, but the generated webpage stored on my local computer had this lower case folders, while jAlbum-data on my local computer had the upper case folders. After generating the album, jAlbum left the folder still in lower cases (even with the forced mode). This where then uploaded to the server in lower cases and this caused the problem.
So I deleted everything: server and the generated local code. Then I generated it again and uploaded it: It works.

My suggestion to the developers of jAlbum:
1. Please make sure, that the folder you are showing in the program are the same as in the generated code.
2. When forcing the Remake, please delete the folder structure of the generated code, that you have only the valid data remaining after generation.

Thx for the help!

Edited by: oehl on 06-Apr-2020 15:25
jGromit

Posts: 7,808
Registered: 31-Jan-2006
Re: Subpage not reachable.
Posted: 06-Apr-2020 15:31   in response to: oehl in response to: oehl
 
  Click to reply to this thread Reply
oehl wrote:
My suggestion to the developers of jAlbum:
1. Please make sure, that the folder you are showing in the program are the same as in the generated code.

I suspect that might not be possible. The problem is that Windows is not case-sensitive, so jAlbum might have no way of detecting that there was a case mismatch. Windows says, "Yes, everything is fine: people == People."

2. When forcing the Remake, please delete the folder structure of the generated code, that you have only the valid data remaining after generation.

The forced remake concerns only the scaled images. It doesn't rebuild the entire output. But there's already a way to do that. Click the little down-arrow to the right of the project name, choose Delete, and then Delete local album.... Then just hit Make Album again.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums