This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 21 - Pages: 2 [ 1 2 | Next ] - Last Post: 11-Feb-2020 20:05 Last Post By: jGromit Threads: [ Previous | Next ]
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
can't tap on subject title to get to contents
Posted: 03-Feb-2020 21:30
 
  Click to reply to this thread Reply
If you look at my website, http://www.paulwhitingphotography.com/, you'll see about half a dozen folders, each one with a differnet part of the world (sorry, none from Sweden!). When I tap on, say, Mexico, that title would turn yellow and bring me to photos taken in Mexico. Now, when I tap on the title nothing happens. I need to tap on the photo above the title to get to the contents.

Not a big deal... just that I can't remember how I got that feature in the first place.

Thank you!

Paul
jGromit

Posts: 7,772
Registered: 31-Jan-2006
Re: can't tap on subject title to get to contents
Posted: 03-Feb-2020 21:43   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
Attachment titleLink.png (46.0 KB)
Had to test it, but my memory is better than I thought! That was the default behavior in Turtle. Tiger doesn't offer it.

You could tackle it manually, but it might be more trouble than it's worth. See the screenshot. I've tested it, and it seems to work, but there may be some fallout that I'm not thinking about...
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
Re: can't tap on subject title to get to contents
Posted: 03-Feb-2020 21:58   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Your answer makes sense... thank you! As I said, not a real serious issue, and also as you said, not worth the trouble to fix it!

Best,

Paul
Laza

Posts: 2,287
Registered: 6-Sep-2005
Re: can't tap on subject title to get to contents
Posted: 04-Feb-2020 08:47   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
You can add the link in the folder caption template (Sections / Folders) to make it work automatically:
<h3><a href="${closeupPath}">${title}</a></h3>
<div class="comment">${commentShort}</div>
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
Re: can't tap on subject title to get to contents
Posted: 08-Feb-2020 14:45   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Thank you, Laza, but I'm not skilled enough to know what to do with your tip.

Sorry!

Paul
jGromit

Posts: 7,772
Registered: 31-Jan-2006
Re: can't tap on subject title to get to contents
Posted: 08-Feb-2020 15:50   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
Attachment ss006609.png (44.0 KB)
It's easy. Take a look at the attached screenshot. Just replace the stuff in the caption template box with the code that Laza has posted.
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
Re: can't tap on subject title to get to contents
Posted: 08-Feb-2020 18:22   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks, jGromiit,

Well, replacing what's in the box with Laza's contents went smoothly, and I checked "apply" (in the lower right hand corner). But when I called up my website and clicked on the folder title nothing happened, the box's original contents were still there.

This is new territory for me, and maybe I'm supposed to carry out another step in order to make the new contents "stick".
jGromit

Posts: 7,772
Registered: 31-Jan-2006
Re: can't tap on subject title to get to contents
Posted: 08-Feb-2020 18:50   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
You still have to Make Album and upload it again, of course. Your website indicates that it was last updated in November of 2019.
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
Re: can't tap on subject title to get to contents
Posted: 08-Feb-2020 19:18   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
SPSF

(Sound of Palm Smiting Forehead)

All is well, thank you!

PS: While I have you... what is Forced Remake (Shift-F9)?
jGromit

Posts: 7,772
Registered: 31-Jan-2006
Re: can't tap on subject title to get to contents
Posted: 08-Feb-2020 19:56   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
Force Remake is what used to be called Make All. It forces jAlbum to reprocess all the images and videos, even if there's absolutely no reason to do so. There are some rare situations when it's needed, but as a rule, you should never have to use it. I begged David to rename it because I was seeing, all too often, users thinking they needed to do that to make the album.

Similarly, too many users thought that Make Changes was what they needed to use after changing something. Sometimes that was true, but not always. So it's been renamed Make Test, to indicate that it might not be enough after you've made some changes (it will process page layout changes, but not image processing changes, like image bounds).

Before uploading, you really need to Make Album. The other two options are rarely needed (I'd like to see them buried even deeper in the user interface).
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
Re: can't tap on subject title to get to contents
Posted: 08-Feb-2020 20:45   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thank you very much!

Paul
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
Re: can't tap on subject title to get to contents
Posted: 10-Feb-2020 23:30   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
Well, ladies and gentlemen, I'm afraid I screwed things up. I lost my modified website again. I thought I'd give PhotoBlogger a try, found it interesting, but came back to Tiger. When I did that, I discovered I had lost the modfied folder header in yellow and also the folder's contents are no longer accessed with a tap of the folder's header.

I did as suggested the first time, installed Laza's modified contents of the Caption template, and performed a Remake and uploaded that. I even erased my computer's cache.

Sorry to trouble you all....

Paul
jGromit

Posts: 7,772
Registered: 31-Jan-2006
Re: can't tap on subject title to get to contents
Posted: 10-Feb-2020 23:43   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
When you switched back to Tiger, that simply loaded the Tiger skin with all of its default settings.

If you had exited the project without saving at that point, you'd be OK. And if you hadn't uploaded the loused-up version, we could access the lifeboat file to recover your original project settings, but now you've overwritten that, so all traces of the correct project are gone. There's just nothing we can look at or retrieve.

There's just one possibility, but if you've done multiple "saves," or if you didn't have your preferences set to make backups, that won't help, either. Worth a shot:

  • Open the project.
  • Choose Tools, Open directories, Open image directory.
  • Close jAlbum.
  • Now, in File Explorer, see if there's a jalbum-settings.jap.bak file. If there is, delete jalbum-settings.jap, and rename jalbum-settings.jap.bak to jalbum-settings.jap.
  • Launch jAlbum and open the project again.
  • Make Album, and see how the results look.

I hope you have backups of the files on your PC, and can go back to the project files from before your misadventure.

In future, if you want to experiment with a different skin, make a copy of the project, and then play with the copy.
PaulWhiting

Posts: 39
Registered: 25-Mar-2013
Re: can't tap on subject title to get to contents
Posted: 10-Feb-2020 23:57   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
I did have my preferences set to make backups. Shall I go that route before proceeding with "worth a shot"?
jGromit

Posts: 7,772
Registered: 31-Jan-2006
Re: can't tap on subject title to get to contents
Posted: 11-Feb-2020 00:08   in response to: PaulWhiting in response to: PaulWhiting
 
  Click to reply to this thread Reply
The "worth a shot" might work - those instructions are trying to recover the backup of the project settings that jAlbum made. But it keeps only one backup, so if you saved, made some changes, then saved again, it won't do you any good.

This is a lesson that everyone needs to learn. Always, always, always have backups of what's on your PC. Hard drives fail, and without backups, you're dead in the water. I have three backup copies of everything - one on a second internal hard drive, one on a plugin external hard drive, and one on Carbonite. I make backups to the internal hard drive repeatedly, whenever I've finished making a bunch of changes to things, and am leaving the PC. I make backups to the external drive a couple of times a day, at least. And Carbonite keeps continual backups automatically.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums