Thread Locked This thread is locked - replies are not allowed.



Permlink Replies: 112 - Pages: 8 [ Previous | 1 2 3 4 5 6 7 | Next ] - Last Post: 25-Oct-2018 15:52 Last Post By: davidekholm Threads: [ Previous | Next ]
davidekholm

Posts: 21,852
Registered: 18-Oct-2002
Re: jAlbum 17 beta for testing
Posted: 20-Oct-2018 18:27   in response to: AndreWolff in response to: AndreWolff
AndreWolff wrote:
OK, but that was set in my tests, so why is is Location / geotagging not working?

I have to investigate that. Thanks for reporting.

Note also that the Advanced /Metadata tab contains also a check-mark ‘Include xmp metadata in generated pages'.

No, it says "images", not "pages"
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 20-Oct-2018 18:30   in response to: davidekholm in response to: davidekholm
davidekholm wrote:
No, it says "images", not "pages"
Correct, sorry to many settings for me!

Don't forget to investigate also the set crop focus zooming problem .
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 20-Oct-2018 19:57   in response to: davidekholm in response to: davidekholm
In the review mode I miss a button to close the Review mode.

I am also missing yellow hints for the buttons in the review mode.
RobM

Posts: 5,063
Registered: 4-Aug-2006
Re: jAlbum 17 beta for testing
Posted: 20-Oct-2018 20:40   in response to: davidekholm in response to: davidekholm
davidekholm wrote:
AndreWolff wrote:
OK, but that was set in my tests, so why is is Location / geotagging not working?

I have to investigate that. Thanks for reporting.

It is working just as before on the Mac.
Andre´ have you moved to another image or closed the edit window before hitting 'Make'?

Re the video location question. I think you will find that there is no xmp GPS metadata, only exif, and jAlbum writes GPS data to xmp not exif.
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 20-Oct-2018 22:14   in response to: RobM in response to: RobM
RobM wrote:
André have you moved to another image or closed the edit window before hitting 'Make'?
No, but even if I had done that, it should not make any difference!
Re the video location question. I think you will find that there is no xmp GPS metadata, only exif, and jAlbum writes GPS data to xmp not exif.
I don't understand this at all, just tell me and future users what I should do to Geotag a video!

And in this whole process, if I have not set the correct check-marks, jAlbum should warn me!
RobM

Posts: 5,063
Registered: 4-Aug-2006
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 00:26   in response to: AndreWolff in response to: AndreWolff
AndreWolff wrote:
RobM wrote:
André have you moved to another image or closed the edit window before hitting 'Make'?
No, but even if I had done that, it should not make any difference!
Re the video location question. I think you will find that there is no xmp GPS metadata, only exif, and jAlbum writes GPS data to xmp not exif.
I don't understand this at all, just tell me and future users what I should do to Geotag a video!
I suggest you read the rest of the help page that you quoted from earlier, it clearly states how it works and what it works with.
jGromit

Posts: 32,062
Registered: 31-Jan-2006
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 01:42   in response to: davidekholm in response to: davidekholm
I'm gettting some console dumps and failed album builds with 17b3. So far, I haven't figured out what's different about the albums that fail, and those that succeed, but these are my standard skin demo albums, which I've been using for a long, long time - in short, there's nothing new or strange about them.

Here's the console dump:
An unexpected error occurred. Please see detailed description below:
 
java.lang.RuntimeException: Error processing C:\Users\jefft\Documents\jAlbum Skins\Comet\Comet Samples\COstandard\Solar Year.jpg
	at se.datadosen.jalbum.AlbumBean.registerVariables(AlbumBean.java:2378)
	at se.datadosen.jalbum.AlbumBean$RegisteringTask.call(AlbumBean.java:5601)
	at se.datadosen.jalbum.AlbumBean$RegisteringTask.call(AlbumBean.java:5582)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
	at se.datadosen.jalbum.XmpManager.importWindowsDefaults(XmpManager.java:535)
	at se.datadosen.jalbum.XmpManager.init(XmpManager.java:128)
	at se.datadosen.jalbum.XmpManager.<init>(XmpManager.java:77)
	at se.datadosen.jalbum.AlbumObjectImpl.getXmpManager(AlbumObjectImpl.java:1280)
	at se.datadosen.jalbum.AlbumBean.registerVariables(AlbumBean.java:2251)
	... 6 more
jGromit

Posts: 32,062
Registered: 31-Jan-2006
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 01:45   in response to: jGromit in response to: jGromit
Attachment sunspot.jpg (93.1 KB)
It seems to be confined to certain images, but they're as "plain vanilla" as can be. Try the attached image in a Minimal album.

ETA: Same error in 17b1. Windows & macOS

ETAETA: No problem in 16.2.
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 09:29   in response to: RobM in response to: RobM
RobM wrote:
I suggest you read the rest of the help page that you quoted from earlier, it clearly states how it works and what it works with.
If I have to read the manual to understand it, it is not correctly implemented!

I did what normal users do:

You make an album.
You check the result and sees that a location is incorrect
You open the location window for that image and correct the location.
You clicks again on the Make button.
If the album is ready you checks again the location, you should see now the corrwect location.

People expects that it works in this way, but is does not!
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 09:30   in response to: davidekholm in response to: davidekholm
In the review mode I can't read the file names on my Windows 10 system, see attached screen-shot
davidekholm

Posts: 21,852
Registered: 18-Oct-2002
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 09:30   in response to: jGromit in response to: jGromit
jGromit wrote:
It seems to be confined to certain images, but they're as "plain vanilla" as can be. Try the attached image in a Minimal album.

Thanks for reporting. A side effect of "improved" import of incorrectly written Windows EXIF descriptions. Please try updated beta!
davidekholm

Posts: 21,852
Registered: 18-Oct-2002
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 09:36   in response to: AndreWolff in response to: AndreWolff
AndreWolff wrote:
In the review mode I can't read the file names on my Windows 10 system, see attached screen-shot

I wonder how that's triggered. Can't reproduce on my Win 10. Does it happen to all your projects?
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 09:48   in response to: RobM in response to: RobM
RobM wrote:
I suggest you read the rest of the help page that you quoted from earlier, it clearly states how it works and what it works with.
I did, the manual says:

If your images are already geo-tagged then the map will display the location it was taken. If not, or you wish to change the displayed GPS location, you can tag the images by either using the search box to look for the location (press 'Enter' to start the search or pick from the list of locations suggested) or enter the coordinate in the format 59.3325800, 18.0649000 (Latitude North, Longitude East for Stockholm, Sweden). Use negative numbers for South and West. For more information on using jAlbum's location pane click here

What I did is not indicated here: I moved the marker with the mouse!

I hope David is not going to tell me that that the most obvious way to change the location is not supported!

You should tell here that you can change the location by moving the cursor and if that is not supported, it shoulds be stated here in big letters and it should be forbidden to move the marker with the mouse in the location window!
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 10:03   in response to: davidekholm in response to: davidekholm
Attachment NoScrollBarPNG.PNG (127.3 KB)
Well this happens in all projects with a large number of images where a scroll bar is visible.

With small projects where no scrollbar is visible, it is better, see enclosed screenshot.
AndreWolff

Posts: 2,558
Registered: 14-Dec-2007
Re: jAlbum 17 beta for testing
Posted: 21-Oct-2018 10:10   in response to: davidekholm in response to: davidekholm
I process my images in Lighthroom where I use 2 monitors, the right monitor for my input and the left monitor to display as large image the currently edited image, you can compare that with the new review mode.

However the review window in jAlbum 17 is always opened on my right monitor.
I like to use the right monitor for the explorer view and the left monitor for the new review mode.

How can I get that done?

Point your RSS reader here for a feed of the latest messages in all forums