This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 1 - Pages: 1 - Last Post: 20-Sep-2018 08:46 Last Post By: Laza
sage12

Posts: 1
Registered: 20-Sep-2018
Problem with Facebook Buttons/Share on function
Posted: 20-Sep-2018 05:07
 
  Click to reply to this thread Reply
Hello community,

I have browsed many posts and also tried the developers guide to get the FB-Like function to work, but only partially successful.
I want to use the Settings/Turtle/Social/Sharing Facebook 'Buttons' and 'Share on' function. If I check the corresponding radio buttons and upload the page to my personal webspace, the FB buttons do appear both on the main page (www.myurl.de) and on the album page (www.myurl.de - Best Of 2014), no problem.

The webspace structure is like this:
Domain: www.myurl.de
ftp-Folder for upload of html-data: ftp.myurl.de/html
ftp.myurl.de/html = www.myurl.de/
(I hope my explanation makes sense, I'm not a web-genius)

On the main page (www.myurl.de) if I click on the "Like" button and check the activity history in my Facebook profile the Like isn't for my photopage but for a dummy page called portfolio-something on lazy.jalbum.net. Same happens if I select the Share on button.

If I go to the photo page (www.myurl.de - Best Of 2014) though it's a different story: there the Like and Share buttons appear on the same position of course, but they work as desired! The only thing I don't like is that the picture that is used in the FB-Share is not a chosen, but a random one - can I change this somehow?

I checked all settings of both Turtle and jAlbum, but nowhere this portfolio-dummy-album-URL is entered or can be erased. Also I tried removing the FB-buttons, uploaded the revised page, changed the settings so that the Facebook buttons are shown again and uploaded the revision again. No effect, always as described above. I am not a web programming genius, more a GUI user, that's why I bought jAlbum. Does anyone have a handy solution? I can't imagine that it is just me who's experiencing this issue...

Thanks for your help,
Rob
Laza

Posts: 2,356
Registered: 6-Sep-2005
Re: Problem with Facebook Buttons/Share on function
Posted: 20-Sep-2018 08:45   in response to: sage12 in response to: sage12
 
  Click to reply to this thread Reply
Was the main page made with jAlbum too? How did you make that page? Perhaps you've copy/pasted the wrong call code. We need the real link to your page to get some idea what we're talking about.

The Facebook share should use the folder thumbnail (or album thumbnail on the top level page) provided you've set the URL through "Settings / Tiger / Site / Site admin / Upload path". This should contain the URL to the album, e.g.
http://www.myurl.de/Best%20Of%202014
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums