This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 4 - Pages: 1 - Last Post: 05-Mar-2018 11:26 Last Post By: Laza Threads: [ Previous | Next ]
aliweber

Posts: 13
Registered: 5-Jun-2014
so called "foreign characters" like å ä ö in the image description
Posted: 03-Mar-2018 11:36
 
  Click to reply to this thread Reply
Hi,

in one of my albums the image description field is different handled regarding so called foreign characters.

Why, I have no explanation. Could you pleease have a look and help me.

https://www.aliweber.de/Images/Project%20Sixty%20-%20Lissabon%20nach%20Moskau/2015%20von%20Istanbul%20nach%20Samsun/00%20Anreise/index.html

In above folder it works.

in the below folder it doesn't work .

https://www.aliweber.de/Images/Project%20Sixty%20-%20Lissabon%20nach%20Moskau/2015%20von%20Istanbul%20nach%20Samsun/02%20Kocaman%20nach%20Caycuma/index.html

Many thanks for your help.
Laza

Posts: 7,165
Registered: 6-Sep-2005
Re: so called "foreign characters" like å ä ö in the image description
Posted: 03-Mar-2018 13:02   in response to: aliweber in response to: aliweber
 
  Click to reply to this thread Reply
Can you please check if the same wrong characters appear in jAlbum too? (change to "Title" view in the top right corner) I guess they must be there too, as other characters show properly on your page.
jGromit

Posts: 31,886
Registered: 31-Jan-2006
Re: so called "foreign characters" like å ä ö in the image description
Posted: 03-Mar-2018 19:28   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
They're not shown correctly in the meta.properties file, so they were probably entered improperly:
descript=Hart wenn die Strasse pl?tzlich und unerwartet endet, aber zum Gl?ck gibt es ja Taxis.
I'm also not sure about the chosen encoding in jAlbum. Under Album > Settings > Advanced > General > Encoding, this user has chosen UTF-8. I think ISO-8859-1 is the safer choice (but still check the Write UTF-8 box).
aliweber

Posts: 13
Registered: 5-Jun-2014
Re: so called "foreign characters" like å ä ö in the image description
Posted: 03-Mar-2018 22:16   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Yes, you are right they are there too. After changing them to ä, ö, ü, ß with the keyboard it works now.
Also I changed the font from Segoe, Dosis to Arial and identical with the base font.

Now the result is exactly what I wanted to see.
Laza

Posts: 7,165
Registered: 6-Sep-2005
Re: so called "foreign characters" like å ä ö in the image description
Posted: 05-Mar-2018 11:26   in response to: aliweber in response to: aliweber
 
  Click to reply to this thread Reply
Dosis supposed to have all the western-european languages. (No greek or cyrillic)
https://fonts.google.com/specimen/Dosis?selection.family=Dosis

Segoe is a system font, therefore it supports several codepages. Perhaps older XP's didn't have all the codepages, I don't know.

I guess the problem was the flawed import of exif data.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums