This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 8 - Pages: 1 - Last Post: 30 Apr 23, 19:50 Last Post By: davidekholm
MarkusD

Posts: 660
Registered: 13-Apr-2006
Wrong keyboard handling in Review mode
Posted: 18 Apr 23, 21:15
 
  Click to reply to this thread Reply
Hi David,

in my opinion there is something wrong using the keyboard handling in Review mode. Please have a look into that video.
https://www.markus-drueck.de/public/jAlbum/Videos/jAlbum%20Core/index.html#img=Video_2023-04-18_210224.mp4

Thanks, Markus
RobM

Posts: 3,802
Registered: 4-Aug-2006
Re: Wrong keyboard handling in Review mode
Posted: 18 Apr 23, 21:45   in response to: MarkusD in response to: MarkusD
 
  Click to reply to this thread Reply
This might be Windows only. On my Mac and using only the keyboard it works as expected.
MarkusD

Posts: 660
Registered: 13-Apr-2006
Re: Wrong keyboard handling in Review mode
Posted: 18 Apr 23, 21:54   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Thanks for testing, Rob.
JeffTucker

Posts: 8,000
Registered: 31-Jan-2006
Re: Wrong keyboard handling in Review mode
Posted: 18 Apr 23, 22:26   in response to: MarkusD in response to: MarkusD
 
  Click to reply to this thread Reply
I can replicate this on my Win11 machine. In short, if you delete an object, the icons on the top row all show as "disabled." You can, indeed, still navigate with the arrow keys, but you can't delete another object from the keyboard. A quick mouse-jiggle restores the "enabled" state of the icons, and all is normal again.
MarkusD

Posts: 660
Registered: 13-Apr-2006
Re: Wrong keyboard handling in Review mode
Posted: 19 Apr 23, 20:19   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
I can replicate this on my Win11 machine. In short, if you delete an object, the icons on the top row all show as "disabled." You can, indeed, still navigate with the arrow keys, but you can't delete another object from the keyboard. A quick mouse-jiggle restores the "enabled" state of the icons, and all is normal again.
Yes, Jeff, I'm aware of this workaround (jiggle the mouse), I'm doing this now for years and I thought it's time to report this, because it is really, I mean really annoying to workaround this issue. It drives me nuts. Looking forward David will kill that bug. ;-)
davidekholm

Posts: 3,430
Registered: 18-Oct-2002
Re: Wrong keyboard handling in Review mode
Posted: 26 Apr 23, 16:35   in response to: MarkusD in response to: MarkusD
 
  Click to reply to this thread Reply
I'll have this issue fixed for the next jAlbum release.
JeffTucker

Posts: 8,000
Registered: 31-Jan-2006
Re: Wrong keyboard handling in Review mode
Posted: 27 Apr 23, 16:09   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
Appears to work properly in jAlbum 30.3.b3. :)
MarkusD

Posts: 660
Registered: 13-Apr-2006
Re: Wrong keyboard handling in Review mode
Posted: 27 Apr 23, 22:55   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
Thanks David! :-)
davidekholm

Posts: 3,430
Registered: 18-Oct-2002
Re: Wrong keyboard handling in Review mode
Posted: 30 Apr 23, 19:50   in response to: MarkusD in response to: MarkusD
 
  Click to reply to this thread Reply
You're welcome :-)
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums