This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 9 - Pages: 1 - Last Post: 29 Aug 22, 13:07 Last Post By: RobM
rdonnelly

Posts: 4
Registered: 19-Jan-2008
only png image files appear - no jpg
Posted: 18 Aug 22, 06:36
 
  Click to reply to this thread Reply
am running 28.1.5 in Linux, the only images that appear are png once I have published - none of the jog images. yet they appear in the editing screens.... have tried various skins same issue
RobM

Posts: 4,376
Registered: 4-Aug-2006
Re: only png image files appear - no jpg
Posted: 18 Aug 22, 10:28   in response to: rdonnelly in response to: rdonnelly
 
  Click to reply to this thread Reply
Can you publish a small test album?
Have you tried skins from different authors?
rdonnelly

Posts: 4
Registered: 19-Jan-2008
Re: only png image files appear - no jpg
Posted: 21 Aug 22, 00:36   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
have tried a number of skins from different authors. also added and deleted images. there doesn't appear to be any issue with jpg files in other programs.- including inserting images into documents, etc.

when published - the same thing - no jpgs - the pages appear fine and all png files appear...
JeffTucker

Posts: 8,440
Registered: 31-Jan-2006
Re: only png image files appear - no jpg
Posted: 21 Aug 22, 00:44   in response to: rdonnelly in response to: rdonnelly
 
  Click to reply to this thread Reply
Well, we can't just guess, having never seen this symptom before. We're going to need, at a minimum, a link to an album that shows this problem. And make sure you have enabled the creation of the lifeboat file - we don't want to play 20 Questions. ;)
rdonnelly

Posts: 4
Registered: 19-Jan-2008
Re: only png image files appear - no jpg
Posted: 21 Aug 22, 06:32   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
here is a link to the published album - https://gallery.jalbum.net/en/browse/user/album/2054885

oddly, when I create the album within the software and preview it - no images appear.

when I published it, and go to the jalbum.net site, the images are all there....
RobM

Posts: 4,376
Registered: 4-Aug-2006
Re: only png image files appear - no jpg
Posted: 21 Aug 22, 10:17   in response to: rdonnelly in response to: rdonnelly
 
  Click to reply to this thread Reply
If you are not previewing the album in a browser try changing the Preview preference to external Preferences>General>Preview>External
JeffTucker

Posts: 8,440
Registered: 31-Jan-2006
Re: only png image files appear - no jpg
Posted: 21 Aug 22, 14:08   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Yes, this does look like an integrated browser problem, but I can't reproduce it. The project settings are all perfectly normal, and I ran the site through a code validator, and everything is fine.

If switching to an external browser for previews fixes the problem, I'd suggest doing a clean reinstall of jAlbum. It will take only a few minutes, and might clear out some old JAR files that are causing mischief.

https://jalbum.net/forum/thread.jspa?threadID=35746
rdonnelly

Posts: 4
Registered: 19-Jan-2008
Re: only png image files appear - no jpg
Posted: 29 Aug 22, 10:21   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
changed the preview option as you suggested - that seems to have fixed the problem. thanks for all of your help. rpd
JeffTucker

Posts: 8,440
Registered: 31-Jan-2006
Re: only png image files appear - no jpg
Posted: 29 Aug 22, 13:03   in response to: rdonnelly in response to: rdonnelly
 
  Click to reply to this thread Reply
Glad that worked, but you really should do a clean, full, reinstall of jAlbum. There's no telling what other problems might be lurking.
RobM

Posts: 4,376
Registered: 4-Aug-2006
Re: only png image files appear - no jpg
Posted: 29 Aug 22, 13:07   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
Glad that worked, but you really should do a clean, full, reinstall of jAlbum. There's no telling what other problems might be lurking.
And with a new version round the corner there is no better time to clean out out of date stuff (ffmpeg is almost certainly an old version).
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums