This question is answered. Helpful answers available: 0. Correct answers available: 1.


Permlink Replies: 14 - Pages: 1 - Last Post: 30 Jul 22, 06:39 Last Post By: ufalbum Threads: [ Previous | Next ]
ufalbum

Posts: 87
Registered: 2-Aug-2010
Bug in latest version of tiger?
Posted: 26 Jul 22, 20:29
 
  Click to reply to this thread Reply
Hi,
i added a new folder in my large album which hast almost 6GB in size.
https://webalben.rezkonv.de/albums/stuttgart21/index.html

New folder within
https://webalben.rezkonv.de/albums/stuttgart21/monatsalben/2022/ab-juli-2022/index.html
namely
621. Montagsdemo which is corrupt.

No other changes!The size of the new folder is 15MB. When uploading the new album after creating to my own server using integrated upload feature it takes a lot more time as usual, but as soon as the new folder should be upload it looks like a permanent loop, the estimated remaining time is only about 1 min, but this time never ends: processing slides (and thumbs) of the new folder, no change.
Bug or feature?

Regards
Ulli
JeffTucker

Posts: 8,324
Registered: 31-Jan-2006
Re: Bug in latest version of tiger?
Posted: 26 Jul 22, 21:02   in response to: ufalbum in response to: ufalbum
 
  Click to reply to this thread Reply
Does that image show properly when you preview the album locally? And do the images in the folder also show properly?
ufalbum

Posts: 87
Registered: 2-Aug-2010
Re: Bug in latest version of tiger?
Posted: 26 Jul 22, 22:17   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Hi,
the image shows what happens when uploading the just locally generated updated album from local storage to the server using jalbum's built-in ftp feature.
Previewing the newly updated album after generation works as it should..
Regards
Ulli
JeffTucker

Posts: 8,324
Registered: 31-Jan-2006
Re: Bug in latest version of tiger?
Posted: 26 Jul 22, 23:00   in response to: ufalbum in response to: ufalbum
Helpful
  Click to reply to this thread Reply
If the album looks OK in local preview, but the upload doesn't work properly, this is not a Tiger issue. The skin's job is done when album generation is finished - it has no role to play in the uploading process. So, I'll move this thread.

To correct the upload, you should connect to your server, delete the manifest.jmf file (at the root of the album), then delete the entire md621 folder - slides and thumbs. Then have jAlbum do the upload again. It will be slower than usual, because the manifest file is gone, but the manifest file is probably damaged.
ufalbum

Posts: 87
Registered: 2-Aug-2010
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 08:24   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Attachment albums21c.jpg (141.3 KB)
Attachment albums21b.jpg (87.6 KB)
Attachment albums21a.jpg (21.8 KB)
Attachment albums21d.jpg (238.1 KB)
Jeff trucker wrote:
So, I'll move this thread.

To correct the upload, you should connect to your server, delete the manifest.jmf file (at the root of the album), then delete the entire md621 folder - slides and thumbs. Then have jAlbum do the upload again. It will be slower than usual, because the manifest file is gone, but the manifest file is probably damaged.

++
Did you move the thread? Where it is now?
I did what you told me. I deleted the manifest.jml file in the server root folder of the album stuttgart21 which is
https://webalben.rezkonv.de/albums/stuttgart21
The file had a length of 0 bytes, I suppose due to an error in my jalbum-install or an abortion of an uncompleted upload.
Then I deleted the contents of md621 which is in
https://webalben.rezkonv.de/albums/stuttgart21/monatsalben/2022/ab-juli-2022/md621
and started making the album again with 'make album' as ever. Ref to attached albums21a.jpg It took some miniutes,. At the beginning it took much more than usual before the progress bar was shown. The local preview was OK. I started the upload after creation didn't use the upload button in attached albums21a.jpg but the upload button in the selection box Local previerw | upload | abort. The upload began. After estimated 5 minutes the remaining time in the progress bar was less than 1 minute, after further 10 minutes it was less than 2 minutes. The remaining time was permanently increased to further minutes, even after several hours. It din't came to an end.I had to stop the process this morning.
Note: jalbum recommended to use background mode, i did this and changed to this mode, ref. to my album preferences settings in attached albums21c.jpg, I started a new "make album". What happened is shown in attached albums21b.jpg.
Note: if I looked in my servers md621 directory the data1.json had only 0 bytes in length.

Addition ref. to attached albums21d, a lot of error messages.

What do you recommend? Reinstalling jalbum? Make the whole album again with "force remake"? What i don't want to do is to delete my complete local album, it is a work of several years.
Regards
Ulli

Edited by: ufalbum on 28 Jul 2022, 08:48
JeffTucker

Posts: 8,324
Registered: 31-Jan-2006
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 09:46   in response to: ufalbum in response to: ufalbum
 
  Click to reply to this thread Reply
The first step is to clear up the error that is causing the warning message. It's difficult to know what other problems that might be creating. There seems to be a missing or damaged folder:

stuttgart21/monatsalben/2018/2018-04/Akt-Baustellenfuehrung/Baustellenbilder

This seems to be pointing to this page, which doesn't exist:

http://webalben.rezkonv.de/albums/stuttgart21/album/impressionen/impressionen2018_02/Hauptbahnhof/index.html
JeffTucker

Posts: 8,324
Registered: 31-Jan-2006
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 09:49   in response to: ufalbum in response to: ufalbum
 
  Click to reply to this thread Reply
ufalbum wrote:
Did you move the thread? Where it is now?

Because it appears to be an uploading problem, the thread was moved to the Uploading albums forum section.

Once you have corrected the problem in the 2018 section, and can build the album without getting any error messages, try the upload again. If it fails, you will probably have to contact jAlbum support directly.
ufalbum

Posts: 87
Registered: 2-Aug-2010
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 11:09   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Hi Jeff,
thank you.
You wrote

Because it appears to be an uploading problem, the thread was moved to the Uploading albums forum section.

Once you have corrected the problem in the 2018 section, and can build the album without getting any error messages, try the upload again. If it fails, you will probably have to contact jAlbum support directly.

In fact there was an empty folder within the subfolder. I deleted it and the whole album was created without error message in 5 min. Ref. to album-s21-made.jpg.
The local preview worked without visible errors. I started upload from button upload (ref. to attached ...start-upload.jpg). Nothing has changed, it never comes to an end. The remaining time increases continuously.

I just sent an email to the helpdesk.

JeffTucker

Posts: 8,324
Registered: 31-Jan-2006
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 15:01   in response to: ufalbum in response to: ufalbum
 
  Click to reply to this thread Reply
Two thoughts:

First, make sure it's not just that you've exceeded the storage on your hosting plan.

Second, if you're not already using SFTP, rather than regular FTP, switch to that. You would have to check with your web host to determine what the correct port setting is.
ufalbum

Posts: 87
Registered: 2-Aug-2010
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 15:43   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Hi Jeff,
I will ask the admin of the server which hosts my albums if he made changes in configuration.

I just made the album Sample Portfolio which is included in jalbum again (make all) and uploaded it to my server again (with normal ftp)
It worked without error messages, the manifest.jmf file has a length of zero!
https://webalben.rezkonv.de/albums/Sample%20Portfolio/index.html

Regards

Edited by: ufalbum on 28 Jul 2022, 15:53
JeffTucker

Posts: 8,324
Registered: 31-Jan-2006
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 16:59   in response to: ufalbum in response to: ufalbum
 
  Click to reply to this thread Reply
ufalbum wrote:
...the manifest.jmf file has a length of zero!

Now that's interesting! On my big family album site, the file is about 100k, so it should be even larger on yours.

It sounds like maybe the server is refusing to save that file. David may want to connect to your server to investigate.
ufalbum

Posts: 87
Registered: 2-Aug-2010
Re: Bug in latest version of tiger?
Posted: 28 Jul 22, 17:29   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Hi Jeff,
each album which I uploaded the last days has a manifest.jml file with length 0. My stuttgart21-album had a length of about 400 kB or more before this new effect. I just made a new small album 'test', preview OK. I tried to create a new folder on the server using fileZilla.
Reply from filezilla: 550 Can't create directory: No space left on device.

My admin didn't answer yet.

Regards
Ulli

Edited by: ufalbum on 28 Jul 2022, 17:34
ufalbum

Posts: 87
Registered: 2-Aug-2010
Re: Bug in latest version of tiger?
Posted: 29 Jul 22, 16:09   in response to: ufalbum in response to: ufalbum
 
  Click to reply to this thread Reply
Hi Jeff,
good news.

I deleted some unnecessary files on my rezkonv.de area on the server and uploaded the album stuttgart21 again using the upload feature of jAlbum. It came to an end within a reasonable time without error message.

But the new subfolder md621 was still uncomplete. I deleted the whole folder md621 on the server and started upload again. Incredibly fast (cache!?, most of time was needed for creating manifest.jmf.which now has a size of 318kB.

Thank you so much for your help!

Best regards from Waiblingen near Stuttgart in Germany. Where do you live?
Ulli
https://webalben.rezkonv.de/albums/stuttgart21
JeffTucker

Posts: 8,324
Registered: 31-Jan-2006
Re: Bug in latest version of tiger?
Posted: 29 Jul 22, 16:17   in response to: ufalbum in response to: ufalbum
Helpful
  Click to reply to this thread Reply
That's excellent! Time to step up to a hosting plan with more disk space.

When the manifest file routine is working properly, it really does result in very fast uploads, much faster than what you would get with something like FileZilla. The jAlbum upload routine doesn't have to compare the timestamps on every file, which is what FileZilla does. For a small site, the difference is small, but when you're dealing with a large site, the difference can be huge!

(I live in the northwest hills of Connecticut, USA. Almost as many black bears and bobcats as people. ;) )
ufalbum

Posts: 87
Registered: 2-Aug-2010
Re: Bug in latest version of tiger?
Posted: 30 Jul 22, 06:39   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Hi, Jalbum team,
The problem emerged from missing space on the upload server. It was not a problem of Jalbum. Sorry for that false suspicion.
Regards
Ulli
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums