This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 4 - Pages: 1 - Last Post: 10 Jul 21, 21:21 Last Post By: RobM
RobM

Posts: 3,736
Registered: 4-Aug-2006
Web location error
Posted: 8 Jul 21, 18:45
 
  Click to reply to this thread Reply
Attachment Owl.jpg (629.9 KB)
Not urgent, enjoy your holiday first.
When adding a web location to a project and using this url
https://robm.jalbum.net/Journal%20Landing%20page%20using%20thumbnail/
I get this error
java.io.IOException: Couldn't read image
	at se.datadosen.jalbum.WebLocation.readImage(WebLocation.java:276)
	at se.datadosen.jalbum.WebLocation.readImage(WebLocation.java:258)
	at se.datadosen.jalbum.WebLocation.findRepresentingImage(WebLocation.java:410)
	at se.datadosen.jalbum.JWebLocationEditPanel$1$1.doInBackground(JWebLocationEditPanel.java:78)
	at se.datadosen.jalbum.JWebLocationEditPanel$1$1.doInBackground(JWebLocationEditPanel.java:63)
	at java.desktop/javax.swing.SwingWorker$1.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.desktop/javax.swing.SwingWorker.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)

Original image attached - this is used in another album without issue.
JeffTucker

Posts: 8,093
Registered: 31-Jan-2006
Re: Web location error
Posted: 8 Jul 21, 18:56   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Interesting. It works if I enter that URL as the web location, but instead of hitting Update, I enter this as the image:

https://robm.jalbum.net/Journal%20Landing%20page%20using%20thumbnail/slides/Owl.jpg

Looks like it's trying to read something else as the representing image, but I have no idea what it's trying to read. I do notice, however, that when creating a web location for one of my own sites, jAlbum is grabbing one of the thumbs images, not one of the slides images. A hint, perhaps?
RobM

Posts: 3,736
Registered: 4-Aug-2006
Re: Web location error
Posted: 8 Jul 21, 19:40   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
Interesting. It works if I enter that URL as the web location, but instead of hitting Update, I enter this as the image:

https://robm.jalbum.net/Journal%20Landing%20page%20using%20thumbnail/slides/Owl.jpg

Looks like it's trying to read something else as the representing image, but I have no idea what it's trying to read. I do notice, however, that when creating a web location for one of my own sites, jAlbum is grabbing one of the thumbs images, not one of the slides images. A hint, perhaps?

Neither that album, nor two others that do work, have thumbnails. Journal skin turns off the creation of thumbnails. It’s a mystery.
RobM

Posts: 3,736
Registered: 4-Aug-2006
Re: Web location error
Posted: 8 Jul 21, 20:37   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Another piece of information. Entering the full path to the image, in the web objects image field, works. The full path is
https://robm.jalbum.net/Journal%20Landing%20page%20using%20thumbnail/Empty%201/folderimage.jpg
RobM

Posts: 3,736
Registered: 4-Aug-2006
Re: Web location error
Posted: 10 Jul 21, 21:21   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Not sure what was/is going on, after uploading the album again it is now working. The only difference is the new upload now has a theme image file, folderimage.jpg, before there was only a single image.

If it happens again I'll repost here.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums