This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 25 - Pages: 2 [ Previous | 1 2 ] - Last Post: 8 May 21, 08:21 Last Post By: Laza
Laza

Posts: 2,277
Registered: 6-Sep-2005
Re: Keywords missing sometime
Posted: 7 May 21, 10:08   in response to: hspagnolo in response to: hspagnolo
 
  Click to reply to this thread Reply
One more thing: are you sure the processing of subfolders is enabled?
hspagnolo

Posts: 163
Registered: 23-Mar-2016
Re: Keywords missing sometime
Posted: 7 May 21, 10:20   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Attachment screenshot_25.png (190.2 KB)
Yes see snapshot, but I use ISO-8859-1, I see on your screen that you are using Windows-1252? Does this can create the problem. Also I use "Chain directories".

I can try to change the ISO-8859-1 to Windows-1252, but I would not like that it change my titles, comments and that I won't be able to get back if this is the case?
Laza

Posts: 2,277
Registered: 6-Sep-2005
Re: Keywords missing sometime
Posted: 7 May 21, 11:00   in response to: hspagnolo in response to: hspagnolo
 
  Click to reply to this thread Reply
No, that's not related. Don't change it.
Laza

Posts: 2,277
Registered: 6-Sep-2005
Re: Keywords missing sometime
Posted: 7 May 21, 11:28   in response to: hspagnolo in response to: hspagnolo
 
  Click to reply to this thread Reply
Can you please try what happens if you replace ${keywords} with ${meta.Iptc.Keywords}? This way the skin handles it itself.
hspagnolo

Posts: 163
Registered: 23-Mar-2016
Re: Keywords missing sometime
Posted: 7 May 21, 11:32   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Tested, but this is worst, it remove all the keywords, even the ones that were present before.
Laza

Posts: 2,277
Registered: 6-Sep-2005
Re: Keywords missing sometime
Posted: 7 May 21, 12:13   in response to: hspagnolo in response to: hspagnolo
 
  Click to reply to this thread Reply
Attachment util.js (138.8 KB)
Are you sure you used "Keywords" with an upper case "K"?

Here's a modified util.js attached that replaces the semicolons ";" in the raw meta with commas ", ". Save it to the skin directory (Ctrl-Shift-S) / lib folder.
JeffTucker

Posts: 7,680
Registered: 31-Jan-2006
Re: Keywords missing sometime
Posted: 7 May 21, 12:42   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
Can you please try what happens if you replace ${keywords} with ${meta.Iptc.Keywords}? This way the skin handles it itself.

When you enter keywords in jAlbum, they get written to the .info files, but I don't think they get written to the IPTC metadata of the image files themselves.
Laza

Posts: 2,277
Registered: 6-Sep-2005
Re: Keywords missing sometime
Posted: 7 May 21, 16:54   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
They appear in my List metadata panel, even though I have never added keywords to these files outside of jAlbum.
JeffTucker

Posts: 7,680
Registered: 31-Jan-2006
Re: Keywords missing sometime
Posted: 7 May 21, 17:35   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
They don't do that, for me. If I add keywords in jAlbum, they never show up in the metadata list as IPTC (or anything else). Double-checked in IrfanView - no IPTC keywords in the input or output image files.

ETA: I take part of that back. They do show up as xmp.dc:subject[1], [2], etc.
hspagnolo

Posts: 163
Registered: 23-Mar-2016
Re: Keywords missing sometime
Posted: 7 May 21, 17:57   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Attachment screenshot_27.png (12.4 KB)
Attachment screenshot_26.png (15.9 KB)
Hi Laza,

This morning, I try with ${meta.Iptc.Keywords} and also with ${meta.Iptc.keywords}, but the keywords were still missing.

I try with the new "util.js" with ${meta.Iptc.Keywords}, but the result is the same.

Also what is strange is that into the Keywords Box, for example for "Prangins" it is mentioned 9, but when displaying only 8 images (or clicking on the "Prangins" keyword into the box or searching the word "Prangins" into that box), so 1 missing or 1 extra??? See snapshots

Then I try the new "util.js" but with ${keywords} and then into the keywords box the result for "Prangins" is 8 and what is displayed is 8 images.

I try the old "util.js" with ${keywords} and then into the keywords box the result for "Prangins" is 8 and what is displayed is 8 images.

Hope this helps
Laza

Posts: 2,277
Registered: 6-Sep-2005
Re: Keywords missing sometime
Posted: 8 May 21, 08:21   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Attachment KeywordsMeta.PNG (294.3 KB)
Yes, thanks, I tried now, and it seems now it saves to dc:subject[1],[2],... fields. Perhaps an earlier version of the metadata library has saved into "Iptc.keywords"? See attachment.

This won't make it easier.

I'm out of ideas. David can only tell why it behaves differently with the JSON file and during engine.processTemplate() call.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums