This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 29 - Pages: 2 [ Previous | 1 2 ] - Last Post: 05-Nov-2020 15:48 Last Post By: AnCa Threads: [ Previous | Next ]
AnCa

Posts: 488
Registered: 25-Mar-2005
Re: Missing menu in the forums
Posted: 03-Nov-2020 23:27   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
AnCa wrote:
But the forum needs a separate fix.
The hamburger should now be back in the forum too.

RobM wrote:
Whatever the solution, can we have a normal navigation menu, in landscape mode, on a 9.7ā€ iPad and similar? Having to use the hamburger menu is an unnecessary pain.
I've been messing with the width for tablets and mobiles now and I think it works ok on i-devices now. But there could be other devices where it's worse now... As the forum isn't responsive it's a bit of a hack.
JeffTucker

Posts: 6,962
Registered: 31-Jan-2006
Re: Missing menu in the forums
Posted: 03-Nov-2020 23:35   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
AnCa wrote:
As the forum isn't responsive it's a bit of a hack.

True - the forum on a phone is a painful experience. Somewhat better in landscape, but you still have to do a lot of pinch-zooming to accomplish anything beyond just reading.

I've said this before, but a perfect project for an intern would be to tackle converting the forum to modern software. A nice, self-contained job (unlike developing a new orphan skin ;) ).
RobM

Posts: 3,255
Registered: 4-Aug-2006
Re: Missing menu in the forums
Posted: 03-Nov-2020 23:36   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
AnCa wrote:
AnCa wrote:
But the forum needs a separate fix.
The hamburger should now be back in the forum too.

RobM wrote:
Whatever the solution, can we have a normal navigation menu, in landscape mode, on a 9.7ā€ iPad and similar? Having to use the hamburger menu is an unnecessary pain.
I've been messing with the width for tablets and mobiles now and I think it works ok on i-devices now. But there could be other devices where it's worse now... As the forum isn't responsive it's a bit of a hack.
As long as it works on iOS/PadOS/MacOS, who cares ;)
JeffTucker

Posts: 6,962
Registered: 31-Jan-2006
Re: Missing menu in the forums
Posted: 04-Nov-2020 00:58   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
AnCa wrote:
I've been messing with the width for tablets and mobiles now and I think it works ok on i-devices now. But there could be other devices where it's worse now... As the forum isn't responsive it's a bit of a hack.

Not sure what's changed, but I can no longer pinch-zoom in the forums in either Chrome or Firefox for Android. The forum is now, therefore, completely unusable on a phone. Without zooming, it's almost impossible to hit any anchor text or icon.
AnCa

Posts: 488
Registered: 25-Mar-2005
Re: Missing menu in the forums
Posted: 04-Nov-2020 01:27   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
Not sure what's changed, but I can no longer pinch-zoom in the forums in either Chrome or Firefox for Android. The forum is now, therefore, completely unusable on a phone. Without zooming, it's almost impossible to hit any anchor text or icon.
Odd... Pinch-zoom works in iOS. But I have now reverted the changes regarding responsive widths.
JeffTucker

Posts: 6,962
Registered: 31-Jan-2006
Re: Missing menu in the forums
Posted: 04-Nov-2020 01:41   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
And, as if by magic, I can now pinch-zoom again! I can't even begin to guess....
AnCa

Posts: 488
Registered: 25-Mar-2005
Re: Missing menu in the forums
Posted: 04-Nov-2020 02:24   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
And, as if by magic, I can now pinch-zoom again! I can't even begin to guess....
Isn't that because I reverted my changes?
JeffTucker

Posts: 6,962
Registered: 31-Jan-2006
Re: Missing menu in the forums
Posted: 04-Nov-2020 02:50   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
Well yes, of course it is. But the mystery is why pinch-zooming ended up being disabled by the changes. It can't be easy to overcome the default behavior of a mobile browser!
AnCa

Posts: 488
Registered: 25-Mar-2005
Re: Missing menu in the forums
Posted: 04-Nov-2020 03:31   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
It can't be easy to overcome the default behavior of a mobile browser!

I've now put my changes back, but without a "user-scalable=no" in the viewport meta tag that I accidentally got from a copy-paste... Hopefully this works for both Apples and Googles.

(Watching the US-election.)
JeffTucker

Posts: 6,962
Registered: 31-Jan-2006
Re: Missing menu in the forums
Posted: 04-Nov-2020 03:37   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
AnCa wrote:
I've now put my changes back, but without a "user-scalable=no" in the viewport meta tag that I accidentally got from a copy-paste... Hopefully this works for both Apples and Googles.

Yes! Looks like that was the culprit.

I'm still wrestling with Firefox for Android. Firefox is my default browser - not loaded with spyware (like Chrome), and renders images and fonts better than any of the others. But the latest version for Android is a bit of a mess. And don't even get me started on Thunderbird 78. Ugh.

AnCa wrote:
(Watching the US-election.)

You have a stronger stomach than I do. I have to keep reminding myself that, by definition, half the population has an IQ of less than 100.
AnCa

Posts: 488
Registered: 25-Mar-2005
Re: Missing menu in the forums
Posted: 05-Nov-2020 11:40   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
I have now messed around with the CSS for the forum, so it should now be fairly responsive (posting this using my phone). Iā€™m basically removing columns from the tables as the screen goes smaller. Works ok on your devices?
RobM

Posts: 3,255
Registered: 4-Aug-2006
Re: Missing menu in the forums
Posted: 05-Nov-2020 13:05   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
On my iPad, in both orientations I see all four columns, with the dread burger menu icon only in portrait mode. On my my Android phone, 2160x1080, in landscape I see two columns - category and last post, in portrait only category.
AnCa

Posts: 488
Registered: 25-Mar-2005
Re: Missing menu in the forums
Posted: 05-Nov-2020 13:43   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
RobM wrote:
On my iPad, in both orientations I see all four columns, with the dread burger menu icon only in portrait mode.
Ok, good. The iPads (except the Pro) should have a "responsive" resolution of 1024x768, so the full width of the site is visible in landscape, but not in portrait.

On my my Android phone, 2160x1080, in landscape I see two columns - category and last post, in portrait only category.
Then your phone is probably using 3 pixels for every "web pixel", so the responsive resolution is 720x360. Having only 360px in width for the forum is a bit challenging, especially for the post listings.... :)
JeffTucker

Posts: 6,962
Registered: 31-Jan-2006
Re: Missing menu in the forums
Posted: 05-Nov-2020 14:31   in response to: AnCa in response to: AnCa
 
  Click to reply to this thread Reply
Vastly improved on my phone. I can read easily without pinch-zooming - even better in landscape. Still have to zoom sometimes to hit the little icons reliably, but that's OK.

It's especially an improvement in Firefox, which is overly-sensitive to touches - any attempt to pinch-zoom tends to trigger the reappearance of the address bar, which is a royal pain.

I've never seen any forum software that's really good on a phone. The device, and the function of a forum, are two things that are fundamentally incompatible. But this one is now pretty good.
AnCa

Posts: 488
Registered: 25-Mar-2005
Re: Missing menu in the forums
Posted: 05-Nov-2020 15:48   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
JeffTucker wrote:
Vastly improved on my phone.
Great! :)
If you find a fixable flaw I'll do it, but as you say, some services are not meant to be used on a phone.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums