This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 14 - Pages: 1 - Last Post: 10-Jul-2020 09:16 Last Post By: Laza
RamonaHapke

Posts: 6
Registered: 29-Aug-2012
Album not visible
Posted: 28-Mar-2020 22:17
 
  Click to reply to this thread Reply
Ein created an album with different skins, like matrix, pluto, ...
When I have uploaded it to my server I paste the embed code in a blogpost (WordPress). The albums are not visible.
"Dieser Inhalt kann nicht in einem Frame angezeigt werden.
An dieser Stelle sollten Sie eigentlich Inhalte sehen, aber der Herausgeber lässt die Anzeige in einem Frame nicht zu. Dadurch wird die Sicherheit der Informationen gewährleistet, die Sie ggf. auf dieser Website eingeben."
Example: https://www.tendency-magazin.com/starke-farben-wirken-positiv-auf-die-stimmung/

Ok, no frame. Makes sense. But the plugin bridge is not tested with my current WP version 5.3.2. What to do?
jGromit

Posts: 6,825
Registered: 31-Jan-2006
Re: Album not visible
Posted: 28-Mar-2020 23:44   in response to: RamonaHapke in response to: RamonaHapke
 
  Click to reply to this thread Reply
See this thread: https://jalbum.net/forum/thread.jspa?threadID=54772

I'll move this thread, since it's not about uploading at all. It's about linking to an album from within Wordpress.
hanso

Posts: 76
Registered: 16-Apr-2008
Re: Album not visible
Posted: 29-Mar-2020 12:01   in response to: RamonaHapke in response to: RamonaHapke
 
  Click to reply to this thread Reply
Indeed the Wordpress plugin is not tested on the current Wordpress version, it does function (but will be deleted from Wordpress site in the near future due to not being maintained/updated).

You can use Jalbum's albums in a frame on a Wordpress site with some skins I have tested.
Most will fail as you have seen.

This is the code I use for example for a Lucid or Animatics album.

<style>.embed-container { position: relative; padding-bottom: 60%; height: 0; overflow: hidden; max-width: 100%; } .embed-container iframe, .embed-container object, .embed-container embed { position: absolute; top: 0; left: 0; width: 100%; height: 100%; }</style>
<iframe src='http://ancientworld.hansotten.com/uploads/afrika/marokko/volubilus/' style='border:0'></iframe>

Ofcourse the url is specific to my website. The result is seen here: http://ancientworld.hansotten.com/afrika/volubilis/

I got this code from Jalbum, after uploading with the internal upload function and looking at what the menu Album - Embed produced as code.
RamonaHapke

Posts: 6
Registered: 29-Aug-2012
Re: Album not visible
Posted: 30-Mar-2020 21:55   in response to: hanso in response to: hanso
 
  Click to reply to this thread Reply
Thank you. I also tried the code from JAlbum. I laso tried it with your skin. Nothing...
Now had an error on another webspace of mine while uploading:
java.net.MalformedURLException
at java.base/java.net.URL.<init>(Unknown Source)
at java.base/java.net.URL.<init>(Unknown Source)
at java.base/java.net.URL.<init>(Unknown Source)
at se.datadosen.jalbum.JAlbumFrame.openInBrowser(JAlbumFrame.java:2453)
at se.datadosen.jalbum.JPublishWizard$PublishStep.doAfterUploadAlbum(JPublishWizard.java:2177)
at se.datadosen.jalbum.JPublishWizard$PublishStep.access$1400(JPublishWizard.java:839)
at se.datadosen.jalbum.JPublishWizard$PublishStep$19.run(JPublishWizard.java:2040)
Caused by: java.lang.NullPointerException
... 7 more
RamonaHapke

Posts: 6
Registered: 29-Aug-2012
Re: Album not visible
Posted: 30-Mar-2020 22:00   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thank you. Yes, this is easy.
RamonaHapke

Posts: 6
Registered: 29-Aug-2012
Re: Album not visible
Posted: 30-Mar-2020 22:19   in response to: RamonaHapke in response to: RamonaHapke
 
  Click to reply to this thread Reply
Some minutes agao I updated JAlbum. Now I could uploaded my album without an error.
I was able to embed a non-responsive album. Absolutely no solution for me!
Linking is the better way.

Edited by: RamonaHapke on 28-Apr-2020 17:42
amorley

Posts: 19
Registered: 6-Dec-2008
Re: Album not visible
Posted: 02-Jul-2020 19:26   in response to: RamonaHapke in response to: RamonaHapke
 
  Click to reply to this thread Reply
I have also not been able to get the new jAlbum Bridge (ver 2.0.6) to work on my WordPress Blog. I just see a blank section.

My Blog post: https://texasmorleys.info/texas-independence-trail

contains a jAlbum Bridge link to:

https://www.texasmorleys.com/2020-2029/2020/2020-MC-Rides/06-TX-Independence/index.html

This is not the root page of the album but is a directory in the album which uses the Photoblogger skin
RobM

Posts: 3,165
Registered: 4-Aug-2006
Re: Album not visible
Posted: 02-Jul-2020 19:54   in response to: amorley in response to: amorley
 
  Click to reply to this thread Reply
Have you followed the instructions for a subfolder here
amorley

Posts: 19
Registered: 6-Dec-2008
Re: Album not visible
Posted: 02-Jul-2020 22:40   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
I entered the URL of the Albums root page as:

https://www.texasmorleys.com/2020-2029/2020/2020-MC-Rides/

and the Initial Folder as:

06-TX-Independence

Setup to display as a Slideshow

I still do not see the Album in the WP Editor or when I publish
RobM

Posts: 3,165
Registered: 4-Aug-2006
Re: Album not visible
Posted: 02-Jul-2020 23:55   in response to: amorley in response to: amorley
 
  Click to reply to this thread Reply
There are errors on both the album and the blog page.
The album has:
Error Failed to load resource: the server responded with a status of 404 () (laza.modal.css.map, line 0)
Error Failed to load resource: the server responded with a status of 404 () (what-input.min.js.map, line 0)

The blog has:
Error Origin https://texasmorleys.info is not allowed by Access-Control-Allow-Origin.
Error XMLHttpRequest cannot load https://www.texasmorleys.com/2020-2029/2020/2020-MC-Rides/tree.json due to access control checks.
Error Failed to load resource: Origin https://texasmorleys.info is not allowed by Access-Control-Allow-Origin. (tree.json, line 0)

Sorry, but that is all beyond me, I don't have a blog page or my own website, I just use jAlbum.
Laza

Posts: 2,365
Registered: 6-Sep-2005
Re: Album not visible
Posted: 03-Jul-2020 06:33   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
The album errors are not real errors, the browser just tries to load the mapping file (between the compressed CSS and the source SCSS) when you open the developer console, so it won't affect the album (only debugging).

The real culprit is the CORS violation. The album site is not allowed to accept request from another site.

Add the following lines to https://www.texasmorleys.com/ root directory's .htacess file:
Header set Access-Control-Allow-Origin: "http://texasmorleys.info/"
Header set Access-Control-Allow-Origin: "https://texasmorleys.info/" env=HTTPS

If there's an Access-Control-Allow-Origin "*" there, it's already enabled for all sites.

Edited by: Laza on 10-Jul-2020 09:11
Swapped the source and destination sites
amorley

Posts: 19
Registered: 6-Dec-2008
Re: Album not visible
Posted: 03-Jul-2020 22:02   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Thanks. I will try to work out how I can access the .htaccess file on my WordPress Blog site to make these changes.
Laza

Posts: 2,365
Registered: 6-Sep-2005
Re: Album not visible
Posted: 04-Jul-2020 08:42   in response to: amorley in response to: amorley
 
  Click to reply to this thread Reply
It's not the WordPress site, but the album site which has to allow foreign access.
amorley

Posts: 19
Registered: 6-Dec-2008
Re: Album not visible
Posted: 09-Jul-2020 18:08   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Tried entering the following in the .htaccess file on www.texasmorleys.com

Header set Access-Control-Allow-Origin: "http://www.texasmorleys.com/"
Header set Access-Control-Allow-Origin: "https://www.texasmorleys.com/" env=HTTPS

Did not work, so I tried:

Header set Access-Control-Allow-Origin: "http://www.texasmorleys.info/"
Header set Access-Control-Allow-Origin: "https://www.texasmorleys.info/" env=HTTPS

and the jAlbum Bridge still did not work.
Laza

Posts: 2,365
Registered: 6-Sep-2005
Re: Album not visible
Posted: 10-Jul-2020 09:10   in response to: amorley in response to: amorley
 
  Click to reply to this thread Reply
I see this error message (press F12 in the browser):
Access to XMLHttpRequest at 'https://www.texasmorleys.com/2020-2029/2020/2020-MC-Rides/tree.json' from origin 'https://texasmorleys.info' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.


The www part is unnecessary here, so use the following in the texasmorleys.com's .htaccess file:
Header set Access-Control-Allow-Origin: "http://texasmorleys.info/"
Header set Access-Control-Allow-Origin: "https://texasmorleys.info/" env=HTTPS
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums