This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 4 - Pages: 1 - Last Post: 03-Jul-2020 20:14 Last Post By: jGromit
rfm2

Posts: 116
Registered: 13-Dec-2007
Neptune 38, slide looping
Posted: 03-Jul-2020 00:49
 
  Click to reply to this thread Reply
I hope this "discovery" is not as foolish as my previous Neptune post about the theme image control.

I created a small album with a fixed theme image. I wanted to use an image for the theme that I did not want to include in the regular slides. I added the desired theme image at the end of the regular images, excluded it, made the album. When I displayed the album (locally or after posting) the slides looped after the last regular slide, even though the "loop" option was not checked. After experimenting with other theme image albums I discovered that the looping was the result of having the excluded theme image at the end of the regular images. If I moved the excluded theme image to within the regular images they did not loop.

I'm not sure whether I might also have some other setting on this one "looping" album that may have caused this behavior, but I wanted to see if this was to be expected.
jGromit

Posts: 6,825
Registered: 31-Jan-2006
Re: Neptune 38, slide looping
Posted: 03-Jul-2020 01:50   in response to: rfm2 in response to: rfm2
 
  Click to reply to this thread Reply
Hmmmm... Kind of impossible. How can I be so sure about that? Try a little test album with just a few images. Choose one as the theme image and exclude it. Let's say the excluded image is mydog.jpg. Now make the album, preview it, and take a look at the page source code. Do you see any reference to mydog.jpg on that page anywhere? In short, an excluded image in jAlbum is truly excluded - it can't have any effect, no matter where it is in the Explore view.

What may be confusing you are the new choices for the timed slideshow. Take a look at Neptune > Layout > Slides > Navigation, paying particular attention to the options when you choose Timed slideshow. And look at what happens when the timed slideshow is finished - if the visitor starts in the middle, the last image on the page isn't actually the "end" of the slideshow:

https://jgromit.com/neptune/man/neptune_layout_slides.html
rfm2

Posts: 116
Registered: 13-Dec-2007
Re: Neptune 38, slide looping
Posted: 03-Jul-2020 03:27   in response to: rfm2 in response to: rfm2
 
  Click to reply to this thread Reply
Thanks for the response. The "Loop slides" and "Timed slideshow" were both unchecked. After I saw the problem I tried various runs with each checked independently and collectively, without solving the problem until I moved the excluded theme image. Just the gremlins, I guess. If I every repeat the problem I'll send you the project file.
rfm2

Posts: 116
Registered: 13-Dec-2007
Re: Neptune 38, slide looping
Posted: 03-Jul-2020 19:03   in response to: rfm2 in response to: rfm2
 
  Click to reply to this thread Reply
In the interest of clarifying my original and latest posts on this thread, I have not been able to verify the conditions I thought existed when the album would loop when manually viewing the images with both the "Loop slides" and "Timed slideshow" options unchecked. It appears that when I imported from an existing project to start a new project, the imported project must have had the "Timed slideshow" checked with an "After slideshow" option of "exit". When I manually viewed the new project with the excluded theme image, the images looped, since the "exit" option after viewing only applies if you use the auto slideshow rather than when manually viewing. Apparently, when I moved the location of the excluded theme image I must have also turned off the "Timed slideshow", so the lack of looping was because of turning off the slideshow option rather than because of moving the location of the theme image.

Sorry for the long explanation, but I didn't want a future Neptune user to see my original post and be as confused as I was (am?).
jGromit

Posts: 6,825
Registered: 31-Jan-2006
Re: Neptune 38, slide looping
Posted: 03-Jul-2020 20:14   in response to: rfm2 in response to: rfm2
 
  Click to reply to this thread Reply
Yes, the looping behavior for a timed slideshow is a little quirky. In short, if you choose the timed slideshow, no matter what option you choose for "after," the images are looped (that's why that option is then grayed out). If you go through manually, it's an endless loop.

If you kick off the timed slideshow, what happens depends on where you start. In a 5-image slideshow, if you start with #3, you see 3, 4, 5, 1, 2, and then it either exits or stops or loops endlessly. It makes some sense - if a visitor started the timed slideshow with #5, you wouldn't want him to see #5 and then exit.

This is the behavior that's built into the Floatbox script. For many Neptune versions I restricted it to just "loop" or "no loop," and if you chose the timed slideshow, you got the endless loop. I finally decided to let the script do what it's designed to do.

But I'm not a fan of timed slideshows - they're a little aggressive, like autoplay videos.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums