This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 25 - Pages: 2 [ Previous | 1 2 ] - Last Post: 04-Apr-2019 18:28 Last Post By: Merlin2504
Merlin2504

Posts: 368
Registered: 25-Jul-2016
Re: Search results will not work
Posted: 03-Apr-2019 18:12   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
The album "7 days test" was added today. These are pictures from 2017.
But if I setting: "last added to the album". Since I think, the date must not matter.
Or I understand that wrong.
Laza

Posts: 2,220
Registered: 6-Sep-2005
Re: Search results will not work
Posted: 03-Apr-2019 19:13   in response to: Merlin2504 in response to: Merlin2504
 
  Click to reply to this thread Reply
Yes, both could work in your case: "Last modified date" and "Added to album" - might worth experimenting which fits better.
Merlin2504

Posts: 368
Registered: 25-Jul-2016
Re: Search results will not work
Posted: 04-Apr-2019 09:08   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
The search results are divided by you into the following:

1. "Date of the last change" - Searches for the modification date of the image in the Exif data.

2. "Shooting Date" - Searches for the shooting date of the image in the Exif data.

3. "Added to Album" - Searches for adding the image. The Exif data of the picture are uninteresting.

Point 3 is either incorrectly translated or programmed incorrectly.
jGromit

Posts: 7,478
Registered: 31-Jan-2006
Re: Search results will not work
Posted: 04-Apr-2019 16:38   in response to: Merlin2504 in response to: Merlin2504
 
  Click to reply to this thread Reply
Attachment ss005299.png (20.2 KB)
Merlin2504 wrote:
3. "Added to Album" - Searches for adding the image.....

Point 3 is either incorrectly translated or programmed incorrectly.


Works for me. Make sure that in the field for the number of days, you have not entered any spaces around the number. That causes the "new" marking to fail.

(Laza - JSpinner!)

ETA: This applies only to the "new" marker. The search box option, on the other hand, does not appear to be working. It refuses to find images added today, no matter how many days I give it. I'll have to tinker to create a good test case for images that are 2, 3, 4, etc. days old.
Merlin2504

Posts: 368
Registered: 25-Jul-2016
Re: Search results will not work
Posted: 04-Apr-2019 16:55   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks for the screenshot.
At this point I had set nothing. It is a bit confusing that the search for new images has to be done in 2 places. See my screenshots.
Now I know it and we can mark the theme as done.

Thanks again for your efforts.
jGromit

Posts: 7,478
Registered: 31-Jan-2006
Re: Search results will not work
Posted: 04-Apr-2019 17:09   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit wrote:
The search box option, on the other hand, does not appear to be working. It refuses to find images added today, no matter how many days I give it. I'll have to tinker to create a good test case for images that are 2, 3, 4, etc. days old.

Pretty much confirmed. Here's a little test album. All of the images were added on Mar. 23, about 12 days ago. The search doesn't find them, even when asking for images added in the last 30 days. I've tried various combinations (current folder, whole album, only one date, etc.), but can't find one that works.

https://jgromit.jalbum.net/bb/

ETA: Rebuilt with debug mode turned on.
Merlin2504

Posts: 368
Registered: 25-Jul-2016
Re: Search results will not work
Posted: 04-Apr-2019 17:24   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Did you, see my screenshots, activated in both places "added to the album"?

Then it works. But must be activated in both places!
jGromit

Posts: 7,478
Registered: 31-Jan-2006
Re: Search results will not work
Posted: 04-Apr-2019 17:27   in response to: Merlin2504 in response to: Merlin2504
 
  Click to reply to this thread Reply
Yes, that does work, but it shouldn't be necessary. You might want to be able to search for new images, but not have the thumbnails showing a "new" marker all the time. The two things should be independent of each other.
Merlin2504

Posts: 368
Registered: 25-Jul-2016
Re: Search results will not work
Posted: 04-Apr-2019 18:07   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit wrote:
......... for new images, but not have the thumbnails showing a "new" marker all the time.

What do you mean by the mark? Can you send me a screenshot?
jGromit

Posts: 7,478
Registered: 31-Jan-2006
Re: Search results will not work
Posted: 04-Apr-2019 18:11   in response to: Merlin2504 in response to: Merlin2504
 
  Click to reply to this thread Reply
Attachment ss005300.png (538.7 KB)
This is the main page of the album, not the "search results."
Merlin2504

Posts: 368
Registered: 25-Jul-2016
Re: Search results will not work
Posted: 04-Apr-2019 18:26   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks, and where do the red crosses come from? where are the settings?
Too bad my english is so bad.

Stop, found it.

Edited by: Merlin2504 on 04-Apr-2019 18:28
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums