This question is answered.


Permlink Replies: 26 - Pages: 2 [ Previous | 1 2 ] - Last Post: 03-Nov-2018 12:48 Last Post By: Roadhouse
Roadhouse

Posts: 101
Registered: 22-Dec-2016
Re: An error
Posted: 02-Nov-2018 03:44   in response to: Roadhouse in response to: Roadhouse
 
  Click to reply to this thread Reply
Attachment custom.JPG (69.6 KB)
Well, I give up now :-(

I have tried anything you have thrown at me - and then some!

I have added almost any role available to the My Album folder (and five minutes ago, I tried to do that on the Document folder and chose to let the sub folders inherit the credentials) but to no avail.

I uninstalled ver. 17 and installed ver. 16 - and made an album using the Minimal skin with only one .mp4 file, to no avail - the error message popped up.

I took loads of .jpg, .tif and .cr2 and made an album based on the Turtle skin, and no problem at all - then I added a small .mp4 file (8mb) - and then the error was there again!

It cannot be a permission error, because I can make albums without problems, as long as they only contain photos! I have tried to make albums with .avi, .mkv and .mp4 - and the same error appears!

And I have followed Robs advice concerning ffmepeg (http://jalbum.net/forum/message.jspa?messageID=308524#308524) - but the text in Step 2 don't correspond with what I see (see screendump)!

I'll try to go to sleep again ... LOL
RobM

Posts: 3,242
Registered: 4-Aug-2006
Re: An error
Posted: 02-Nov-2018 13:01   in response to: Roadhouse in response to: Roadhouse
Helpful
  Click to reply to this thread Reply
Roadhouse wrote:
Well, I give up now :-(
And I have followed Robs advice concerning ffmepeg (http://jalbum.net/forum/message.jspa?messageID=308524#308524) - but the text in Step 2 don't correspond with what I see (see screendump)!
Sorry, I missed the settings change for videos when jAlbum 13.3 was released - I'd already updated FFmpeg and at that time (with jAlbum 13.2) the audio codec needed changing. The current settings don't need the audio codec specifying, so there is no need to make the change.

I'll update those instructions and the image of the video default settings later tonight.

Not sure what to suggest now, maybe a re-install of Windows? Second opinions?
jGromit

Posts: 7,750
Registered: 31-Jan-2006
Re: An error
Posted: 02-Nov-2018 13:29   in response to: RobM in response to: RobM
Helpful
  Click to reply to this thread Reply
RobM wrote:
Not sure what to suggest now, maybe a re-install of Windows? Second opinions?

I'm equally flummoxed. These days, reinstalling Windows isn't a realistic option for most users. My new PC, like the last one, did not come with a DVD-ROM with Windows on it, nor did my Mac come with a copy of macOS - I don't know how I would "reinstall" that, either. In short, I don't have a "fresh copy" to start with.

On the hypothesis that maybe something else is interfering with the file writing, it would be worth booting the PC into "safe mode," and trying a simple one-video album. If that, by some miracle, is successful, I'd start looking at anti-virus packages as the culprit.
AndreWolff

Posts: 1,862
Registered: 14-Dec-2007
Re: An error
Posted: 02-Nov-2018 13:34   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit wrote:
I don't know how I would "reinstall" that, either. In short, I don't have a "fresh copy" to start with.
On a Windows PC: System / Restore settings / Restart a clean installation of Windows
(translated: Dutch -> English)
RobM

Posts: 3,242
Registered: 4-Aug-2006
Re: An error
Posted: 02-Nov-2018 14:10   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit wrote:
I'm equally flummoxed. These days, reinstalling Windows isn't a realistic option for most users. My new PC, like the last one, did not come with a DVD-ROM with Windows on it, nor did my Mac come with a copy of macOS - I don't know how I would "reinstall" that, either. In short, I don't have a "fresh copy" to start with.
A Time Machine disc is the easiest for recovery, for clean install options a good reference is http://osxdaily.com/2018/10/10/how-reinstall-macos-mojave/
Roadhouse

Posts: 101
Registered: 22-Dec-2016
Re: An error
Posted: 02-Nov-2018 18:04   in response to: Roadhouse in response to: Roadhouse
 
  Click to reply to this thread Reply
I too have an idea that it might be antivirus related, and I will look into that. But I definately do not think it is something to do with my windows installation and that it require a re-installation. Because as I wrote in my last post - and this is important to remember - it is ONLY video files jAlbum comes up with a permission problem error! NO other file types generate this error! And when I push Make Album, jAlbum copy the .mp4 file into C:\Users\Frank\Documents\Mine Albums\Katten Anna BUT it does not copy the file to C:\Users\Frank\Documents\Mine Albums\Katten Anna\album\slides!

In the mean time I have disabled my antivirus (Bitdefender), but that doesn't change anything :-(

I have tried to make an album on my Lapto which runs ver. 16.1 and have done that since that release was launched, and which since then with 100% absolutely certainty only have had Bitdefender installed and the forced MS Windows updates ... and it too comes with the error! Soooooo .......

Edited by: Roadhouse on 02-Nov-2018 18:17
Roadhouse

Posts: 101
Registered: 22-Dec-2016
Re: An error
Posted: 02-Nov-2018 18:16   in response to: Roadhouse in response to: Roadhouse
 
  Click to reply to this thread Reply
Attachment 2.JPG (46.6 KB)
Attachment 1.JPG (89.2 KB)
I FAGGIN' FOUND THE SOLUTION!

It IS Bitdefender that cause the problem! I bought it because it was getting the best reviews overall - but I have had SO many problems on my computers, which came because of that bullsh*t :-(

Here is what I found out:

If you look at the first screendump, you can see that Safe File is active. Then if you look at the second screendump, you'll se that 8 folders are 'protected' (!) - including the Documents folder. When I removed that, well then I had no more problems with making albums that included video files!

Thanks to you guys for your input, and screw you, Bitdefender :-(
RobM

Posts: 3,242
Registered: 4-Aug-2006
Re: An error
Posted: 02-Nov-2018 18:52   in response to: Roadhouse in response to: Roadhouse
Correct
  Click to reply to this thread Reply
Roadhouse wrote:
If you look at the first screendump, you can see that Safe File is active. Then if you look at the second screendump, you'll se that 8 folders are 'protected' (!) - including the Documents folder. When I removed that, well then I had no more problems with making albums that included video files!
Glad you got it sorted out. Does seem odd that ‘protected’ folders are only protected against video files ;)

I just use the built-in firewall, which is considered overkill by many as routers take care of most threats and the firewall is off by default too.
jGromit

Posts: 7,750
Registered: 31-Jan-2006
Re: An error
Posted: 02-Nov-2018 18:53   in response to: Roadhouse in response to: Roadhouse
 
  Click to reply to this thread Reply
Glad you found it! :)

Over the years, I've discovered that a lot of anti-virus products make your PC secure by preventing you from using it for anything. It's like making a car safe by removing its wheels - effective, but not really what you had in mind.

I have never gotten an infection on any of my PC's, and all I use are the built-in Windows firewall (and I'm also behind a router), the built-in Windows Defender anti-virus, and the occasional manual scan with the free version of Malwarebytes. Of course, I never open a zip file that's been sent to me by someone I haven't talked to in years, I don't download things from dodgy bittorrent sites, and so on. Some caution is called for, but paranoia isn't.
Roadhouse

Posts: 101
Registered: 22-Dec-2016
Re: An error
Posted: 02-Nov-2018 18:57   in response to: Roadhouse in response to: Roadhouse
 
  Click to reply to this thread Reply
The last from me in this thread - I think you have 'earned' to see what I have experienced after I bought and installed Bitdefender:

"Hi.

Look at this thread - especially the last (my!) post: https://jalbum.net/forum/thread.jspa?threadID=54587&start=15&tstart=0

I am not going to use BD when it expires, I've never experienced so many problems with/on my computers than after I installed your product - and involved so many support teams in trying to solve them. And every time it is because of BD.

  • When i use Explorer on my computers, it takes between 10-20 second for the folders to open!
  • When I am on the internet and hit buttons on misc. pages, it takes extremely long time for them to load!
  • I keep getting the message that BD want me to reboot, and when I have done that, I STILL get this message - and there are NO updates that require restarts :-(
  • Even though I have added my network shares as by your instructions, I keep on losing contact to them.
  • And then the problem mentioned in the thread.

EVERYTHING mentioned above works when I disable BD :-(

Kind regards

Frank"

I could come up with more issues connected to BD, but I am tired!
Roadhouse

Posts: 101
Registered: 22-Dec-2016
Re: An error
Posted: 02-Nov-2018 19:05   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
I had the exact same anti-virus setup as you - but then some day, I had a virus! It was so bad that my PayPal account was suspended - by them (!) and I had a lot of weird errors on all three Windows computers I own! I re-partitioned all my drives, formatted them the slow way, and reinstalled Windows, installed BD - and have avoided vira since then! BUT I have learned that this comes at a price - and I won't pay that. I do not know what caused the virus, I'm pretty cautious on the net, but something went wrong!

But thank you to all of you for your help, jAlbum support is world class - and I might not be the last jAlbum/BD user who runs into this problem!
Roadhouse

Posts: 101
Registered: 22-Dec-2016
Re: An error
Posted: 03-Nov-2018 12:48   in response to: Roadhouse in response to: Roadhouse
 
  Click to reply to this thread Reply
The problem was Bitdefender (anti-virus) that prevented jAlbum from saving videofiles.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums