This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 9 - Pages: 1 - Last Post: 11-Jan-2021 09:00 Last Post By: dcrintea
dcrintea

Posts: 9
Registered: 21-Mar-2010
'Show numbers' not working
Posted: 01-Jan-2021 22:08
 
  Click to reply to this thread Reply
Attachment result.jpg (12.6 KB)
Attachment settings.jpg (94.5 KB)
Hello,

After upgrade to jAlbum 23.1 and Lucid 2.1.2, 'show numbers' is not working.

I attach images for settings and result.

Thanks for guiding me to make this work again.

Edited by: dcrintea on 01-Jan-2021 22:09
JeffTucker

Posts: 7,406
Registered: 31-Jan-2006
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:20   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
Attachment ss008165.png (63.1 KB)
Please give us a link to the album. It's working properly for me when I make a small test album.
dcrintea

Posts: 9
Registered: 21-Mar-2010
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:28   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
My album is on a website protected with a password, I cannot give the link.

In the browser console (F12) I can see one error:

Uncaught TypeError: o.share is undefined
ce http://album..../res/all.min.js?v=2.1.2:24
skin http://album..../res/all.min.js?v=2.1.2:24
JeffTucker

Posts: 7,406
Registered: 31-Jan-2006
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:30   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
So just create a test album using the same project settings, don't password-protect it, and give us a link.
dcrintea

Posts: 9
Registered: 21-Mar-2010
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:33   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
I am creating a test album, coming back in a few minutes.

But I just think that disabling the share button (which was re-enabled automaticall by the skin update, then disabled by me within the settings), is breaking the JS.
dcrintea

Posts: 9
Registered: 21-Mar-2010
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:37   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
Please see the last image attached.

If I enable again the SHare button, numbers are working.

So the bug comes when the share is disabled.
dcrintea

Posts: 9
Registered: 21-Mar-2010
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:39   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
I re-attach the screen capture in jpg.
JeffTucker

Posts: 7,406
Registered: 31-Jan-2006
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:41   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
Ah, yes - I can now replicate the problem.

Under Lucid > Control bar > Social, if either Email or Link is selected, the image numbers display properly. But if neither is selected, they don't.

I'll have to leave this one to Laza to dig into.
dcrintea

Posts: 9
Registered: 21-Mar-2010
Re: 'Show numbers' not working
Posted: 01-Jan-2021 22:42   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
Please see image attached --> how to reproduce the bug.
dcrintea

Posts: 9
Registered: 21-Mar-2010
Re: 'Show numbers' not working
Posted: 11-Jan-2021 09:00   in response to: dcrintea in response to: dcrintea
 
  Click to reply to this thread Reply
Hello,

Would you please fix this JavaScript soon? My album navigation is broken now.

Thanks!
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums