This question is answered.


Permlink Replies: 12 - Pages: 1 - Last Post: 21-Oct-2018 00:34 Last Post By: jGromit
AndreWolff

Posts: 1,862
Registered: 14-Dec-2007
ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 12:47
 
  Click to reply to this thread Reply
I tried to improve the processing of the theme image in my skins, so I looked into the ZigZag skin which uses the 'Set cropping...' context menu item for the Theme image.

I did select a size 1920x200 and next I enlarged the Theme image via the 'Set crop focus...' context menu in the Explorer for the selected image to fine tune the area used to display.

I expected to see a highlighted area with a ratio of about 10:1, but the highlighted area shows a ratio of about 4:1, see attached screen-shot.

Edited:

I copied the ZigZag desgin to my FancyBox skin, but than it is even more weird, see screen-shot FB_ThemeImageNewDesign.PNG

I get a better display if I select the 'Thumbnails bounds option instead of the 'Theme image' option, see screen-shot FB_ThemeImageNewDesignTumbnailsSet.PNG

Edited by: AndreWolff on 18-Oct-2018 14:50
RobM

Posts: 3,241
Registered: 4-Aug-2006
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 15:37   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
This is not really about Zigzag skin, it is about theme images. See Theme image hit and miss post of which this is essentially a duplicate post.
jGromit

Posts: 7,747
Registered: 31-Jan-2006
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 15:49   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
No, this is different, and it's a quirk that I haven't managed to figure out yet (but I've been away from my development machine for the last few weeks).

In ZigZag, and in all of my own skins, changes in the theme image aspect ratio are correctly fed back to the theme image crop mask in the right panel, but not to the theme image crop mask that appears when you invoke the context menu in the main window.

In Tiger, however, it works correctly.

I've had a little email exchange with Laza and David about this - Laza doesn't know why things are behaving differently in his skins, and David seems to have been "missing in action" for a while. I have a couple of things to try when I get home.
AndreWolff

Posts: 1,862
Registered: 14-Dec-2007
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 15:52   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit wrote:
No, this is different, and it's a quirk that I haven't managed to figure out yet (but I've been away from my development machine for the last few weeks).
Indeed this is different.

In my current version of the FancyBox skin, the display of the zoomded theme image is correct, but in a new version where I copied the ZigZag skin theme image code, the display of the zoomed theme image is incorrect, see the screen shots above.

I think you can move this thread to tthe Bug reports thread.

Edited by: AndreWolff on 18-Oct-2018 16:17
jGromit

Posts: 7,747
Registered: 31-Jan-2006
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 17:25   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
AndreWolff wrote:
I think you can move this thread to tthe Bug reports thread.

No, it works correctly in Tiger, so it's clearly a matter of skin UI coding, not a jAlbum bug. It's just not clear what the difference is between skins.
AndreWolff

Posts: 1,862
Registered: 14-Dec-2007
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 17:27   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit wrote:
AndreWolff wrote:
I think you can move this thread to tthe Bug reports thread.

No, it works correctly in Tiger, so it's clearly a matter of skin UI coding, not a jAlbum bug.


Incorrect, the Tiger skin did not enable the Set cropping context menu as is possible with the ZigZag skin!
If the Set context menu item is not used then it works also correctly in the current version of my Fancybox skin.

Edited by: AndreWolff on 18-Oct-2018 17:33
jGromit

Posts: 7,747
Registered: 31-Jan-2006
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 17:36   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
AndreWolff wrote:
jGromit wrote:
AndreWolff wrote:
I think you can move this thread to tthe Bug reports thread.

No, it works correctly in Tiger, so it's clearly a matter of skin UI coding, not a jAlbum bug.

Incorrect. the Tiger skin did not enable the Set cropping cotext menu as is possible with the ZigZag skin!

Edited by: AndreWolff on 18-Oct-2018 17:30


The underlying coding issue is the same - the skin is doing something that changes the theme image crop focus. It's shown correctly in the right panel, but not in the context menu popup.

André, if you expect to get help, you have to stop labeling anything you don't understand as a "bug." It's really very tiresome.
AndreWolff

Posts: 1,862
Registered: 14-Dec-2007
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 17:46   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit wrote:
The underlying coding issue is the same - the skin is doing something that changes the theme image crop focus. It's shown correctly in the right panel, but not in the context menu popup.
With the Crop focus context menu, is not the skin doing something, it is the jAlbum core doing something!
André, if you expect to get help, you have to stop labeling anything you don't understand as a "bug." It's really very tiresome.
Well that might be my bad understanding of the English language, but I see that the display is not what a user expects, so it is incorrectly implemented. I thought English people do call this a bug. It is not meant as an insult, I just try to make jAlbum better as it already is!
jGromit

Posts: 7,747
Registered: 31-Jan-2006
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 17:52   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
AndreWolff wrote:
With the Crop focus context menu, is not the skin doing something, it is the jAlbum core doing something!

Again, no. It's the skin not passing the information to the core in the way that it needs to. I don't know what the missing piece of the puzzle is, but it's in the skin UI coding somewhere.

I give up. Yes, this is a jAlbum core bug. You should immediately uninstall jAlbum, and not use it again until this is corrected. Don't bother checking in - we'll get back to you.
AndreWolff

Posts: 1,862
Registered: 14-Dec-2007
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 18-Oct-2018 21:52   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
Attachment FB_1920x400.PNG (535.3 KB)
Attachment FB_1920x100.PNG (564.1 KB)
Attachment PS_1920x100.PNG (428.3 KB)
The effect depends on the used dimensions:

If I select cropping 1920x100 there is a big difference, see screen-shot FB_1920x100.PNG

If I select cropping 1920x400 the zoomed image looks OK, see screen-shot FB_1920x400.PNG

If the cropping dimensions are selected in the skin, like in the PhotoSwipe skin which has no Set cropping focus context menu, there is no problem: If I select cropping 1920x100 the zoomed image is OK, see screen-shot PS_1920x100.PNG

Edited by: AndreWolff on 18-Oct-2018 22:41
davidekholm

Posts: 3,688
Registered: 18-Oct-2002
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 20-Oct-2018 19:00   in response to: AndreWolff in response to: AndreWolff
Correct
  Click to reply to this thread Reply
Attachment CropFocus.jaext (32.7 KB)
Guys, I've been absent as I've worked fully on the new v17 release and its new Review mode.

Isn't the core problem that the older "Set crop focus" plugin doesn't reflect the changes made since we added the theme image selector and updated Zigzag? I looked inside the "Set crop focus" tool and found that it was hard wired to a 3.75 aspect ratio for theme images unless it could find a "folderImageSize" skin variable and read the ratio out of that one. I've now updated the "Set crop focus" tool to pick the ratio from the engine, just as the theme image selector does. Put the attached file inside jAlbum'e ext folder and restart jAlbum. Now select Zigzag and pick an extreme ratio, like 1200x100. Now pop up the "Set crop focus" tool and select "Theme image". It should now respect this ratio.
AndreWolff

Posts: 1,862
Registered: 14-Dec-2007
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 20-Oct-2018 19:36   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
davidekholm wrote:
I looked inside the "Set crop focus" tool and found that it was hard wired to a 3.75 aspect ratio for theme images unless it could find a "folderImageSize" skin variable and read the ratio out of that one. I've now updated the "Set crop focus" tool to pick the ratio from the engine, just as the theme image selector does. Put the attached file inside jAlbum'e ext folder and restart jAlbum. Now select Zigzag and pick an extreme ratio, like 1200x100. Now pop up the "Set crop focus" tool and select "Theme image". It should now respect this ratio.
Yes, that solves the problem!

I am happy you solved it, because I added the ZigZag way of selecting the theme image to my Slide Show 4 skin, my PhotoSwipe skin and my FancyBox skin!

If you are ready with the new v17 coding, please give your opinion over my theme image feature request.
jGromit

Posts: 7,747
Registered: 31-Jan-2006
Re: ZigZag skin displays 'Set crop focus…' image incorrectly
Posted: 21-Oct-2018 00:34   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
davidekholm wrote:
...unless it could find a "folderImageSize" skin variable and read the ratio out of that one.

And that's why it worked in Tiger and Turtle, but not in my skins! In Laza's skins, the variable is, indeed, folderImageSize. But in my skins, the variable is themeImageSize (and the skin.properties file tells the core about that), so it wasn't getting picked up.

I'm still unloading the car from my return from the beach, but I'll do some testing later.

(David - you'll see a string of emails on this subject, which you can probably now ignore. Neither Laza nor I could figure out why skins were behaving differently.)
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums