This question is answered.


Permlink Replies: 7 - Pages: 1 - Last Post: 26-Jun-2019 18:36 Last Post By: ianferris Threads: [ Previous | Next ]
ianferris

Posts: 6
Registered: 31-May-2009
'Make album' and 'Upload' issues
Posted: 18-Jun-2019 18:44
 
  Click to reply to this thread Reply
Attachment Screenshot 4.png (290,2 KB)
Attachment Screenshot 3.png (3,0 MB)
Attachment Screenshot 2.png (2,4 MB)
Attachment Screenshot 1.png (3,0 MB)
Machine: Mac
jAlbum: 18.2.1
Skin: Tiger
See attachments

I've certainly got an 'Uploading albums' issue but I also have a 'Make album' issue too and hope this is a suitable forum to ask for for help. Let me take the 'Make album' issue first:

'Make album' actually works fine in that it does make the highlighted album 'Scotland, May 2019' and all its subdirectory albums. When the process finishes the Preview pane properly shows the Scotland... directory and its subdirectories and navigation works properly. But what 'Make album' also does is process subsequent non-highlighted directories, in order, (generating many unnecessary files that are subsequently uploaded to 'Scotland...' directory on the server). See attachments 1, 2 & 3.

'Upload' also completes satisfactorily but the generated Scotland... web pages are blank. Filezilla shows that the additional 'rogue' directories are also uploaded to the server (which I subsequently deleted). I'm not aware what server files are necessary after the upload so attach a further screenshot 4.

Let me know if any further info required.
Appreciate your help! :-)

Ian.
JeffTucker

Posts: 6,878
Registered: 31-Jan-2006
Re: 'Make album' and 'Upload' issues
Posted: 18-Jun-2019 20:13   in response to: ianferris in response to: ianferris
 
  Click to reply to this thread Reply
I think you've got a conceptual problem, here. Scotland, May 2019 is not an album project. Your album project is actually Latest photos, and Scotland, May 2019 is just a folder within that album project, along with all the others, like Leah and Rob's wedding, Mykonos, September 2018, and so on.

When you make the album, it processes all the folders within that album, as it should. Again, it's not going to create a single album called Scotland, May 2019 - the album is called Latest photos, and Scotland, May 2019 is just one folder within that album.

Similarly, in order for the album to work properly on the server, the whole album must be uploaded. The Scotland, May 2019 folder, for example, depends on some files that are common to the complete album, so you can't upload just Scotland, May 2019 and expect anything to work properly.

The jAlbum uploader is smart enough to upload only the new or changed files - you don't have to upload the entire album every time. The uploader will simply skip rapidly over the things that are already there. If you're using FileZilla to do the uploading, you need to tell FileZilla to upload only new or changed files.

You should not be manually deleting anything from the server - in this case it looks as if you've deleted the slides folder, for example, which contains the images you want to view!
ianferris

Posts: 6
Registered: 31-May-2009
Re: 'Make album' and 'Upload' issues
Posted: 18-Jun-2019 22:20   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Attachment Screenshot 6.png (434,1 KB)
Ah! Many thanks, Gromit, conceptual error corrected! I don't believe I've deleted any slides folders but I was indeed trying to create and upload just a Scotland.... 'album' and my Upload was incorrectly pointed to the Scotland subdirectory so now I understand my error on this point.

So, how might I now correct the 'Latest photos' album and regenerate the missing 'slides' directories, please?
I selected 'Latest photos' (rather than 'Scotland...') and hit 'Make album'. After processing, many of the slides subdirectories are still not present, e.g. Scotland... does not have a slides directory, nor does '1 Arrochar & Loch Long' but '2 On & around Loch Lomond' does. See new attachment 6.

Ian
JeffTucker

Posts: 6,878
Registered: 31-Jan-2006
Re: 'Make album' and 'Upload' issues
Posted: 18-Jun-2019 23:50   in response to: ianferris in response to: ianferris
 
  Click to reply to this thread Reply
I really can't diagnose a screenshot. Perhaps you have told jAlbum to Link to originals, in which case there won't be a slides subdirectory. But unless you've resized the images outside of jAlbum, the originals are probably much too large to be used in a web photo album, and you should be letting jAlbum resize the images.

I can't seem to get to your site at all - the main page is down completely, and the Scotland folder within Latest photos is returning some sort of empty "parking" page, something that your web host provides when there's no other content there. I can't sort it out, because there's simply nothing to look at.
ianferris

Posts: 6
Registered: 31-May-2009
Re: 'Make album' and 'Upload' issues
Posted: 24-Jun-2019 23:24   in response to: JeffTucker in response to: JeffTucker
 
  Click to reply to this thread Reply
Hi Gromit. I added a new 'Scotland' folder over the weekend, quite straightforward as jAlbum had processed the images & saved most settings, and of course it worked first time. I put it alongside the original Scotland folder and I couldn't find any differences between them but at least it worked and I've deleted the broken folder.

Since then I'm now getting memory errors. I'm guessing this is . because I may be adding too many new folders together?

An unexpected error occurred. Please see detailed description below:

java.lang.OutOfMemoryError: Java heap space
at java.desktop/java.awt.image.DataBufferByte.<init>(Unknown Source)
at java.desktop/java.awt.image.Raster.createInterleavedRaster(Unknown Source)
at java.desktop/com.sun.imageio.plugins.jpeg.JPEGImageReader.readInternal(Unknown Source)
at java.desktop/com.sun.imageio.plugins.jpeg.JPEGImageReader.readRaster(Unknown Source)
at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.readImageAsRasterAndReplaceColorProfile(JPEGImageReader.java:498)
at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.read(JPEGImageReader.java:388)
at se.datadosen.util.FileFilters.doLoadImage(FileFilters.java:692)
at se.datadosen.util.FileFilters.loadImage(FileFilters.java:589)
at se.datadosen.jalbum.AlbumBean$StandardImageProcessor.processImage(AlbumBean.java:5819)
at se.datadosen.jalbum.AlbumBean$StandardImageProcessor.processImages(AlbumBean.java:5688)
at se.datadosen.jalbum.AlbumBean$ImageProcessingTask.call(AlbumBean.java:5618)
at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)

Thanks & regards,
Ian.

JeffTucker

Posts: 6,878
Registered: 31-Jan-2006
Re: 'Make album' and 'Upload' issues
Posted: 24-Jun-2019 23:27   in response to: ianferris in response to: ianferris
Correct
  Click to reply to this thread Reply
Try the standard fixes for the Java heap space error:

https://jalbum.net/forum/thread.jspa?threadID=38632
RobM

Posts: 3,226
Registered: 4-Aug-2006
Re: 'Make album' and 'Upload' issues
Posted: 24-Jun-2019 23:30   in response to: ianferris in response to: ianferris
 
  Click to reply to this thread Reply
See Gromit's tip on out of memory errors
ianferris

Posts: 6
Registered: 31-May-2009
Re: 'Make album' and 'Upload' issues
Posted: 26-Jun-2019 18:36   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Great help. Back on track again. Many thanks, both. :-)
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums