This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 19 - Pages: 2 [ 1 2 | Next ] - Last Post: 23-Feb-2019 22:27 Last Post By: RobM Threads: [ Previous | Next ]
daveturk

Posts: 39
Registered: 21-Sep-2008
Unable to set folder thumbnails
Posted: 23-Feb-2019 06:17
 
  Click to reply to this thread Reply
Attachment Screenshot_3.png (693.8 KB)
Attachment Screenshot_2.png (512.1 KB)
Attachment Screenshot_1.png (369.6 KB)
For example, I have a folder named '2019'. In the 2019 folder there are two more folders ('01 - January' and '02 - February') and an image 'IMG_3201.jpg'. I have selected the image to be the folder thumbnail by right-clicking and checking 'Use as folder thumbnail'. That image also shows up on the right panel under 'Thumbnail' and 'Theme image'. See Screenshot_1

However, when I build the album it is selecting the first image in the '01-January' folder to be the thumbnail for the '2019' folder and try as I might I cannot get this to change. It is also using this same image for the Hero theme strip. See Screenshot_2 and Screenshot_3

I've tried using the built-in browser and Firefox with same results.

I've tried completely clearing my browser cache and history with same results.

I'm stumped.

Any help would be greatly appreciated.

Thanks,
Dave

Using jAlbum 18.0.1 - Java 11, 64 bit
Using Tiger skin 2.4.4
Windows 10, 64-bit
Laza

Posts: 2,199
Registered: 6-Sep-2005
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 09:50   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Check if you haven't turned off refreshing the subfolders:
Settings / Advanced / Process only updated subdirectories should be turned OFF.
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 16:01   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Attachment Screenshot_4.png (35.1 KB)
That setting is OFF. See attached.
RobM

Posts: 3,063
Registered: 4-Aug-2006
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 19:10   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Please don’t post the same question in two forums, if Laza thinks it is not skin specific he, or another admin, can move the post to the general discussion forum. However, I have replied to your other post.
Laza

Posts: 2,199
Registered: 6-Sep-2005
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 19:12   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Sorry, I just guessed. Please give a link to the album. I guess the album is too large to be able to send it as ZIP. Try to select other thumbs, instead of right-click try to drag the thumb onto the right panel. Normally this should not happen. Can you record a screencast, so we might spot where it fails.
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 19:47   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Sorry, I thought perhaps it is not a skin issue. Won't do it again.
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 19:51   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Attachment Album.zip (4.1 MB)
Album zip file is attached.

What SW do you recommend to record a screen session?

Thanks,
Dave
RobM

Posts: 3,063
Registered: 4-Aug-2006
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 20:03   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
What I meant was to check the output folders (the album) to see if the theme images ‘created/modified date’ is newer than the other images (slide or thumbs), if it is not a ‘new’ project - that is you made the project and then changed the theme images.

Deleting the existing output theme images would ensure new ones were created, possibly the correct ones.
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 20:11   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Okay. I deleted the entire output folder and sub-folders and tried again with same results. Does that accomplish what you were suggesting?

Thanks,
Dave
RobM

Posts: 3,063
Registered: 4-Aug-2006
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 20:18   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
daveturk wrote:
Album zip file is attached.

What SW do you recommend to record a screen session?

Thanks,
Dave

I used the lifeboat file to get your project settings, and the images from the album to re-create a project. Building the album gave the correct theme images, adding more images and changing theme images also worked on just clicking on 'Make album'.
RobM

Posts: 3,063
Registered: 4-Aug-2006
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 20:20   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
daveturk wrote:
Okay. I deleted the entire output folder and sub-folders and tried again with same results. Does that accomplish what you were suggesting?

Thanks,
Dave

Yes.
The only thing left is to zip the actual project folder and either provide a link to it (you can do that by private messages if you prefer) or if small enough attach it here - if willing.
RobM

Posts: 3,063
Registered: 4-Aug-2006
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 20:37   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Ok, I have reproduced your project using the lifeboat file and slide images.
See attached images that show the project view and the album's theme folders.
All is working correctly.
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 21:42   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
I've zipped the Image directory (Pictures_for_web_site.zip).

I've zipped the jAlbum output directory (jAlbum.zip)

If either of the above do not contain the project folder you're referring to please let me know where I can find that and I will zip and upload it.

Thanks,
Dave
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 21:43   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Attachment jAlbum.zip (4.1 MB)
Here is the jAlbum.zip file
RobM

Posts: 3,063
Registered: 4-Aug-2006
Re: Unable to set folder thumbnails
Posted: 23-Feb-2019 21:44   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Attachment Test project.zip (3.1 MB)
Try the attached project, put it in the same location as your normal project - F:>Users>Dave>Pictures>Test project.
Double click the project settings to open the project and build the album, is it correct?

NB, if you see any weird Mac folders just delete them from the project.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums