This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 14 - Pages: 1 - Last Post: 19-Feb-2018 15:30 Last Post By: davidekholm
ctwist

Posts: 1,517
Registered: 27-Sep-2003
v15 fileVariables error
Posted: 25-Nov-2017 00:49
 
  Click to reply to this thread Reply
Generation of an ExhibitPlus album in v15 fails because
fileVariables.get(files[i])
returns null. This returns a populated map in v14.1.

The release notes mention "Old code solutions factored out". Does this mean that support for fileVariables been dropped?
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 25-Nov-2017 11:53   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
Hi. No I should not have factored out that code. Can't reproduce either. I just downloaded E+ from our repository and built Sample Portfolio fine with jAlbum 15.
ctwist

Posts: 1,517
Registered: 27-Sep-2003
Re: v15 fileVariables error
Posted: 25-Nov-2017 23:49   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
ExhibitPlus gets a nullPointerException when it gets fileVariables for a linked image.

BluPlusPlus is also unstable in v15, but not in 14. This also uses fileVariables.

I don't have time to investigate these problems right now.
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 26-Nov-2017 00:12   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
Just bring me a minimalist project that reproduces it and I'll look into it.
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 26-Nov-2017 13:12   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
This is tricky. I can't seem to understand what might have changed to fileVariables. I can reproduce the problem with E+ and BPP but only a couple of times. All of a sudden it seems stable and then I can't investigate it further naturally :-(
ctwist

Posts: 1,517
Registered: 27-Sep-2003
Re: v15 fileVariables error
Posted: 26-Nov-2017 19:06   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
I can't make a reproducible example of this error.

E.g.
  • A simple E+ album containing 2 images (one of them was linked) failed consistently.
  • I renamed the linked file from 100_2004.JPG to test1.JPG and attached it to the album and the album generated successfully.
  • I renamed the file to its original name and re-attached it to the album and the error occurred again when I made the album.

I have run out of ideas.
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 27-Nov-2017 12:02   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
I can only trigger it occasionally too. As soon as I though I had a pattern to reproduce it, it starts working again :-(
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 27-Nov-2017 12:03   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
A "workaround" is naturally to rewrite these skins and do away with the reliance on fileVariables...
ctwist

Posts: 1,517
Registered: 27-Sep-2003
Re: v15 fileVariables error
Posted: 27-Nov-2017 15:01   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
The rewrite is in progress for E+. It should be available very soon.

For BPP, this is on my task list.
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 27-Nov-2017 15:12   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
Happy to hear :-)
ctwist

Posts: 1,517
Registered: 27-Sep-2003
Re: v15 fileVariables error
Posted: 12-Jan-2018 00:26   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
Some more information about this bug:
  • It only occurs if multiple threads are selected. I cannot reproduce it if "number of threads" is set to 1 in the preferences.
  • After the error has occurred, if the album is regenerated, it usually proceeds without an error. If you want to see the error again, close the project and open it again.
  • The error occurs in a coliterator within a rowiterator. Randomly, fileVariables for the current object is null.

Edited by: ctwist on 11-Jan-2018 18:30

Edited by: ctwist on 12-Jan-2018 17:00
ctwist

Posts: 1,517
Registered: 27-Sep-2003
Re: v15 fileVariables error
Posted: 12-Jan-2018 23:02   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
Ignore my previous message. The error has also occurred with a single thread; it just doesn't happen as frequently.

So, I don't have any additional insight into what causes the problem.
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 16-Jan-2018 14:15   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
I'm sorry I don't have a clue on how to address this rare error either.
ctwist

Posts: 1,517
Registered: 27-Sep-2003
Re: v15 fileVariables error
Posted: 18-Feb-2018 14:37   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
In 15.2, I can't reproduce this bug. The person who originally reported it has also confirmed that the bug is fixed.
davidekholm

Posts: 21,759
Registered: 18-Oct-2002
Re: v15 fileVariables error
Posted: 19-Feb-2018 15:30   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
I keep my fingers crossed :-D
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums