This question is answered.


Permlink Replies: 18 - Pages: 2 [ Previous | 1 2 ] - Last Post: 14-Nov-2017 13:28 Last Post By: davidekholm Threads: [ Previous | Next ]
jGromit

Posts: 21,668
Registered: 31-Jan-2006
Re: Image won't load
Posted: 11-Nov-2017 18:57   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
Good - I'll check again with the next beta.

It was just a surprise that it failed, because I've been using that image (along with others) in test albums for years, without any problems.
davidekholm

Posts: 10,828
Registered: 18-Oct-2002
Re: Image won't load
Posted: 13-Nov-2017 12:50   in response to: jGromit in response to: jGromit
Correct
  Click to reply to this thread Reply
jGromit wrote:
Good - I'll check again with the next beta.

It was just a surprise that it failed, because I've been using that image (along with others) in test albums for years, without any problems.


I think it's a side effect of Java 9 having a somewhat more capable image reader, meaning that some thumbnail reading that was totally ignored by Java 8 is now attempted by Java 9, but caused this failure. I solved the problem by catching a wider range of possible failures and resorting to a fallback.

Edited by: davidekholm on 14-Nov-2017 13:27
(changed "not" to "now")
jGromit

Posts: 21,668
Registered: 31-Jan-2006
Re: Image won't load
Posted: 13-Nov-2017 19:30   in response to: davidekholm in response to: davidekholm
 
  Click to reply to this thread Reply
Yes, these images are happy in jAlbum 14.2b14. :)
davidekholm

Posts: 10,828
Registered: 18-Oct-2002
Re: Image won't load
Posted: 14-Nov-2017 13:28   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks for confirming

Point your RSS reader here for a feed of the latest messages in all forums