This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 2 - Pages: 1 - Last Post: 02-Nov-2017 09:10 Last Post By: Laza Threads: [ Previous | Next ]
Nordschleife

Posts: 71
Registered: 18-Dec-2012
Folder images disappear after short time. Problem with 1.4.1; 1.3.0 is o.k.
Posted: 01-Nov-2017 16:45
 
  Click to reply to this thread Reply
Hello,
today I wanted to add some pictures to a folder in my album which I took yesterday. When checking the preview I noticed that all folder images are not visible and the folders are not clickable. Then I checked the album which is online and found the same problem there.

Here my observations:
  • the problem is only present in one folder of the album. I've checked all other 1st level folder and none had a problem

  • sometimes the folder images can be seen for a short time. Once I was fast enough and recognized that the folder was clickable while the images where shown. After the images disappeared the folder was not clickable any more

  • I remembered that there was an error message when I received the notice that there was Tiger 1.4.1 was available. That's why I moved ~/.jabum/skins/Tiger to ~/.jalbum/skiks/Tiger.Fehler. After starting jAlbum new Tiger version 1.3.0 was active. Making changes led to a working local version. After updating to Tiger 1.4.1, without error, the problem appeared again.

  • selecting subfolders of folder "Dampf" from the navigation bar at the top of the page works fine

  • recreating the whole album didn't solve the problem

  • making changes is configured to create all folders, not only the ones with changes

  • Problem is the same with browsers Firefox, Chromium, Konqueror and Internet Explorer

Link to the online ablum with the problem:
https://www.doh.photos/media/Dampf/index.html

My environment:
Linux bond 4.13.10-1-default #1 SMP PREEMPT Fri Oct 27 09:03:09 UTC 2017 (db36cf8) x86_64 x86_64 x86_64 GNU/Linux

Online album was created with Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Problem is the same with 1..8.0_151

With Tiger version 1.4.1 the problem is present. The album with Tiger version 1.3.0 does not have this problem.

Firefox 56.0 (64-Bit)
Chromium Version 62.0.3202.75 (openSUSE Build) (64-Bit)

On a windows 7 laptap, latest SP, with IE 11.0.9600.19916 the problem is the same.

Any help is appreciated. Thank you.

jGromit

Posts: 33,190
Registered: 31-Jan-2006
Re: Folder images disappear after short time. Problem with 1.4.1; 1.3.0 is o.k.
Posted: 01-Nov-2017 17:02   in response to: Nordschleife in response to: Nordschleife
 
  Click to reply to this thread Reply
Never seen this one before, but that page is trying to load folder thumbnail images with names like this:

P1150529.RW2

That's a Lumix RAW file, and it certainly shouldn't be part of the output directory of the album.

I can confirm the problem - if I build a Tiger album with NEF files (Nikon's RAW format), the links to the folder images are incorrect.

Laza will have to poke around with this one - the JSON files correctly point to the JPG files, and the JPG files are in the output, but the skin is calling the NEF files, which aren't in the output.
Laza

Posts: 9,471
Registered: 6-Sep-2005
Re: Folder images disappear after short time. Problem with 1.4.1; 1.3.0 is o.k.
Posted: 02-Nov-2017 09:10   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Yes, when I made the utility to save the folder thumbnails at the upper level folder I didn't think of the RAW files, that is their extension will change to "jpg". Fixed it now, and will be inclued in the next skin update.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums