This question is answered. Helpful answers available: 1. Correct answers available: 1.


Permlink Replies: 10 - Pages: 1 - Last Post: 26-Sep-2017 12:29 Last Post By: benhat
Shuttergrub

Posts: 5
Registered: 6-Jul-2005
Index page missing thumbnails and hyperlinks
Posted: 18-Sep-2017 03:16
 
  Click to reply to this thread Reply
I created album from scratch (no conversions) and only half of my thumbnail and links work on album thumbs.

See here: http://rixclix.com/RixClix/album/index.html
Any help much appreciated
jGromit

Posts: 33,207
Registered: 31-Jan-2006
Re: Index page missing thumbnails and hyperlinks
Posted: 18-Sep-2017 04:09   in response to: Shuttergrub in response to: Shuttergrub
 
  Click to reply to this thread Reply
About half of the thumbnail images have not been uploaded to the server. For example, this:

http://rixclix.com/RixClix/album/2013/folderthumb.jpg

Returns a "404 - Not found."
Shuttergrub

Posts: 5
Registered: 6-Jul-2005
Re: Index page missing thumbnails and hyperlinks
Posted: 18-Sep-2017 16:11   in response to: Shuttergrub in response to: Shuttergrub
 
  Click to reply to this thread Reply
I should have been more clear. Years 2007, 2010, 2012, 2013 do not have any albums (yet). They should be empty. The years that should link to an album with a thumbnail are 2006, 2008, 2009, & 2011. All remaining years are working, as is the drop-down menu bar.

I have tried assigning different thumbnails and have dropped images into the "year" folder, assigned and excluded the image. Nothing works, The HTML code looks, in my novice eyes, OK. Maybe someone with better code experience (which is anyone other than me!) can see something out of place.
Laza

Posts: 9,472
Registered: 6-Sep-2005
Re: Index page missing thumbnails and hyperlinks
Posted: 18-Sep-2017 16:36   in response to: Shuttergrub in response to: Shuttergrub
Helpful
  Click to reply to this thread Reply
The skin isn't prepared for the empty folders yet. Just add one image in those folders and "exclude" them. Also click the "Heart" icon, to make sure folderthumb.jpg's are generated. I will fix this in the upcoming version.
Shuttergrub

Posts: 5
Registered: 6-Jul-2005
Re: Index page missing thumbnails and hyperlinks
Posted: 18-Sep-2017 17:00   in response to: Shuttergrub in response to: Shuttergrub
 
  Click to reply to this thread Reply
With a little closer look I found for the years that don't work:
<div class="column"><div class="card folder *preload*">
<a href="2006/index.html" class="thumb vertical-middle"><*_img src_*="2006/folderthumb.jpg">
For the years that do work I found:
<div class="column"><div class="card folder *lazyload*">
<a href="2015/index.html" class="thumb vertical-middle" *_data-thumb_*="2015/folderthumb.jpg">

Changing syntax of the broken one to match the working one fixes it. So my question now: How to get Tiger Skin to create the same syntax for all albums. I wouldn't want to edit every time I publish!

Edited by: jGromit to use proper "code" tags
Shuttergrub

Posts: 5
Registered: 6-Jul-2005
Re: Index page missing thumbnails and hyperlinks
Posted: 18-Sep-2017 17:07   in response to: Shuttergrub in response to: Shuttergrub
 
  Click to reply to this thread Reply
That did it. Thanks! I just inserted a "Coming soon" image. Thanks again!
benhat

Posts: 5
Registered: 25-Jul-2014
Re: Index page missing thumbnails and hyperlinks
Posted: 25-Sep-2017 18:24   in response to: Shuttergrub in response to: Shuttergrub
 
  Click to reply to this thread Reply
i am having the same problem. And the workaround does not work for me.
Just a simple sub-folder directly under root, Images directly in it. Marked on image as favorite icon/folder icon.
In the preview function in jalbum and in firefox/chrome locally i do not see thumbnails images, and i can not click the folder to open. Nothing happening.

Maybe it works after upload? But i don't want to test because upload of album will take hours!
Thank you

Edited by: benhat on 25-Sep-2017 18:25

Edited by: benhat on 25-Sep-2017 18:28
Laza

Posts: 9,472
Registered: 6-Sep-2005
Re: Index page missing thumbnails and hyperlinks
Posted: 26-Sep-2017 11:21   in response to: benhat in response to: benhat
 
  Click to reply to this thread Reply
This might be a different error, as selecting a folder image should fix it alone.

Please check if jAlbum is allowed to process the subfolders:
benhat

Posts: 5
Registered: 25-Jul-2014
Re: Index page missing thumbnails and hyperlinks
Posted: 26-Sep-2017 12:14   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Everything is as it is in your screenshot.
I created a new album and just used 1 folder and 1 image in it. And there it works.
I will try to figure out what is happening
Laza

Posts: 9,472
Registered: 6-Sep-2005
Re: Index page missing thumbnails and hyperlinks
Posted: 26-Sep-2017 12:19   in response to: benhat in response to: benhat
 
  Click to reply to this thread Reply
Peek into the browser's "Developer tools" (F12) to see if any javascript error has happened.

Normally Chrome and Opera won't allow local JSON access, but you can read here how you can start the browser to allow local testing.
https://jalbum.net/forum/ann.jspa?annID=172
benhat

Posts: 5
Registered: 25-Jul-2014
Re: Index page missing thumbnails and hyperlinks
Posted: 26-Sep-2017 12:22   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
ok wait... it is just because "only one folder" needs to be empty, and no folder will show thumbnails / links not working.

So, i guess in a way i was wrong about my error and it is the same as above from other people.
So to make it clear, every folder needs an image in it, else the whole album doesn't work on the index page. Even the ones you don't need :)

SORRY FOR THE CONFUSION.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums