This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 4 - Pages: 1 - Last Post: 28-Aug-2017 23:54 Last Post By: jwinslow Threads: [ Previous | Next ]
jwinslow

Posts: 88
Registered: 2-May-2012
Error loading tree.json
Posted: 28-Aug-2017 23:40
 
  Click to reply to this thread Reply
So I just built my album again, and like usual, I manually uploaded the updated files Due to the outrageous size of my album, I have to do it manually. (tree.json, data1.json, index.html, res folder) in the root plus all of the relevant files at each additional nested level that was updated, as well as the new folder/sub-gallery files.

In the past when I've run into the "only loads 6 images" problem, it's because I failed to update the tree.json file, or my webserver took 10-90 minutes to display the updated files, but eventually a simple and complete upload clears it up. Not this time.

For some reason, I'm getting this error:
jquery.min.js:4 GET http://www.jwinslow.com/photos/Equestrian/tree.json net::ERR_EMPTY_RESPONSE
send @ jquery.min.js:4
ajax @ jquery.min.js:4
r.(anonymous function) @ jquery.min.js:4
getJSON @ jquery.min.js:4
T @ all.min.js?v=1.6.8:7
R @ all.min.js?v=1.6.8:7
e.fn.skin @ all.min.js?v=1.6.8:20
(anonymous) @ index.html:137
j @ jquery.min.js:2
k @ jquery.min.js:2
setTimeout (async)
(anonymous) @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
fire @ jquery.min.js:2
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
R @ jquery.min.js:3
all.min.js?v=1.6.8:7 
 
Error loading "tree.json". Please note, JSON support is required for this album, but it's blocked in Chrome and IE when viewing local albums. The uploaded album will work fine, however.
all.min.js?v=1.6.8:7 

The entire website was functional before this upload. Now not only is the new section not working, but all of the old, functional content is not loading too. I'm pretty sure this is strictly a tree.tson issue but I'm not positive.

Here's an example of the incomplete gallery that shows up throughout the site now:
http://www.jwinslow.com/photos/Equestrian/2016/10.06-09.Showtime/Friday/313.Pointe.Taken/index.html

Edited by: jwinslow on 28-Aug-2017 17:41

Edited by: jwinslow on 28-Aug-2017 17:41

Edited by: jwinslow on 28-Aug-2017 17:42
jwinslow

Posts: 88
Registered: 2-May-2012
Re: Error loading tree.json
Posted: 28-Aug-2017 23:48   in response to: jwinslow in response to: jwinslow
 
  Click to reply to this thread Reply
So I'm going to leave this up, in case anyone else runs into this. The problem wasn't with the album, or the server, it was the unstable internet connection (mine) accessing the server.

After fighting with the wrong end of things for 30-60 minutes, I drove to another location and tried the website and it worked perfectly
RobM

Posts: 4,382
Registered: 4-Aug-2006
Re: Error loading tree.json
Posted: 28-Aug-2017 23:52   in response to: jwinslow in response to: jwinslow
 
  Click to reply to this thread Reply
jwinslow wrote:
Here's an example of the incomplete gallery that shows up throughout the site now:
http://www.jwinslow.com/photos/Equestrian/2016/10.06-09.Showtime/Friday/313.Pointe.Taken/index.html
That page says it has 34 files and I see all 34 thumbnails.
RobM

Posts: 4,382
Registered: 4-Aug-2006
Re: Error loading tree.json
Posted: 28-Aug-2017 23:53   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Just read your follow up post, glad you got it sorted.
jwinslow

Posts: 88
Registered: 2-May-2012
Re: Error loading tree.json
Posted: 28-Aug-2017 23:54   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Thanks Rob. It turns out that it was my internet connection. (TWC, now spectrum)

I've struggled with the 6 thumbnail thing before, so I wrongly overlooked that unending source of consternation.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums