This question is answered.


Permlink Replies: 8 - Pages: 1 - Last Post: 27-Aug-2017 00:47 Last Post By: jGromit Threads: [ Previous | Next ]
femoree

Posts: 4
Registered: 12-Jan-2016
Unexpected reaction
Posted: 22-Aug-2017 14:01
 
  Click to reply to this thread Reply
Gromit is my favourite skin. I have always used it without a problem. However since about 2 months now whenever I rendered it (I use it as standalone on my website) I don't get the expected result. What happens is when I click on the thumbnail the picture is shown like for a nano-second in the expected format and then shrinks to a very small format. I have been using the same settings for ages. It is only since about 2 months that I get this reaction.
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Unexpected reaction
Posted: 22-Aug-2017 14:03   in response to: femoree in response to: femoree
 
  Click to reply to this thread Reply
Please give us a link to your site. No one else has reported these kinds of symptoms. The skin is now fully responsive, but that should produce only the kind of resizing you see on my demo site, https://jgromit.com/gromit/
femoree

Posts: 4
Registered: 12-Jan-2016
Re: Unexpected reaction
Posted: 22-Aug-2017 16:44   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
I have found where the problem lies. I always add a youtube embed code to the pictures page. Something like
<iframe width="560" height="315" src="https://www.youtube.com/embed/videoseries?list=UUljBfmJffQppZYiX2h3pgGQ" frameborder="0" allowfullscreen></iframe> that shows up on all the pages. This has never been a problem until a while ago. Now that I have removed that code everything is fine. I would still love to be able to embed videos though
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Unexpected reaction
Posted: 22-Aug-2017 16:58   in response to: femoree in response to: femoree
Correct
  Click to reply to this thread Reply
Without seeing your site, I can only guess. But I suspect that what's happening is that when the slide page is displayed, the responsiveness script tries to display all of the page content, so that there are no vertical scrollbars. But the page content, in your case, also includes a fairly large iframe. So, the script tries to make the slide image small enough so that everything on the page "fits," and there's just too much material on the page. So, you end up with a relatively tiny slide image. (The same thing would happen if your comments under the slide image were twenty lines long, for example.)

Try using a different responsiveness mode for the slide pages. Under Gromit > Layout > Slides > Slide Page Responsiveness > Type, choose width instead of full.
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Unexpected reaction
Posted: 22-Aug-2017 17:10   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
There might be a way to get the benefit of full responsiveness, but still be able to show your embedded video below the slide image, but I'd have to see your page coding, and also have you explain how you're planting the video on each slide page, to know how best to do that. I can't do it "blind."
femoree

Posts: 4
Registered: 12-Jan-2016
Re: Unexpected reaction
Posted: 23-Aug-2017 18:54   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks for your great help. I have made a test page at https://afropeans.com/test/
Gromit --> Setting--> Code--> Slide page--> HTML body closing that is where I put the embed and the statcounter codes.

Btw. If I do as you suggested and set the responsiveness to width instead of full the problem disappears. So I think I will just do that from now on.

Edited by: femoree on 23-Aug-2017 18:58
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Unexpected reaction
Posted: 23-Aug-2017 19:11   in response to: femoree in response to: femoree
Helpful
  Click to reply to this thread Reply
That's a help.

For now, your best bet is to choose one of the other slide responsiveness modes - under Gromit > Layout > Slides > Slide Page Responsiveness > Type, try image or width. Either one will avoid the "shrinking image" phenomenon.

I'll see if there's an easy way to accommodate full responsiveness without taking into account the height of an embedded iframe like this. It's buried in the Javascript code for the responsiveness, so it's not something you can fix with a quick code fiddle.
femoree

Posts: 4
Registered: 12-Jan-2016
Re: Unexpected reaction
Posted: 23-Aug-2017 22:20   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thank you!
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Unexpected reaction
Posted: 27-Aug-2017 00:47   in response to: femoree in response to: femoree
 
  Click to reply to this thread Reply
The next release of the skin will include an option to have fully-responsive slide pages not worry about the additional body material you're providing. That should provide the best of both worlds.

Not sure when I'll release it - I've got some other, more time-consuming changes to work out. A few miserable, rainy days would do the trick, but it's in the 70's and sunny, so....
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums