This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 18 - Pages: 2 [ 1 2 | Next ] - Last Post: 28-Aug-2017 13:41 Last Post By: lestizis
lestizis

Posts: 17
Registered: 9-Oct-2007
Marking new files
Posted: 18-Aug-2017 17:58
 
  Click to reply to this thread Reply
Attachment Capture2.JPG (144,7 KB)
Attachment Capture01.JPG (191,8 KB)
Attachment Capture.JPG (103,6 KB)
I do not have the marking of the album while its files are well marked (add album)
The parent of this album is well marked

Jalbum 14.1.6 and Tiger1.3.4

Thanks

lestizis

Posts: 17
Registered: 9-Oct-2007
Re: Marking new files
Posted: 22-Aug-2017 17:53   in response to: lestizis in response to: lestizis
 
  Click to reply to this thread Reply
With new version Jalbum 14.1.7 and Tiger 1.3.5 I have the same marking problems.
what should be done?
Thank you for your help
Laza

Posts: 9,465
Registered: 6-Sep-2005
Re: Marking new files
Posted: 22-Aug-2017 18:14   in response to: lestizis in response to: lestizis
 
  Click to reply to this thread Reply
What do you mean by "marking of the album". The album itself doesn't get marked.
lestizis

Posts: 17
Registered: 9-Oct-2007
Re: Marking new files
Posted: 22-Aug-2017 19:58   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Directories, Subdirectories, Files ... . If files of one subdirectorie are new they are marked as new but not the subdirectorie. The Directorie (parent) is marked as new .

See pictures attached in first message.

Thank and excuse my poor english
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Marking new files
Posted: 22-Aug-2017 20:05   in response to: lestizis in response to: lestizis
 
  Click to reply to this thread Reply
I can confirm this problem.

Create a new album project with:

Folder > Subfolder > 2 images.

If you tell Tiger to mark as "new" anything added in the last 10 days, the two images both get red stars, and Folder gets a red star. But Subfolder does not.

Edit: Quick demo album: (demo removed)

EditEdit: Same problem if "newness" is using date taken. Demo updated with one recent image and a couple that are from 5 years ago.
Laza

Posts: 9,465
Registered: 6-Sep-2005
Re: Marking new files
Posted: 22-Aug-2017 20:11   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks, I can see now. The top level directories worked, so I assumed it works in the subfolders too.
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Marking new files
Posted: 26-Aug-2017 04:34   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
This is still not working properly in Tiger 1.3.8.
Laza

Posts: 9,465
Registered: 6-Sep-2005
Re: Marking new files
Posted: 26-Aug-2017 08:59   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
I shouldn't have released this latest version so early - I forgot about this bug too...
Laza

Posts: 9,465
Registered: 6-Sep-2005
Re: Marking new files
Posted: 27-Aug-2017 16:22   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
jGromit, Can you please upload the same album with Debug mode on? I couldn't reproduce the error in my test album...
I could reproduce it know - en empty folder triggers it that only has folders.

Edited by: Laza on 27-Aug-2017 16:28
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Marking new files
Posted: 27-Aug-2017 16:46   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
No, it's happening even if there are images in each folder.

Updated example, with debug mode turned on. There is only one "new" image in that album, at the bottom level (Subfolder). But no star at the middle level (Folder).

(demo removed)
jGromit

Posts: 33,151
Registered: 31-Jan-2006
Re: Marking new files
Posted: 27-Aug-2017 17:04   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Zipped-up project: (demo removed)
Nordschleife

Posts: 71
Registered: 18-Dec-2012
Re: Marking new files
Posted: 27-Aug-2017 17:23   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
I have an example where marking new files works for a folder constaining only folder but no pictures, see folder "Entenmörder":

https://www.doh.photos/media/Dampf/index.html

But exactly for this folder the Labels/Tags are not visible even if the album is created from scratch and uploaded completely, see my thread:

http://jalbum.net/forum/thread.jspa?threadID=53060&tstart=0
Laza

Posts: 9,465
Registered: 6-Sep-2005
Re: Marking new files
Posted: 27-Aug-2017 17:52   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks. I fixed this now. It was really complicated. When constructing the folder tree I forgot to copy custom (skin-defined) variables to the folder tree by default. This was working however when any function relied on the tree, like the tag cloud has triggered walking through the album tree. Also was working on upper levels - it's just the last folder suffered from this error.
Laza

Posts: 9,465
Registered: 6-Sep-2005
Re: Marking new files
Posted: 27-Aug-2017 17:56   in response to: Nordschleife in response to: Nordschleife
 
  Click to reply to this thread Reply
Attachment Tiger.jaskin (4,3 MB)
I'm not sure it works, but might worth to try the attached skin version. If it still fails can you please remake/reupload with Site Admin / Debug mode = ON?
Nordschleife

Posts: 71
Registered: 18-Dec-2012
Re: Marking new files
Posted: 27-Aug-2017 18:13   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
It works now.
Thanks Laza.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums