Permlink Replies: 255 - Pages: 18 [ Previous | 1 2 3 4 5 6 7 | Next ] - Last Post: 01-Jul-2017 23:34 Last Post By: davidekholm Threads: [ Previous | Next ]
ctwist

Posts: 569
Registered: 27-Sep-2003
Re: jAlbum 14 beta for testing
Posted: 22-May-2017 13:34   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
If the YouTube site cannot be contacted, the exception "java.net.ConnectException: Connection timed out: connect" is raised.
This should be handled gracefully; a simple error message should be shown instead of the full trace log.
davidekholm

Posts: 3,570
Registered: 18-Oct-2002
Re: jAlbum 14 beta for testing
Posted: 22-May-2017 15:42   in response to: RobM in response to: RobM
  Click to reply to this thread Reply
RobM wrote:
If you select 'Convert link to copy' you get an error,
Exception in thread "copier" java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
at java.util.ArrayList.rangeCheck(ArrayList.java:653)
at java.util.ArrayList.get(ArrayList.java:429)
at se.datadosen.jalbum.FileCopier$2.run(FileCopier.java:107)

That option should not be available.


I can't repoduce neither of your reported errors Rob (b8)
davidekholm

Posts: 3,570
Registered: 18-Oct-2002
Re: jAlbum 14 beta for testing
Posted: 22-May-2017 18:00   in response to: ctwist in response to: ctwist
  Click to reply to this thread Reply
When creating an AlbumObject explicitly through the API, ensure you pass some AlbumObject as parent, don't call vAOFactory.createInstance(vTempFile); but call vAOFactory.createInstance(vTempFile, rootFolder); for instance.
ctwist

Posts: 569
Registered: 27-Sep-2003
Re: jAlbum 14 beta for testing
Posted: 22-May-2017 19:00   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
call vAOFactory.createInstance(vTempFile, rootFolder)
Yes that fixed it. It's strange that it didn't fail in earlier versions of jAlbum.
RobM

Posts: 3,101
Registered: 4-Aug-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 16:06   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
RobM wrote:
If you select 'Convert link to copy' you get an error,
Exception in thread "copier" java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
at java.util.ArrayList.rangeCheck(ArrayList.java:653)
at java.util.ArrayList.get(ArrayList.java:429)
at se.datadosen.jalbum.FileCopier$2.run(FileCopier.java:107)

That option should not be available.

I can't repoduce neither of your reported errors Rob (b8)

I can still trigger both errors repeatedly, Mac OS 10.12.4, jAlbum 14b6 Java 1.8, 64 bit.
The error occurs as the attached popup progress window appears, but only if pasting to the same location that the copied item exists (so you could quickly paste and edit for an album of albums, for example). Can anyone else on a Mac reproduce it?
jGromit

Posts: 7,459
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 16:56   in response to: RobM in response to: RobM
  Click to reply to this thread Reply
RobM wrote:
I can still trigger both errors repeatedly....

I can't reproduce either of them, neither on Win10 nor on macOS 10.12.5.

But before going any further, you should get 14b8: https://jalbum.net/download/beta/jalbum-core.jar
RobM

Posts: 3,101
Registered: 4-Aug-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 17:04   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
jGromit wrote:
RobM wrote:
I can still trigger both errors repeatedly....

I can't reproduce either of them, neither on Win10 nor on macOS 10.12.5.

But before going any further, you should get 14b8: https://jalbum.net/download/beta/jalbum-core.jar

It is still the same with the latest core update. I'll try a clean install tonight to see if anything in the config directory is causing the problem.
davidekholm

Posts: 3,570
Registered: 18-Oct-2002
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 19:56   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
jGromit wrote:
There's a nasty bug in jAlbum 14b7 video processing. Blew one of my projects out the water, but it was easy to track down.

If you add an MP4 and tag it, "Do not re-encode," the videoPath variable ends up void. Remove that tag, and the path reappears. This does not occur in jAlbum 13.


Thanks for reporting. Now fixed in b9 .
jGromit

Posts: 7,459
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 20:39   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
jGromit wrote:
There's a nasty bug in jAlbum 14b7 video processing. ...

Thanks for reporting. Now fixed in b9 .


Yes, it's much happier now. :)

Just dumb luck that I stumbled on it. Skins that use originalPath for videos (Minimal, Turtle) wouldn't have run into the error, but both Gromit and Matrix use videoPath, and I happen to have one personal album project in which I processed the older videos outside of jAlbum, before jAlbum had real video support.
RobM

Posts: 3,101
Registered: 4-Aug-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 21:04   in response to: RobM in response to: RobM
  Click to reply to this thread Reply
RobM wrote:
jGromit wrote:
RobM wrote:
I can still trigger both errors repeatedly....

I can't reproduce either of them, neither on Win10 nor on macOS 10.12.5.

But before going any further, you should get 14b8: https://jalbum.net/download/beta/jalbum-core.jar

It is still the same with the latest core update. I'll try a clean install tonight to see if anything in the config directory is causing the problem.
I deleted the old configuration folder and then installed a new version of jAlbum, with the b9 core update installed too. I loaded the included Sample portfolio and then added a web location. Then copied and pasted it into the same folder, clicked "Don't replace" and got the error. See attached mp4 for exact actions. Still, if it's just me…
jGromit

Posts: 7,459
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 21:21   in response to: RobM in response to: RobM
  Click to reply to this thread Reply
RobM wrote:
See attached mp4 for exact actions. Still, if it's just me…

I don't get the same results. But there's something that flickers by that makes me suspicious, something about jAlbum wanting to contact apple.com on port 80. I've never seen that, and have no idea what it's about. But it makes me think that perhaps there's something odd about the webloc itself.

For a simpler test case, go to https://jgromit.com, and drag that into a project. Then try your copy/paste routine.
RobM

Posts: 3,101
Registered: 4-Aug-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 22:10   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
jGromit wrote:
RobM wrote:
See attached mp4 for exact actions. Still, if it's just me…

I don't get the same results. But there's something that flickers by that makes me suspicious, something about jAlbum wanting to contact apple.com on port 80. I've never seen that, and have no idea what it's about. But it makes me think that perhaps there's something odd about the webloc itself.

For a simpler test case, go to https://jgromit.com, and drag that into a project. Then try your copy/paste routine.

Exactly the same result.
The popup alerts are due to another application, LittleSnitch by Objective Development, which alerts of outgoing web connections.
jGromit

Posts: 7,459
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 22:15   in response to: RobM in response to: RobM
  Click to reply to this thread Reply
RobM wrote:
The popup alerts are due to another application....

You know what I'm going to suggest next, right? ;)
RobM

Posts: 3,101
Registered: 4-Aug-2006
Re: jAlbum 14 beta for testing
Posted: 23-May-2017 22:18   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
jGromit wrote:
RobM wrote:
The popup alerts are due to another application....

You know what I'm going to suggest next, right? ;)

I'll try it tomorrow, the battery is nearly flat and there's a TV show on about volcanoes in the Solar System ;)
davidekholm

Posts: 3,570
Registered: 18-Oct-2002
Re: jAlbum 14 beta for testing
Posted: 24-May-2017 20:56   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
jGromit wrote:
RobM wrote:
The popup alerts are due to another application....

You know what I'm going to suggest next, right? ;)


Let me join in on that ;-)
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums