This question is answered.


Permlink Replies: 35 - Pages: 3 [ 1 2 3 | Next ] - Last Post: 04-Sep-2016 22:32 Last Post By: borisv Threads: [ Previous | Next ]
borisv

Posts: 62
Registered: 24-Oct-2005
Can't make my album after rolling up to 12.7 and 1.7.0
Posted: 24-May-2016 04:00
 
  Click to reply to this thread Reply
I just have installed the latest jAlbum (for my license) and new version of ExhibitPlus.
The previous versions were 12.2 and 1.5, and it worked fine last night. No album changes.
Opened my album, tried to build it (Make All or Make Changes), and immediately get the fatal error. Repeated with the same result. Any ideas? Thank you.

Stack trace for jAlbum 12.7.2 using skin ExhibitPlus 1.7:

javax.script.ScriptException: bsh.EvalError: Sourced file: inline evaluation of: ``import se.datadosen.util.; setAccessibility(true); // Write an entry in the . . . '' : Typed variable declaration : Class: Utils not found in namespace : at Line: 22 : in file: inline evaluation of: ``import se.datadosen.util.; setAccessibility(true); // Write an entry in the . . . '' : Utils
in inline evaluation of: ``import se.datadosen.util.*; setAccessibility(true); // Write an entry in the . . . '' at line number 22
at bsh.BshScriptEngine.evalSource(BshScriptEngine.java:102)
at bsh.BshScriptEngine.eval(BshScriptEngine.java:61)
at javax.script.AbstractScriptEngine.eval(Unknown Source)
at se.datadosen.jalbum.AlbumBean.doProcessExpression(AlbumBean.java:2123)
at se.datadosen.jalbum.AlbumBean.processExpression(AlbumBean.java:2107)
at se.datadosen.jalbum.AlbumBean.processScript(AlbumBean.java:2063)
at se.datadosen.jalbum.AlbumBean.prepareMakeAlbum(AlbumBean.java:2515)
at se.datadosen.jalbum.AlbumBean.makeAlbum(AlbumBean.java:2300)
at se.datadosen.jalbum.AlbumBean.makeAlbum(AlbumBean.java:2262)
at se.datadosen.jalbum.JAlbumFrame$11.run(JAlbumFrame.java:960)
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 24-May-2016 05:41   in response to: borisv in response to: borisv
 
  Click to reply to this thread Reply
I get the same error. Somehow, the Utils.java file didn't get compiled into Utils.class before the skin was packaged for distribution.

Until ctwist has a chance to fix this, try this stopgap. Open the skin directory - Tools, Open directories, Skin directory - go to the plugins subdirectory, and copy the attached file to it.

No guarantees - I just did a quick compile of this with JDK 1.8.0_92.

Edited by: jGromit - attachment removed - version 1.7.1 cures the problem.
ctwist

Posts: 1,411
Registered: 27-Sep-2003
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 24-May-2016 14:44   in response to: borisv in response to: borisv
 
  Click to reply to this thread Reply
I don't know how that happened.

This is fixed in version 1.7.1.
borisv

Posts: 62
Registered: 24-Oct-2005
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 24-May-2016 15:43   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
I will test it tonight, thank you. Then I would mark this request as closed.

And let me tell you: it feels really good when knowledgeable people like you and jGromit reply almost immediately. This friendly support is one of the main reasons I love jAlbum and use it for so many years now. You guys are awesome and kind.

Edited by: borisv on 24-May-2016 09:44
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 24-May-2016 15:48   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
ctwist wrote:
I don't know how that happened.

Code gremlins. They visit my PC every now and then, too.
borisv

Posts: 62
Registered: 24-Oct-2005
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 25-May-2016 05:20   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
ctwist, your fix 1.7.1 is working well. I did rebuild my album. Thanks again.

I hope I can ask quick question here instead of opening a new thread.
The newly generated album is missing the navigation controls to following index pages - I have 4 index pages with 96 folders total / 24 per page (see attached images of the controls in previous version: one on top and another at the bottom). Now I don't have them.
Is there some config setting I've missed?
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 25-May-2016 13:05   in response to: borisv in response to: borisv
 
  Click to reply to this thread Reply
Confirmed error.

Chris, the value of totalIndexPagesFixed seems to be 0 or 1, but never greater than 1, so that section of the index page never gets produced. Even if I force that section to be produced, it's incorrect - no actual link to page 2, image count on page 1 wrong, etc.

BTW, the skin blows up if you specify rows 0.

Edit: Found the problem. Line 95 of index.bsh:
Change:
 
totalIndexPagesFixed = (int) Math.ceil(totalImages / (cols * rows));
 
To:
 
totalIndexPagesFixed = (int) Math.ceil(totalImages / (double) (cols * rows));
That still doesn't take care of the "zero rows" problem, however.

Edited by: jGromit on 25-May-2016 07:15
ctwist

Posts: 1,411
Registered: 27-Sep-2003
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 25-May-2016 13:15   in response to: borisv in response to: borisv
 
  Click to reply to this thread Reply
Strange. When I generate my test album, I do get the navigation bar on the index pages. I will have to look into it.
ctwist

Posts: 1,411
Registered: 27-Sep-2003
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 25-May-2016 13:50   in response to: borisv in response to: borisv
 
  Click to reply to this thread Reply
borisv wrote:
The newly generated album is missing the navigation controls to following index pages
This is fixed in version 1.7.2.
borisv

Posts: 62
Registered: 24-Oct-2005
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 26-May-2016 05:11   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
Sorry, Chris, but I still miss index pages navigation.
Installed 1.7.2, rebuilt - no changes.
And in index.bsh I do see that line in question corrected:
totalIndexPagesFixed = Math.ceil((Double)totalImages / (Double)(cols * rows)).intValue();
(I assume totalImages is not the number of photos, but number of folders *on the top level*)
I must be doing something wrong...
ctwist

Posts: 1,411
Registered: 27-Sep-2003
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 27-May-2016 15:20   in response to: borisv in response to: borisv
Helpful
  Click to reply to this thread Reply
Changing that line fixed it for me. This restored it to how it worked in E+ 1.6.
I don't know why it isn't working for you. I could suggest the obvious things to check (e.g. restart jAlbum, do you have 2 versions of E+ installed?, re-load the page in your web browser in case you are seeing an old cached page). I can't think of anything else.
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 27-May-2016 15:33   in response to: ctwist in response to: ctwist
Helpful
  Click to reply to this thread Reply
And the other one: make sure you haven't checked Process only updated subdirectories.
borisv

Posts: 62
Registered: 24-Oct-2005
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 27-May-2016 17:21   in response to: ctwist in response to: ctwist
 
  Click to reply to this thread Reply
I will try all of those. I just don't know how to install/verify E+
Google should help, I guess.
Thank you. I'll keep you posted.
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 27-May-2016 17:29   in response to: borisv in response to: borisv
 
  Click to reply to this thread Reply
borisv wrote:
I just don't know how to install/verify E+

Launch jAlbum, and choose a skin other than ExhibitPlus, like Minimal. Then choose Tools, Open directories, Config directory. Open the skins subdirectory, and delete the entire ExhibitPlus subdirectory. Now download and install ExhibitPlus again from http://jalbum.net/skins/skin/ExhibitPlus.
borisv

Posts: 62
Registered: 24-Oct-2005
Re: Can't make my album after rollong up to 12.7 and 1.7.0
Posted: 30-May-2016 23:24   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Well, I feel very stupid indeed. What I meant: "I didn't know that by E+ you guys refer to ExhibitPlus".
When I finally got that to my mind, it was easy. Well, sort of.

I have completely removed E+, closed/opened jAlbum, checked all settings and rebuilt ("Make Changes"). Deleted index files manually. Repeated that 3 times to check all my steps. Still no navigation element.

I even tried to hard-code totalIndexPagesFixed=4; after line 95 of index.bsh or inside addLinks(), but that didn't help at all.

I am stuck.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums