This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 6 - Pages: 1 - Last Post: 14-Dec-2015 18:52 Last Post By: RobM Threads: [ Previous | Next ]
Stoertie

Posts: 1
Registered: 31-Oct-2012
A problem with Firefox?
Posted: 14-Dec-2015 10:14
 
  Click to reply to this thread Reply
Hi all,

I created some albums in 2012... Now I found out that there is a problem when I open these albums with my Firefox browser ( Vers. 42.0 )
With the Internet Explorer everything works well!

When I click to the tumbnail bar the pictures opens correct, but I can't scroll the tumbnail bar to right oder left.

When I click to a shown picture, it shows nothing (all black) and doesn't go to the next pic... :-(

If opu like to check, try this link

Is it a problem of the album or a firefox-problem?

Any soloutions to fix it?

Best regards
Michael
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: A problem with Firefox?
Posted: 14-Dec-2015 16:37   in response to: Stoertie in response to: Stoertie
 
  Click to reply to this thread Reply
So far, I haven't been able to figure out why some of your albums work, but others do not - Tag1 and Tag2 are OK, but Tag3 is broken, and so on.

I think it may have to do with using quote marks in titles and comments, which is always dangerous. There are also HTML errors in your header and footer material, which could be causing problems. Also, I'm seeing <br /> tags in alt and title attributes, which isn't strictly legal. But I can't create a "broken" album, even when I introduce the same errors.

Can anyone else spot what's wrong here?
RobM

Posts: 4,382
Registered: 4-Aug-2006
Re: A problem with Firefox?
Posted: 14-Dec-2015 18:19   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
It looks look the double quote is encoded but not the single quote, maybe it is the single quote causing the problem?
<a href="slides/Marc u Ines - 6885.jpg" title="&quotBig Brother is watching YOU!&quot">
 
<a href="slides/Marc u Ines - 7021.jpg" title="hier geht's richtig tief runter">
Removed semicolon to show the rest!
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: A problem with Firefox?
Posted: 14-Dec-2015 18:28   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
No, that should be fine. I still can't produce a broken album. The file names all appear to be OK, too, which would be my first suspicion.
RobM

Posts: 4,382
Registered: 4-Aug-2006
Re: A problem with Firefox?
Posted: 14-Dec-2015 18:33   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Just been through the whole album in Safari on an iPad with no error, tapping on main image, a thumbnail and left/right buttons all work. A problem with the Firefox installation?
jGromit

Posts: 33,185
Registered: 31-Jan-2006
Re: A problem with Firefox?
Posted: 14-Dec-2015 18:39   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
No, the broken albums fail in Firefox on my PC, as well. Ditto on a Mac. Nothing wrong with Firefox.

There's a hint in the address bar. Take that Tag6 album as an example. Load the page, then click the right arrow. In Chrome, the address bar now shows:

http://www.z1-nordlichter.de/norwegen2012/Tag6/album/#slides/Stefan - P1020903.jpg

But in Firefox:

http://www.z1-nordlichter.de/norwegen2012/Tag6/album/#undefined

Something is kicking the Javascript in the butt, but my Javascript debugging skills are sorely lacking.

Edited by: jGromit on 14-Dec-2015 12:43
RobM

Posts: 4,382
Registered: 4-Aug-2006
Re: A problem with Firefox?
Posted: 14-Dec-2015 18:42   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Is there another album you looked at? The one linked to above works fine for me.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums