This question is answered. Helpful answers available: 1. Correct answers available: 1.


Permlink Replies: 10 - Pages: 1 - Last Post: 22-Jan-2019 18:22 Last Post By: jGromit
porterj

Posts: 6
Registered: 14-Dec-2006
Audio Files not playing
Posted: 21-Jan-2019 23:08
 
  Click to reply to this thread Reply
Hi,
I have just updated jAlbum to latest version, also Turtle Skin is latest version.

In my latest project the Music plays fine on my browser when I use the files on my local disc, but when I upload to my website they will not play.

The Album is at :-

http://www.porterj.com/PhotoAlbums/Beate/beate.html

Any Ideas?

Many thanks
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: Audio Files not playing
Posted: 21-Jan-2019 23:15   in response to: porterj in response to: porterj
 
  Click to reply to this thread Reply
The server gives a 404 on that music file, but I think the problem is simple. Rename the MP3 without using any diacriticals in the name (specifically, the "variés" part), add it to the album, make the album, and upload again.
porterj

Posts: 6
Registered: 14-Dec-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 01:06   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Hi jGromit,

Many thanks for your speedy reply.

I have tried your suggestion, but unfortunately it does not seem to have solved the problem
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 01:24   in response to: porterj in response to: porterj
 
  Click to reply to this thread Reply
I'm looking at the album now, and the file name hasn't changed - it's still showing as:

http://www.porterj.com/PhotoAlbums/Beate/res/Love Theme - Romeo And Juliet Various Artists - Artistes variés.mp3

And the server is still telling me that the file isn't there. But I still think it's just a file naming problem.
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 02:18   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
BTW, not related to the music problem, but why are you renaming the index.html file? If you just left the default alone, the address of the album would be:

http://www.porterj.com/PhotoAlbums/Beate/

... instead of:

http://www.porterj.com/PhotoAlbums/Beate/beate.html

Why complicate it?
porterj

Posts: 6
Registered: 14-Dec-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 15:51   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
The reason is that there would be many "index.html" files on my website so I name each one differently so I know which one I am looking at. As you can see my HTML is very basic and completely self taught, mostly by trial and error!

Edited by: porterj on 22-Jan-2019 14:52
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 15:59   in response to: porterj in response to: porterj
 
  Click to reply to this thread Reply
porterj wrote:
The reason is that there would be many "index.html" files on my website so I name each one differently so I know which one I am looking at.

The name of the directory would tell you that.
porterj

Posts: 6
Registered: 14-Dec-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 16:35   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Many thanks for your help.

After much searching I think I have got the naming sorted, but most unfortunately the sound is still not playing.
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 16:48   in response to: porterj in response to: porterj
 
  Click to reply to this thread Reply
Well, that music file is still producing a "404 - Not found" from the server. The necessary file is simply not present.

http://www.porterj.com/PhotoAlbums/Beate/res/Love Theme - Romeo And Juliet Various Artists.mp3

So, either you haven't uploaded the file where it belongs (notice that it's in the "res" folder), or the naming is still a problem.

Humor me. Try renaming it to something very simple - no spaces, no dashes, no upper/lower case. Maybe beatesong.mp3.
porterj

Posts: 6
Registered: 14-Dec-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 17:55   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
"YES" ! It is now working fine.

Thank you for your persistence. I wonder why I have not had similar problems in previous photo albums? I have always just used the original mp3 file names.

Just a couple of simple questions.

1. How do I adjust the font for the Album description. I know I can just edit the beate.html file but that is cheating!, There must be a way in the Turtle settings but I can't seem to find it.

2 How do I insert a pointer to return to the previous page?

Many thanks for your help.

John
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: Audio Files not playing
Posted: 22-Jan-2019 18:22   in response to: porterj in response to: porterj
Helpful
  Click to reply to this thread Reply
First, I would strongly suggest that you switch from Turtle to Tiger. TIger handles the thumbnails better, handles videos better, handles audio better, and so on. Development of Turtle is pretty much at an end.

To alter the font characteristics of the album description, go to Turtle > Advanced > CSS and enter, for example:
#main header .description {font-size: 22px;}
A pointer to the previous page? What previous page? This is a one-page album. It doesn't know how the visitor got there. But if you want it to display an "up" arrow to some other place on your website, just enter the URL and tooltip text under Album > Settings > Pages > Link to homepage (this is true in almost every skin).
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums