This question is answered.


Permlink Replies: 4 - Pages: 1 - Last Post: 14-Mar-2018 22:15 Last Post By: fredsphotoweb Threads: [ Previous | Next ]
fredsphotoweb

Posts: 5
Registered: 2-Mar-2012
Error message after installation of version 1.8.3
Posted: 14-Mar-2018 14:48
 
  Click to reply to this thread Reply
I got this error message after updating to version 1.8.3. I am running Jalbum on Windows 10.

Stack trace for jAlbum 15.3 using skin PhotoBlogger 1.8.3:

se.datadosen.util.ScriptException: bsh.EvalError: Sourced file: inline evaluation of: ``/* init.bsh - the Beanshell script to initialize the skin Author: Laza / . . . '' : Typed variable declaration : Attempt to resolve method: equals() on undefined variable or class name: folderTreeType : at Line: 43 : in file: inline evaluation of: ``/ init.bsh - the Beanshell script to initialize the skin Author: Laza */ . . . '' : folderTreeType .equals ( "none" )
in init.bsh at line number 43
at se.datadosen.util.ScriptException.of(ScriptException.java:59)
at se.datadosen.jalbum.AlbumBean.processScript(AlbumBean.java:2404)
at se.datadosen.jalbum.AlbumBean.prepareMakeAlbum(AlbumBean.java:2904)
at se.datadosen.jalbum.AlbumBean.makeAlbum(AlbumBean.java:2652)
at se.datadosen.jalbum.AlbumBean.makeAlbum(AlbumBean.java:2608)
at se.datadosen.jalbum.JAlbumFrame$5.run(JAlbumFrame.java:1053)
jGromit

Posts: 34,114
Registered: 31-Jan-2006
Re: Error message after installation of version 1.8.3
Posted: 14-Mar-2018 14:55   in response to: fredsphotoweb in response to: fredsphotoweb
 
  Click to reply to this thread Reply
Do you still get the error message if you save the project, close it, reopen it, and try to make the album again?
fredsphotoweb

Posts: 5
Registered: 2-Mar-2012
Re: Error message after installation of version 1.8.3
Posted: 14-Mar-2018 21:40   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Saving, closing and reopening the project makes no difference. The error message continues to pop up and I am unable to remake the album.
jGromit

Posts: 34,114
Registered: 31-Jan-2006
Re: Error message after installation of version 1.8.3
Posted: 14-Mar-2018 21:56   in response to: fredsphotoweb in response to: fredsphotoweb
Correct
  Click to reply to this thread Reply
Very strange - it's complaining about a variable not being defined, but that variable is definitely defined in the skin, and has a default value, so that error should never occur.

I'd suggest reinstalling the skin without jAlbum running - just download the installation file from https://jalbum.net/skins/skin/Photoblogger then double-click on it to install the skin.
fredsphotoweb

Posts: 5
Registered: 2-Mar-2012
Re: Error message after installation of version 1.8.3
Posted: 14-Mar-2018 22:15   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
That worked. Many thanks for your help.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums