This question is answered. Helpful answers available: 1. Correct answers available: 1.


Permlink Replies: 11 - Pages: 1 - Last Post: 30-Aug-2017 02:41 Last Post By: jGromit
aviavi1234

Posts: 8
Registered: 17-Mar-2013
Slim skin: hide .jpg extension?
Posted: 29-Aug-2017 19:49
 
  Click to reply to this thread Reply
Hi. I'm using the Slim skin.

Does anyone know of a way to "show filename instead of jalbum title" and hide the .jpg extension, or otherwise make the Jalbum title be the same as the filename, but without the .jpg extension?

Thanks,
Avi
jGromit

Posts: 33,207
Registered: 31-Jan-2006
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 00:46   in response to: aviavi1234 in response to: aviavi1234
 
  Click to reply to this thread Reply
I did a little quick hacking of the main script of the skin, and of the user interface, that I think will do what you want. I've changed the checkbox so that it now reads, Show filename (without extension) if no jAlbum title.

If you choose that option, it will show the title if there is one, and if there isn't, the filename, minus its extension. If you don't choose that option, it will show the title if there is one, otherwise nothing (or just the comment, if you've entered one).

I made a similar fix to the thumbstrip so that, when you hover on a thumbnail, you get just the filename without its extension. I didn't plunge any further into it - the thumbstrip tooltip won't show the title, no matter what. That exercise is left to the student. ;)

Edited by: jGromit - removed test skin
aviavi1234

Posts: 8
Registered: 17-Mar-2013
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 01:08   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Oh wow, thanks JGromit! Super kind of you.
But now there seems to be a problem - the non-thumbnail images are not showing. Not sure why. See screen shot.
jGromit

Posts: 33,207
Registered: 31-Jan-2006
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 01:36   in response to: aviavi1234 in response to: aviavi1234
 
  Click to reply to this thread Reply
Hmmm.... No problem in my quick tests. Make sure you're refreshing the browser cache.

I'm seeing other problems in the skin, however (not the result of my changes). If there are spaces in file names, for example, they're being encoded as %20, which is technically correct, but not very friendly for display purposes.

This is the problem with orphan skins like this one. The developer was an intern who's no longer around. Anyone else wading into the skin to make changes starts uncovering all manner of glitches that need to be addressed, but the code is unfamiliar.

Attached is another beta, which addresses this filename encoding.

Edited by: jGromit - removed test skin
aviavi1234

Posts: 8
Registered: 17-Mar-2013
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 01:42   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Well, still not working - not in Firefox nor in the built-in previewer. Thanks for trying though. It's a nice skin - too bad it's not current.
jGromit

Posts: 33,207
Registered: 31-Jan-2006
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 01:46   in response to: aviavi1234 in response to: aviavi1234
 
  Click to reply to this thread Reply
Please give me a link to your album. In my tests, there's simply no problem with displaying the images. The changes I've made don't touch that part of the code at all!

Edit: my test album (there's an entered title on the first image in the home directory - all the rest are just showing the file name): (demo album removed)

EditEdit: The jalbum.net server seems to have ground to a halt at the moment....

Edited by: jGromit on 29-Aug-2017 20:40
aviavi1234

Posts: 8
Registered: 17-Mar-2013
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 02:02   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
(test album removed)

Edited by: jGromit on 29-Aug-2017 20:40
jGromit

Posts: 33,207
Registered: 31-Jan-2006
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 02:12   in response to: aviavi1234 in response to: aviavi1234
 
  Click to reply to this thread Reply
Hmmm.... Very strange. I'm not seeing anything that would explain the failure. Please attach your project file - maybe there's some setting that's interfering. jalbum-settings.jap
aviavi1234

Posts: 8
Registered: 17-Mar-2013
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 02:19   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
here you go. Thanks!
jGromit

Posts: 33,207
Registered: 31-Jan-2006
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 02:30   in response to: jGromit in response to: jGromit
Helpful
  Click to reply to this thread Reply
Attachment slim.jaskin (255,9 KB)
It would appear that my attempt to correct the loused-up thumbstrip tooltips had some unintended side effects, ones that kick in only with a longer thumbstrip. The skin coding is horribly non-modular.

Try this version.
aviavi1234

Posts: 8
Registered: 17-Mar-2013
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 02:34   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thank you! This works fine. Very grateful!
jGromit

Posts: 33,207
Registered: 31-Jan-2006
Re: Slim skin: hide .jpg extension?
Posted: 30-Aug-2017 02:36   in response to: aviavi1234 in response to: aviavi1234
 
  Click to reply to this thread Reply
Remind me never to wade into one of these JSON-driven skins again. ;)
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums