This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 40 - Pages: 3 [ 1 2 3 | Next ] - Last Post: 05-Aug-2019 08:02 Last Post By: Laza
TorstenHa

Posts: 6
Registered: 28-May-2012
auto-pano feature
Posted: 18-Jul-2019 21:29
 
  Click to reply to this thread Reply
how can I disable the function, it does not work with some pictures
Gruß Torsten
RobM

Posts: 3,170
Registered: 4-Aug-2006
Re: auto-pano feature
Posted: 19-Jul-2019 12:37   in response to: TorstenHa in response to: TorstenHa
 
  Click to reply to this thread Reply
There are two panoramic settings, one in Tiger and the other in jAlbum’s ‘Edit’ mode.

In Tiger it is Settings / Tiger / Lightbox / Main Image / use 360 layer, see https://jalbum.net/help/en/Skin/Tiger/Lightbox/Main_image

With the image in edit mode, uncheck the 360º image box, see https://jalbum.net/help/en/jAlbum/Edit , 360º image is about a third of the way down the page.

If the problem is that an image is to big for the browser window but it is not a pano image try the Tiger settings panel above, but look at images / scaling and select ‘Fit both’.
TorstenHa

Posts: 6
Registered: 28-May-2012
Re: auto-pano feature
Posted: 19-Jul-2019 17:12   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Hello,

I deactivated the settings / Tiger / Lightbox / Main Image / use 360 layer, set the scaling to Fit both.

The setting in picture edit mode I do not have?

The result unfortunately still looks like this:
http://hartmann-torsten.net/neu/#img=20190621-RTHA4456-Edit.jpg

Greeting Torsten
RobM

Posts: 3,170
Registered: 4-Aug-2006
Re: auto-pano feature
Posted: 19-Jul-2019 17:48   in response to: TorstenHa in response to: TorstenHa
 
  Click to reply to this thread Reply
The uploaded lifeboat file is dated Thu Jul 18 21:25:05 CEST 2019 and shows your settings file is showing that the 360 player is still selected
double check it and then try remaking the album when you are sure it is unchecked.

If it is still the same then Laza will respond when he returns from his holiday.
jGromit

Posts: 7,489
Registered: 31-Jan-2006
Re: auto-pano feature
Posted: 19-Jul-2019 18:16   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
There's another suspicious setting in the latest release of Tiger, as yet undocumented. See Tiger > Lightbox > Main image > Behavior > Use panorama player. It's selected by default. I'd turn it off, and see what happens.
TorstenHa

Posts: 6
Registered: 28-May-2012
Re: auto-pano feature
Posted: 19-Jul-2019 18:24   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
have both disabled, the image is no longer scaled

http://hartmann-torsten.net/neu/#img=20190621-RTHA4456-Edit.jpg

Edited by: TorstenHa on 19-Jul-2019 18:24
jGromit

Posts: 7,489
Registered: 31-Jan-2006
Re: auto-pano feature
Posted: 19-Jul-2019 18:43   in response to: TorstenHa in response to: TorstenHa
 
  Click to reply to this thread Reply
I think the problem is your custom footer code. It's not valid HTML, and it's breaking the page layout. See Tiger > Footer > Custom content.
TorstenHa

Posts: 6
Registered: 28-May-2012
Re: auto-pano feature
Posted: 19-Jul-2019 19:35   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Unfortunately, it is not the custom footer code, I have deleted this. The result is the same

It is the aspect ratio of the picture

Wrong presentation -> 2713 x 4825 pixels (original image)
http://hartmann-torsten.net/neu/#img=20190621-RTHA4456-Edit.jpg

Correct presentation -> 2932 x 4825 pixels (original image)
http://hartmann-torsten.net/neu/#img=20190621-RTHA4456-Edit-3.jpg
jGromit

Posts: 7,489
Registered: 31-Jan-2006
Re: auto-pano feature
Posted: 19-Jul-2019 20:45   in response to: TorstenHa in response to: TorstenHa
 
  Click to reply to this thread Reply
I agree, there's a deeper bug here, something that Laza will need to look at. As best I can tell, the problem occurs when there's a portrait-mode image whose vertical dimension is larger than the viewport. Instead of fitting to both dimensions, the image spills out above and below the viewport.

If you don't choose Never scale up, the problem gets even worse, and more obvious.

(Very difficult to test because of browser caching!)

ETA: And leaving the panorama viewer turned on produces some bizarre, uncontrollable behavior. The second image in this album is quite an adventure: (demo album removed)

Edited by: jGromit on 25-Jul-2019 08:20
TorstenHa

Posts: 6
Registered: 28-May-2012
Re: auto-pano feature
Posted: 19-Jul-2019 21:57   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Thanks for your help. I change to version 2.7.3, there is the problem not
hapeche

Posts: 29
Registered: 31-Jan-2017
Re: auto-pano feature
Posted: 21-Jul-2019 00:01   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
I have a similar problem: Some pictures - also pictures in portait-format - are intepreted as a panorama, but they are non panoramic pictures. I cannot find a possibility to disable the panorama player for such a specific picture only. I see the possibility only to diasable or enable the panorama player for ALL pictures.
RobM

Posts: 3,170
Registered: 4-Aug-2006
Re: auto-pano feature
Posted: 21-Jul-2019 00:28   in response to: hapeche in response to: hapeche
 
  Click to reply to this thread Reply
hapeche wrote:
I have a similar problem: Some pictures - also pictures in portait-format - are intepreted as a panorama, but they are non panoramic pictures. I cannot find a possibility to disable the panorama player for such a specific picture only. I see the possibility only to diasable or enable the panorama player for ALL pictures.
Have you tried the as yet undocumented setting mentioned by jGromit, Tiger > Lightbox > Main image > Behavior > Use panorama player.
hapeche

Posts: 29
Registered: 31-Jan-2017
Re: auto-pano feature
Posted: 21-Jul-2019 09:07   in response to: RobM in response to: RobM
 
  Click to reply to this thread Reply
Tiger > Lightbox > Main image > Behavior > Use panorama player does not work: Disbaling "Panorama player" disables it for ALL pictures, not for this one only. AND: Still this one picture (portait-format, 1680x2988) is upscaled in a way, so the width fits to the maximal width. I have to activate "don't upscale" to avoid this. BUT: Then upscaling for ALL pictures is disabled.
SO: It seems not to be possible to change the behaviour for SPECIFIC pictures, it can be changed for ALL pictures in the album only.

Edited by: hapeche on 24-Jul-2019 16:05
Laza

Posts: 2,276
Registered: 6-Sep-2005
Re: auto-pano feature
Posted: 24-Jul-2019 19:20   in response to: hapeche in response to: hapeche
 
  Click to reply to this thread Reply
Per-picture settings is kind of limited for a skin. Normally skin settings are global, but I can add an Edit mode setting, e.g. "Don't treat as panorama".
hapeche

Posts: 29
Registered: 31-Jan-2017
Re: auto-pano feature
Posted: 24-Jul-2019 21:14   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Yes, please:
Provide for each picture in the edit-mode for a picture the option: "Present this picture as a panorama" and check-boxes for "fast movement" "standard movement" "slow movement" or let enter the time in seconds for the duration of one movement.
And, after generating the album, for all pictures which are defined as a panorama a "pause"-button should appear to stop the movement and to move the picture with the cursor / the finger.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums