This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 17 - Pages: 2 [ 1 2 | Next ] - Last Post: 20-Apr-2019 18:56 Last Post By: jGromit
daveturk

Posts: 39
Registered: 21-Sep-2008
Top level folders are not showing
Posted: 28-Feb-2019 21:50
 
  Click to reply to this thread Reply
The folders at the top level of my generated album are not showing when viewed on-line. I've tried Firefox, Chrome and IE - all with same results. The top level folders are visible when I use the built-in jAlbum browser.

You can access the album here: http://73.189.157.121/

How do I get the folders to display at the top level?

Thanks,
Dave
jGromit

Posts: 7,276
Registered: 31-Jan-2006
Re: Top level folders are not showing
Posted: 28-Feb-2019 21:58   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
The server is misconfigured. It's serving up one of the Javascript files as script: octet-stream instead of script: js. Worse, the JSON files are being served as xhr: octet-stream instead of xhr: json.
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Top level folders are not showing
Posted: 28-Feb-2019 22:19   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Good to know, thanks.

I'm using the AnalogX SimpleServer.

Any suggestions for a lightweight, easy-to-configure server app for basic home use that will do a better job with this?

Thanks,
Dave

Edited by: daveturk on 28-Feb-2019 13:20
jGromit

Posts: 7,276
Registered: 31-Jan-2006
Re: Top level folders are not showing
Posted: 28-Feb-2019 22:24   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Sorry, that's beyond the scope of what we do here. This is why most people pay a few bucks a month for a properly-configured, professionally-managed server.

And are you on a residential ISP contract? If so, I'm surprised Comcast lets you run a home server. When I was with Comcast, that was explicitly prohibited (and my current provider, Spectrum, also prohibits it).
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Top level folders are not showing
Posted: 28-Feb-2019 22:26   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Ok, that's also good to know.

Can you recommend a company that has properly-configured, professionally-managed servers that play well with jAlbum?

Thanks,
Dave
jGromit

Posts: 7,276
Registered: 31-Jan-2006
Re: Top level folders are not showing
Posted: 28-Feb-2019 22:44   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Almost any normal web host would be fine - there's nothing unusual about jAlbum web pages.

Just watch out for any host that's owned by the dreaded Endurance International Group (EIG). They've bought out dozens of hosts, and the first thing they do is overload the servers and cut support to the bone. Miserable service.

Reliable reviews: https://www.reviewhell.com. Any of the top listings there would be fine. I'm with MDD Hosting, and have no complaints. Just don't sign up for any host for more than one year. The discounts may sound good, but if the company turns into a dog, you'll end up having to walk away from your money if you want to jump ship.

And don't register your domain with your web host - keep those two things separate, so you don't end up being a captive of a web host (can't leave the host because they make it tough to move or re-point your domain registration). I use Namecheap for domain registrations.

The latest list of EIG captives to be shunned, and some of the horror stories: https://www.reviewhell.com/blog/endurance-international-group-eig-hosting/
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Top level folders are not showing
Posted: 28-Feb-2019 23:00   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Okay, I signed up for an MDD Cloud1 hosting service. How do I get jAlbum to publish to that site?
jGromit

Posts: 7,276
Registered: 31-Jan-2006
Re: Top level folders are not showing
Posted: 28-Feb-2019 23:12   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Choose Tools, Publish/Manage, then add a new profile.

The Type should be SFTP (SSH File Transfer Protocol)

The Server name should be your chosen domain name, like example.com

The Username and Password should be whatever they are to login to the MDD cPanel.

Then click Advanced and enter 2233 for the Port.

Everything else should take care of itself. If you just signed up for hosting, the secure connection might not work right off the bat - I'm not sure how they're handling that these days, but it could take a day or two. And of course you'll have to wait for DNS propagation, so your domain name is pointing to the right place. That's pretty speedy these days - it might take only minutes. But theoretically, it could also take a day or two.
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Top level folders are not showing
Posted: 01-Mar-2019 00:10   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
Okay, I've got all of that working. But the album address is now:

http://www.theturks.org/Turk Family Photos

How do I make the album address the following:

http://www.theturks.org/

Thanks,
Dave
daveturk

Posts: 39
Registered: 21-Sep-2008
Re: Top level folders are not showing
Posted: 01-Mar-2019 00:43   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
I figured out a way to do an HTML redirect so it's working the way I want now.

Thanks,
Dave
jGromit

Posts: 7,276
Registered: 31-Jan-2006
Re: Top level folders are not showing
Posted: 01-Mar-2019 01:37   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
Needlessly complicated. Connect to the web host and delete the Turk Family Photos directory. Then, just upload the album to the root of the domain, directly under public_html. jAlbum will warn about this, because it assumes that you want to have multiple albums on your domain, each in its own directory. But that does seem to be what you want to do, so bypass the warning.
wringel

Posts: 2
Registered: 7-Apr-2014
Re: Top level folders are not showing
Posted: 18-Apr-2019 04:13   in response to: daveturk in response to: daveturk
 
  Click to reply to this thread Reply
I have a similar issue; save that my site is hosted by 'Hostmonster' and not a private server.

One of my albums online can be viewed here: http://www.ringelstetter.net/Holy_Land_2013/holy_land_2013.html

Any assistance in getting this back to normal would be appreciated.
jGromit

Posts: 7,276
Registered: 31-Jan-2006
Re: Top level folders are not showing
Posted: 18-Apr-2019 05:44   in response to: wringel in response to: wringel
 
  Click to reply to this thread Reply
This looks like the same kind of problem. The tree.json file, for example, is being served as text/html, which is not what it is.

I think you'll have to get your host's assistance on this one. But good luck - Hostmonster is one of the EIG captive companies, and customer service is the last thing they care about.

ETA: I'm seeing a collection of mysterious things on that site. Maybe Laza will recognize what's happening. Some of the individual folders work correctly, but the top level doesn't even seem to be trying to load the main Javascript routines at all. In particular, there is no call to all.min.js, which is the main driver of the page layout. You haven't done any manual edits to the completed album, have you?

The source code is virtually unviewable - it's being served up without any line feeds in it. That shouldn't stop the page from working, but it does make debugging very difficult.
jGromit

Posts: 7,276
Registered: 31-Jan-2006
Re: Top level folders are not showing
Posted: 18-Apr-2019 05:57   in response to: wringel in response to: wringel
 
  Click to reply to this thread Reply
BTW, this shouldn't matter, but why are you renaming the default index.html page?
Laza

Posts: 2,204
Registered: 6-Sep-2005
Re: Top level folders are not showing
Posted: 18-Apr-2019 08:50   in response to: wringel in response to: wringel
 
  Click to reply to this thread Reply
Looks like some "page optimization" is carried over on the server. You should turn that off - see your Control Panel! The album pages are already optimized, and those "optimization" scripts are too dumb for a complex page.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums