Permlink Replies: 8 - Pages: 1 - Last Post: 06-Nov-2017 22:11 Last Post By: ctwist
ctwist

Posts: 1,412
Registered: 27-Sep-2003
Doesn't render in IE8
Posted: 05-Nov-2017 17:56
  Click to reply to this thread Reply
The jAlbum home page opens in IE8 as a text page with most graphics missing. It's been a while since I tried this, but it did render correctly a few months ago.

These errors are reported:
Message: Object expected
Line: 104
Char: 9
Code: 0
URI: https://jalbum.net/en/
 
Message: Script error
Line: 0
Char: 0
Code: 0
URI: https://f.vimeocdn.com/p/2.63.5/js/moogaloop.js
AnCa

Posts: 2,101
Registered: 25-Mar-2005
Re: Doesn't render in IE8
Posted: 06-Nov-2017 12:46   in response to: ctwist in response to: ctwist
  Click to reply to this thread Reply
ctwist wrote:
The jAlbum home page opens in IE8 as a text page with most graphics missing.
Interresting... I will investigate... Might have something to do with https... Thanks for the report!
Btw, are you using Win XP?
ctwist

Posts: 1,412
Registered: 27-Sep-2003
Re: Doesn't render in IE8
Posted: 06-Nov-2017 14:35   in response to: AnCa in response to: AnCa
  Click to reply to this thread Reply
Yes, for that test I was using my old XP PC.
AnCa

Posts: 2,101
Registered: 25-Mar-2005
Re: Doesn't render in IE8
Posted: 06-Nov-2017 14:41   in response to: ctwist in response to: ctwist
  Click to reply to this thread Reply
ctwist wrote:
Yes, for that test I was using my old XP PC.
Ok. Fortunately less than 1% of our users are using IE8, so it's not a big problem. But it might be interesting to find out the cause.
jGromit

Posts: 33,186
Registered: 31-Jan-2006
Re: Doesn't render in IE8
Posted: 06-Nov-2017 15:17   in response to: AnCa in response to: AnCa
  Click to reply to this thread Reply
AnCa wrote:
Fortunately less than 1% of our users are using IE8....

When I saw this post, my first thought was that almost none of the current skins will display properly in IE8, so maybe discouraging visitors who are using it might not be a bad thing.
ctwist

Posts: 1,412
Registered: 27-Sep-2003
Re: Doesn't render in IE8
Posted: 06-Nov-2017 15:30   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
My home page ctwist.jalbum.net has a similar problem in IE8
Message: 'Wicket' is undefined
Line: 91
Char: 1
Code: 0
URI: https://jalbum.net/en/users/ctwist?t=1509977696067
 
Message: Script error
Line: 0
Char: 0
Code: 0
URI: https://platform.twitter.com/widgets.js
 
Message: 'Wicket' is undefined
Line: 123
Char: 1
Code: 0
URI: https://jalbum.net/en/users/ctwist?t=1509977696067
So maybe the simplest solution is to intercept any request from IE8 and show a simple page that instructs the user to try again in a proper browser. It is a waste of time to cater to an XP user who doesn't have another browser installed. However, allow an album to be viewed in IE8, since it may be OK (e.g. Mirage still works in IE8).
AnCa

Posts: 2,101
Registered: 25-Mar-2005
Re: Doesn't render in IE8
Posted: 06-Nov-2017 15:33   in response to: ctwist in response to: ctwist
  Click to reply to this thread Reply
ctwist wrote:
My home page ctwist.jalbum.net has a similar problem in IE8codeMessage: 'Wicket' is undefined
Yes, we tried some random URLs on jalbum.net with IE8 and none worked... :(
We send a clear message to IE8 users. :)
jGromit

Posts: 33,186
Registered: 31-Jan-2006
Re: Doesn't render in IE8
Posted: 06-Nov-2017 15:41   in response to: ctwist in response to: ctwist
  Click to reply to this thread Reply
ctwist wrote:
...Mirage still works in IE8....

Just curious, but how does Mirage handle MP4's? I believe that most of the skins that play MP4's have now dropped back to using a simple <video> tag, but that's a complete non-starter in IE8.
ctwist

Posts: 1,412
Registered: 27-Sep-2003
Re: Doesn't render in IE8
Posted: 06-Nov-2017 15:53   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
I play MP4's in VideoJS The latest version is 6, but I use version 5 to ensure IE8 compatibility. For my simple use of the player, version 5 is good, and bug fixes are still being applied. VideoJS uses a video tag where it is supported, but it uses Flash to play MP4's in IE8.

At some point, I will have to drop support for Flash & IE8, but for now I just leave the workarounds in place; it requires very little effort to maintain this.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums