This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 22 - Pages: 2 [ 1 2 | Next ] - Last Post: 19-Jul-2017 13:10 Last Post By: Laza
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Why is a web location red?
Posted: 15-Jul-2017 14:06
 
  Click to reply to this thread Reply
I have added a map as a web location to my Photoblogger test album.

The background of the weblocation image is red instead of the original white map.

What do I wrongly?
jGromit

Posts: 7,269
Registered: 31-Jan-2006
Re: Why is a web location red?
Posted: 15-Jul-2017 14:43   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
Attachment ss003159.png (447.7 KB)
No problem here. See screenshot.

For some reason, the image in your album is in the CMYK color space instead of sRGB. I don't know why - when I enter the same URL for the web page, jAlbum picks up a "clean" JPG, in the correct color space. Did you enter a URL for the representing image manually?
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: Why is a web location red?
Posted: 15-Jul-2017 16:10   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
I just dropped the url from the browser address box on the jAlbum Explorer.
I did the same with my Tiger test album and there it is OK.

Edited by: AndreWolff on 15-Jul-2017 16:25
jGromit

Posts: 7,269
Registered: 31-Jan-2006
Re: Why is a web location red?
Posted: 15-Jul-2017 16:34   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
I can't reproduce the error. Anyone else?
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: Why is a web location red?
Posted: 15-Jul-2017 16:59   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
I did add the website again, but now via a new page. Now it is not red, but the window is smaller, why?
See my Photobloger test album.
Laza

Posts: 2,209
Registered: 6-Sep-2005
Re: Why is a web location red?
Posted: 17-Jul-2017 08:33   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
The first is the slide image (1200x1117), while the second is the normal thumbnail (86x80px). You might want to bump up the thumbnail size - 225x80 is way too small for Photoblogger. The default is 300x300. The redness is probably caused by a wrong Java version. Please remove the red file from the slides folder and regenerate the album with the latest jAlbum.
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: Why is a web location red?
Posted: 17-Jul-2017 16:25   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
The redness is probably caused by a wrong Java version. Please remove the red file from the slides folder and regenerate the album with the latest jAlbum.
I updated to jAlbum 14.0.7, removed the weblocations from the Explorer, added the weblocation again via drag and drop, removed the images fronm the slides directory and did a Make.

The result is still red on a PC: see my test album
On my iPad it is black!

Edited by: AndreWolff on 17-Jul-2017 16:37
Laza

Posts: 2,209
Registered: 6-Sep-2005
Re: Why is a web location red?
Posted: 17-Jul-2017 19:04   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
You are a magician. :) Whatever I tried I could not reproduce this error with the same URL.
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: Why is a web location red?
Posted: 17-Jul-2017 19:56   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Attachment PhotoBlogger.jap (8.7 KB)
Yes I did hear that earlier, see here.

But I am still not sure about the correct JAVA version.
The About box says jAlbum 14.0.7 JAVA 1.8 64 bit, is that the same as you see?

I did attach the project file, may that helps you.
jGromit

Posts: 7,269
Registered: 31-Jan-2006
Re: Why is a web location red?
Posted: 17-Jul-2017 20:54   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
You are a magician. :) Whatever I tried I could not reproduce this error with the same URL.

I tried everything I could think of, both in Win10 and macOS, and couldn't reproduce it, either. The resulting JPG is in the CMYK color space - that's why it's a mess. In Firefox and Chrome, it's mostly red - Safari just gives up completely, and displays solid black. I have no idea how it's even possible to make jAlbum produce a CMYK image. There's certainly no project setting that would do that.
Laza

Posts: 2,209
Registered: 6-Sep-2005
Re: Why is a web location red?
Posted: 19-Jul-2017 08:07   in response to: jGromit in response to: jGromit
 
  Click to reply to this thread Reply
I can imagine if you link to originals and enter the representing image manually you can achieve this. Or perhaps jAlbum picks the wrong representing image from WikiPedia sometimes? Anyway it's strange no one else but Andre can achieve this. There must be some "secret".
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: Why is a web location red?
Posted: 19-Jul-2017 09:39   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
I can imagine if you link to originals and enter the representing image manually you can achieve this.
I did not do that
Or perhaps jAlbum picks the wrong representing image from WikiPedia sometimes?
Could be, I can repair it by making a screen dump of the map at the website and next edit the image URL.

The map is not red if I add the same location again via drag and drop, but than the quality of the image is very bad, see the test album. How can I improve that?

I can't get the webloication displayed between the images where I dropped the web location. Is that impossible?
Laza

Posts: 2,209
Registered: 6-Sep-2005
Re: Why is a web location red?
Posted: 19-Jul-2017 10:37   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
The "Settings / Photoblogger / Advanced / Folder thumbnail size" variable is set to 86x80. Set this back to its default value: 600x420.
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: Why is a web location red?
Posted: 19-Jul-2017 11:20   in response to: Laza in response to: Laza
 
  Click to reply to this thread Reply
Laza wrote:
The "Settings / Photoblogger / Advanced / Folder thumbnail size" variable is set to 86x80. Set this back to its default value: 600x420.
I have already that setting, see attached screen shot, so it is caused by something else.

I did add also an image discussed in this thread. It shows here the caption correct below the thumbnail. The ListMetaData shoiws the same result as with other skins.
If I click on that image, the image is enlarged, but I see no navigation buttons to go back or go to the next slide. I like to see here also the caption. What should I do to see a caption and see navigation buttons?

If I make a test album with only the problem image, the caption is also displyaed wrongly, see here. Can you explain the difference?
Laza

Posts: 2,209
Registered: 6-Sep-2005
Re: Why is a web location red?
Posted: 19-Jul-2017 11:28   in response to: AndreWolff in response to: AndreWolff
 
  Click to reply to this thread Reply
Yes, unfortunately it seems the skin doesn't know the previous folder thumbnail size, so you need to remove that manually first from the output folder.
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums