Permlink Replies: 255 - Pages: 18 [ Previous | 1 ... 11 12 13 14 15 16 17 | Next ] - Last Post: 01-Jul-2017 23:34 Last Post By: davidekholm
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 17:52   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
Currently the democratic votes against allowing web locations in slides were more than those in favor of it. You can likely keep your code the way it is. If we allow web locations in slides in the future, your skin is one of the first ones to use it.
Democratic votes? I can't remember that you asked me to vote!!

You think apparently that if the same person repeats his objections in many similar posts that he represents a lot of people!
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:21   in response to: AndreWolff in response to: AndreWolff
  Click to reply to this thread Reply
AndreWolff wrote:
Democratic votes? I can't remember that you asked me to vote!!

You think apparently that if the same person repeats his objections in many similar posts that he represents a lot of people!


You got your one vote. I got my one vote. Others expressed their opinions (in various ways, some of them not here in the forum), and each got one vote.

If you really want to include a slide page that links to an external site, just add a JPG to the project and plant a link in the comment. Or create a skin-specific, image-specific variable to allow entry of a target URL for an image, then grab it and use it on your slide page in any way you like. That's been possible in jAlbum for many, many versions back. In fact, both Gromit and Matrix have had that for years, though Matrix doesn't use it for any slide images.

That way, it doesn't screw up things like image counters, thumbstrip links, and so on.
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:26   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
  • Fixed color issue with Nimbus look&feel

Looks good both in Windows and macOS.
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:28   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
I've now fixed the issue with missing EXIF image description comments. All in rc6.

Confirmed, working as it should. :)
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:39   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
On the question why .webloc files are generated to the output folder, although they are not used by the album. Here are the reasons:
  • I want to create minimal surprises for skins. All album objects should therefore have a backing File object (i.e. AlbumObject.getFile() should never return null). In case of Web locations, the getFile() call simply returns the .webloc file.

Hmmm.... When would an ao.getFile() ever be looking at the output directory?

* The .webloc files can be used to recreate the representing images and target URLs in case one wants to use a generated album to recreate an album project.

That part, I do understand. A rare case, to be sure, but without that, you'd have to reconstruct the webloc from the .info file in the lifeboat, and you might not have the lifeboat.
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:46   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
You have the code to make webloc slide images and it was working fine, so why is it not possible to add a check-mark Generate webloc images ?
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:49   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
  • The .webloc files can be used to recreate the representing images and target URLs in case one wants to use a generated album to recreate an album project.
What are the representing images if you do not generate webloc images?
davidekholm

Posts: 3,575
Registered: 18-Oct-2002
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:53   in response to: AndreWolff in response to: AndreWolff
  Click to reply to this thread Reply
AndreWolff wrote:
davidekholm wrote:
  • The .webloc files can be used to recreate the representing images and target URLs in case one wants to use a generated album to recreate an album project.
What are the representing images if you do not generate webloc images?

There are at least representing thumbnails that need the .webloc file for their generation. I personally lean towards allowing web locations in slide pages myself. Can others please bring your opinions!
davidekholm

Posts: 3,575
Registered: 18-Oct-2002
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:55   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
Anyone wanting to make their "home baked" web locations with the benefit of the clever (if I may say so) way the current web locations figure out the representing image, may directly use the WebLocation API
Simply create a WebLocation given a URL, then call findRepresentingImage()
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 18:58   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
I personally lean towards allowing web locations in slide pages myself. Can others please bring your opinions!

If you want to add it as an option, fine. Just don't force a skin to use them, or to have to generate its own array of album objects, simply to avoid them.

To me, slide pages for web locations reminds me of my local bank's website. You login, and there's a link marked Statements. You click on it, and it takes you to a page that says, "This is where you can get your statements," and there's a link marked Statements.
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 19:07   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
I personally lean towards allowing web locations in slide pages myself. Can others please bring your opinions!
Well you know my opinion, but with a a check-mark Generate webloc images you can please both parties!
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 19:09   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
Attachment bears2.jpg (31.4 KB)
jGromit wrote:
davidekholm wrote:
I've now fixed the issue with missing EXIF image description comments. All in rc6.

Confirmed, working as it should. :)


I take it back. If you choose EXIF Image Desc as a comment source, but the images don't contain that field, you get NullPointerExceptions.

Add the attached image to a Minimal project. Check Advanced > Metadata > Comment sources > EXIF Image Desc, then make an album.

Edit: In fact, just about any image, even something fresh from a modern DSLR, with full metadata.
AndreWolff

Posts: 1,715
Registered: 14-Dec-2007
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 19:30   in response to: davidekholm in response to: davidekholm
  Click to reply to this thread Reply
davidekholm wrote:
I've now fixed the issue with missing EXIF image description comments. All in rc6.
Where can I find rc6?
jGromit

Posts: 7,501
Registered: 31-Jan-2006
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 19:32   in response to: AndreWolff in response to: AndreWolff
  Click to reply to this thread Reply
davidekholm

Posts: 3,575
Registered: 18-Oct-2002
Re: jAlbum 14 beta for testing
Posted: 20-Jun-2017 20:35   in response to: jGromit in response to: jGromit
  Click to reply to this thread Reply
jGromit wrote:
jGromit wrote:
davidekholm wrote:
I've now fixed the issue with missing EXIF image description comments. All in rc6.

Confirmed, working as it should. :)

I take it back. If you choose EXIF Image Desc as a comment source, but the images don't contain that field, you get NullPointerExceptions.

Add the attached image to a Minimal project. Check Advanced > Metadata > Comment sources > EXIF Image Desc, then make an album.

Edit: In fact, just about any image, even something fresh from a modern DSLR, with full metadata.


Ah, now fixed. (same version number though)
Legend
Forum admins
Helpful Answer
Correct Answer

Point your RSS reader here for a feed of the latest messages in all forums