This skin has not been updated for over two years, and may not work with the current version of jAlbum.

Kristoffer Jelbring Kristoffer Jelbring
Install skin

You can also install the skin by unzipping this file into the skin folder.

Min. jAlbum version

Expo is a rich viewing experience that keeps your photos in the center of attention. No other disturbing elements, just your photos. The way it should be!

Navigate through your photos by clicking on the photo being viewed, or by using the built in keyboard navigation.

The expo skin is based on the Exposure image viewing plugin for jQuery (, which means it's suitable for handling large amounts of photos.

Multi-language albumsSupports foldersjAlbum widget supportTouch interface supportTransition effect(s)FreewareUses JavascriptHas slideshow
Oct 1, 2010
Last updated
Jan 18, 2012

Commercial use is allowed.
Modifications of the skin are allowed.


1.2.1 Jan 18, 2012 (current)

- Dutch user interface translation added. Big thanks to Freek Pol!

More skins made by Kristoffer Jelbring

Sign in to post
Write a comment
Post comment
Randy Jennings

Randy Jennings 3 years ago

Sorry I forgot to paste the code..... Myrtle Beach High School 2013

Randy Jennings

Randy Jennings 3 years ago

I really love this skin but am having trouble with the code below, can anyone help I have written this code to display a logo in Expo but I cannot make it work, I have placed the code in the "Include custom header box (HTML). the results are the text displays but all I get of the logo is a place holder with a ? in the box. I have placed the logo JPG in the album folder. here is the link to the slideshow

Urs Meyer

Urs Meyer 4 years ago

Hi Kris, thanks for this excellent skin. It gave me a good start to create my home page. I did some modification to fit my needs. Display thumbnails in several columns as example. best regards

steve clay

steve clay 4 years ago

Hi - I love this skin but the link to home page doesn't work for me. Any ideas why? Cheers.


ntn123 4 years ago

I did a album 2 year ago and i cant remember why i dont get the slideshow to work, i only see the first pic. I klick in the pageing control but it still dosent work, what am i doing wrong? // Nathan